Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск нескольких ФИО по фамилии. Возможен? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск нескольких ФИО по фамилии. Возможен? (Формулы/Formulas)
Поиск нескольких ФИО по фамилии. Возможен?
Leem Дата: Среда, 18.09.2019, 10:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго дня, друзья.

Возникла необходимость ячейку с поиском.
Есть список сотрудников и номера личных дел. Но сотрудники попадаются с одинаковыми фамилиями и разными инициалами.

Возможно ли с помощью функций реализовать поиск:
Пишу фамилию, и, если сотрудников несколько, то, находятся все сотрудники с этой фамилией?

Благодарю
К сообщению приложен файл: 0753899.xlsx(9.2 Kb)


Ктулху всех спасет
 
Ответить
СообщениеДоброго дня, друзья.

Возникла необходимость ячейку с поиском.
Есть список сотрудников и номера личных дел. Но сотрудники попадаются с одинаковыми фамилиями и разными инициалами.

Возможно ли с помощью функций реализовать поиск:
Пишу фамилию, и, если сотрудников несколько, то, находятся все сотрудники с этой фамилией?

Благодарю

Автор - Leem
Дата добавления - 18.09.2019 в 10:11
Nic70y Дата: Среда, 18.09.2019, 10:35 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03


ЯД(poison) 41001841029809
 
Ответить
Сообщениеhttp://www.excelworld.ru/board/vba/tricks/find_in_database/9-1-0-27

Автор - Nic70y
Дата добавления - 18.09.2019 в 10:35
Anis625 Дата: Четверг, 19.09.2019, 01:01 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 303
Репутация: 7 ±
Замечаний: 0% ±

Excel 2013
Leem,
можно так (инструкция в файле)
К сообщению приложен файл: 0753899.xlsb(15.6 Kb)
 
Ответить
СообщениеLeem,
можно так (инструкция в файле)

Автор - Anis625
Дата добавления - 19.09.2019 в 01:01
прохожий2019 Дата: Четверг, 19.09.2019, 01:33 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 8 ±
Замечаний: 0% ±

Excel 2016
PQ и немножко VBA [vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="Base"]}[Content],
    who = Excel.CurrentWorkbook(){[Name="second"]}[Content]{0}[Column1],
    to = Table.SelectRows(from, each Text.Contains([кто],who))[[кто]]
in
    to
[/vba]
К сообщению приложен файл: 0753899.xlsm(23.1 Kb)
 
Ответить
СообщениеPQ и немножко VBA [vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="Base"]}[Content],
    who = Excel.CurrentWorkbook(){[Name="second"]}[Content]{0}[Column1],
    to = Table.SelectRows(from, each Text.Contains([кто],who))[[кто]]
in
    to
[/vba]

Автор - прохожий2019
Дата добавления - 19.09.2019 в 01:33
AlexM Дата: Четверг, 19.09.2019, 08:58 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3885
Репутация: 976 ±
Замечаний: 0% ±

Excel 2003
в столбце В формула массива
Код
=ИНДЕКС(Список!A$1:A$99;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(A$1&" ";Список!A$1:A$99));СТРОКА(A$1:A$99));СТРОКА(A1)))

Чтобы убрать ошибку, используйте функцию ЕСЛИОШИБКА()
К сообщению приложен файл: 0753899_01.xlsx(9.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениев столбце В формула массива
Код
=ИНДЕКС(Список!A$1:A$99;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(A$1&" ";Список!A$1:A$99));СТРОКА(A$1:A$99));СТРОКА(A1)))

Чтобы убрать ошибку, используйте функцию ЕСЛИОШИБКА()

Автор - AlexM
Дата добавления - 19.09.2019 в 08:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск нескольких ФИО по фамилии. Возможен? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!