Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет повторяющихся сцепок в массиве напротив каждой строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет повторяющихся сцепок в массиве напротив каждой строк (Формулы/Formulas)
Подсчет повторяющихся сцепок в массиве напротив каждой строк
Olga2007 Дата: Воскресенье, 22.09.2019, 11:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Как посчитать формулой в массиве повторяющиеся сцепки из всего массива напротив каждой строки, проверяя сцепку в этой строке.
К сообщению приложен файл: 8895932.xlsx(13.9 Kb)
 
Ответить
СообщениеКак посчитать формулой в массиве повторяющиеся сцепки из всего массива напротив каждой строки, проверяя сцепку в этой строке.

Автор - Olga2007
Дата добавления - 22.09.2019 в 11:22
прохожий2019 Дата: Воскресенье, 22.09.2019, 11:42 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 8 ±
Замечаний: 0% ±

Excel 2016
Код
=СУММПРОИЗВ(--($I$2:$I$21&$C$2:$C$21&$Q$2:$Q$21=I2&C2&Q2))
К сообщению приложен файл: 9494909.xlsx(14.9 Kb)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--($I$2:$I$21&$C$2:$C$21&$Q$2:$Q$21=I2&C2&Q2))

Автор - прохожий2019
Дата добавления - 22.09.2019 в 11:42
Olga2007 Дата: Воскресенье, 22.09.2019, 13:53 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата прохожий2019, 22.09.2019 в 11:42, в сообщении № 2 ()
=СУММПРОИЗВ(--($I$2:$I$21&$C$2:$C$21&$Q$2:$Q$21=I2&C2&Q2))

Волшебно. hands А чтобы сумму по столбцу N у таких сцепок посчитать есть формула? :shy:
И еще интересует вопрос, если из этих значений сделать сводную таблицу, то в в вычисляемое поле можно подобную формулу прописать для подсчета суммы по столбцу N и количества сцепок? А то если в массиве много значений, таблица долго грузится.
К сообщению приложен файл: __-__-.xlsx(22.9 Kb)


Сообщение отредактировал Olga2007 - Воскресенье, 22.09.2019, 17:22
 
Ответить
Сообщение
Цитата прохожий2019, 22.09.2019 в 11:42, в сообщении № 2 ()
=СУММПРОИЗВ(--($I$2:$I$21&$C$2:$C$21&$Q$2:$Q$21=I2&C2&Q2))

Волшебно. hands А чтобы сумму по столбцу N у таких сцепок посчитать есть формула? :shy:
И еще интересует вопрос, если из этих значений сделать сводную таблицу, то в в вычисляемое поле можно подобную формулу прописать для подсчета суммы по столбцу N и количества сцепок? А то если в массиве много значений, таблица долго грузится.

Автор - Olga2007
Дата добавления - 22.09.2019 в 13:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет повторяющихся сцепок в массиве напротив каждой строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!