Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать в массиве суммы и поставить не на каждой строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать в массиве суммы и поставить не на каждой строк (Формулы/Formulas)
Как посчитать в массиве суммы и поставить не на каждой строк
Olga2007 Дата: Вторник, 24.09.2019, 22:06 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Нужно посчитать в массиве по заданным совпадениям сумму столбца "кол-во", но вывести эту сумму только для строк, где нет искомого параметра.
К сообщению приложен файл: __-___-.xlsx(13.0 Kb)
 
Ответить
СообщениеНужно посчитать в массиве по заданным совпадениям сумму столбца "кол-во", но вывести эту сумму только для строк, где нет искомого параметра.

Автор - Olga2007
Дата добавления - 24.09.2019 в 22:06
krosav4ig Дата: Среда, 25.09.2019, 02:17 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2182
Репутация: 913 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Код
=ЕСЛИ(СУММ(СЧЁТЕСЛИ(H3;{"*Ардели*0,5*";"*Георгиевс*0,5*"}));;СУММ(СУММЕСЛИМН(I$3:I$23;C$3:C$23;C3;E$3:E$23;E3;H$3:H$23;{"*Ардели*0,5*";"*Георгиевс*0,5*"})))


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщение
Код
=ЕСЛИ(СУММ(СЧЁТЕСЛИ(H3;{"*Ардели*0,5*";"*Георгиевс*0,5*"}));;СУММ(СУММЕСЛИМН(I$3:I$23;C$3:C$23;C3;E$3:E$23;E3;H$3:H$23;{"*Ардели*0,5*";"*Георгиевс*0,5*"})))

Автор - krosav4ig
Дата добавления - 25.09.2019 в 02:17
Olga2007 Дата: Среда, 25.09.2019, 15:59 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
[Перевод / Translate]
=ЕСЛИ(СУММ(СЧЁТЕСЛИ(H3;{"*Ардели*0,5*";"*Георгиевс*0,5*"}));;СУММ(СУММЕСЛИМН(I$3:I$23;C$3:C$23;C3;E$3:E$23;E3;H$3:H$23;{"*Ардели*0,5*";"*Георгиевс*0,5*"})))

СПАСИБО! Работает! И как можно все знать! %)
 
Ответить
Сообщение
[Перевод / Translate]
=ЕСЛИ(СУММ(СЧЁТЕСЛИ(H3;{"*Ардели*0,5*";"*Георгиевс*0,5*"}));;СУММ(СУММЕСЛИМН(I$3:I$23;C$3:C$23;C3;E$3:E$23;E3;H$3:H$23;{"*Ардели*0,5*";"*Георгиевс*0,5*"})))

СПАСИБО! Работает! И как можно все знать! %)

Автор - Olga2007
Дата добавления - 25.09.2019 в 15:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать в массиве суммы и поставить не на каждой строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!