Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение первого и последнего значения в списке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение первого и последнего значения в списке (Формулы/Formulas)
Определение первого и последнего значения в списке
JK Дата: Понедельник, 30.09.2019, 13:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день уважаемые форумчане!
Необходимо выводить в нужной ячейке для анализа первое и последнее значение списка после фильтрации по определенным условиям.
Хотел применить
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ

но среди номеров этой функции есть только МАКС и МИН, а необходимо первое и последнее значение.
Как это можно сделать?

Заранее благодарю за уделенное время этой теме!
К сообщению приложен файл: example_1.xlsx(17.0 Kb)


Сообщение отредактировал JK - Понедельник, 30.09.2019, 14:17
 
Ответить
СообщениеДобрый день уважаемые форумчане!
Необходимо выводить в нужной ячейке для анализа первое и последнее значение списка после фильтрации по определенным условиям.
Хотел применить
Код
=ПРОМЕЖУТОЧНЫЕ.ИТОГИ

но среди номеров этой функции есть только МАКС и МИН, а необходимо первое и последнее значение.
Как это можно сделать?

Заранее благодарю за уделенное время этой теме!

Автор - JK
Дата добавления - 30.09.2019 в 13:04
китин Дата: Понедельник, 30.09.2019, 13:07 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
JK, - Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеJK, - Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 30.09.2019 в 13:07
JK Дата: Понедельник, 30.09.2019, 14:25 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин,
Поправил - файл приложил к первому сообщению.
 
Ответить
Сообщениекитин,
Поправил - файл приложил к первому сообщению.

Автор - JK
Дата добавления - 30.09.2019 в 14:25
Nic70y Дата: Понедельник, 30.09.2019, 15:18 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
только МАКС и МИН
ну так у Вас так красиво даты расположены, почему бы не воспользоваться
Код
=ВПР(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(5;A5:A277);A5:C277;2;)
Код
=ВПР(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;A5:A277);A5:C277;2;)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
только МАКС и МИН
ну так у Вас так красиво даты расположены, почему бы не воспользоваться
Код
=ВПР(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(5;A5:A277);A5:C277;2;)
Код
=ВПР(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;A5:A277);A5:C277;2;)

Автор - Nic70y
Дата добавления - 30.09.2019 в 15:18
китин Дата: Понедельник, 30.09.2019, 15:44 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
волатильная, но не требует сортировки
начало периода
Код
=СМЕЩ($A$4;ПОИСКПОЗ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(5;$A$4:$A$1000);$A$4:$A$1000;0)-1;1;;)

конец периода

Код
=СМЕЩ($A$4;ПОИСКПОЗ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;$A$4:$A$1000);$A$4:$A$1000;0)-1;1;;)
К сообщению приложен файл: 5619218.xlsx(17.7 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеволатильная, но не требует сортировки
начало периода
Код
=СМЕЩ($A$4;ПОИСКПОЗ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(5;$A$4:$A$1000);$A$4:$A$1000;0)-1;1;;)

конец периода

Код
=СМЕЩ($A$4;ПОИСКПОЗ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(4;$A$4:$A$1000);$A$4:$A$1000;0)-1;1;;)

Автор - китин
Дата добавления - 30.09.2019 в 15:44
Nic70y Дата: Понедельник, 30.09.2019, 16:38 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
Игорь, так мои формулы дадут тот же результат.


ЯД(poison) 41001841029809
 
Ответить
СообщениеИгорь, так мои формулы дадут тот же результат.

Автор - Nic70y
Дата добавления - 30.09.2019 в 16:38
JK Дата: Понедельник, 30.09.2019, 17:23 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Благодарю всех за представленные варианты решений!
 
Ответить
СообщениеБлагодарю всех за представленные варианты решений!

Автор - JK
Дата добавления - 30.09.2019 в 17:23
китин Дата: Вторник, 01.10.2019, 08:05 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
дадут тот же результат.

Коля дык я и не спорю. просто захотелось поизвращаться со СМЕЩ


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
дадут тот же результат.

Коля дык я и не спорю. просто захотелось поизвращаться со СМЕЩ

Автор - китин
Дата добавления - 01.10.2019 в 08:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение первого и последнего значения в списке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!