Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести имя работника из табеля учета в бланк выручка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести имя работника из табеля учета в бланк выручка (Формулы/Formulas)
Вывести имя работника из табеля учета в бланк выручка
Monach Дата: Вторник, 01.10.2019, 14:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Прошу помощи в решении задачки.
Есть бланк выручки, куда ежедневно вносится сумма продаж по магазину. Есть Табель учета времени сотрудников, где указывается количество отработанных часов за смену. В магазине 3 кассира, которые меняются.
Хочу сделать так, чтобы в бланке выручка напротив даты отображалось имя кассира, который закрыл смену.
Нужно сделать так, чтобы таблицы делали проверку по дате, и выводило имя того сотрудника, который работал в этот день.
Спасибо заранее!
К сообщению приложен файл: 6861360.xlsx(29.8 Kb)


Сообщение отредактировал Monach - Вторник, 01.10.2019, 14:35
 
Ответить
СообщениеДобрый день!
Прошу помощи в решении задачки.
Есть бланк выручки, куда ежедневно вносится сумма продаж по магазину. Есть Табель учета времени сотрудников, где указывается количество отработанных часов за смену. В магазине 3 кассира, которые меняются.
Хочу сделать так, чтобы в бланке выручка напротив даты отображалось имя кассира, который закрыл смену.
Нужно сделать так, чтобы таблицы делали проверку по дате, и выводило имя того сотрудника, который работал в этот день.
Спасибо заранее!

Автор - Monach
Дата добавления - 01.10.2019 в 14:28
китин Дата: Вторник, 01.10.2019, 15:28 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а вдруг получилось?
Код
=ИНДЕКС($F$6:$F$19;ПОИСКПОЗ(1=1;($E$6:$E$19="Кассир")*(ИНДЕКС($Z$6:$BD$19;;ПОИСКПОЗ($E24;$Z$5:$BD$5;0)))<>0;0))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 9664446.xlsx(30.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа вдруг получилось?
Код
=ИНДЕКС($F$6:$F$19;ПОИСКПОЗ(1=1;($E$6:$E$19="Кассир")*(ИНДЕКС($Z$6:$BD$19;;ПОИСКПОЗ($E24;$Z$5:$BD$5;0)))<>0;0))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 01.10.2019 в 15:28
Nic70y Дата: Вторник, 01.10.2019, 17:21 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5687
Репутация: 1248 ±
Замечаний: 0% ±

ru13;10;03
не массивные варианты
Код
=ИНДЕКС(F$6:F$19;ПОИСКПОЗ(1;ИНДЕКС(((Z$6:BD$19)*(E$6:E$19="Кассир"))^0;;ПОИСКПОЗ(E24;Z$5:BD$5;));))
Код
=ИНДЕКС(F$6:F$19;ПОИСКПОЗ(1;ИНДЕКС(((Z$6:BD$19)*(E$6:E$19="Кассир"))^0;;ДЕНЬ(E24));))
Код
=ИНДЕКС(F$6:F$19;ПОИСКПОЗ(1;ИНДЕКС(((Z$6:BD$19)*(E$6:E$19="Кассир"))^0;;СТРОКА(G1));))


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Вторник, 01.10.2019, 17:26
 
Ответить
Сообщениене массивные варианты
Код
=ИНДЕКС(F$6:F$19;ПОИСКПОЗ(1;ИНДЕКС(((Z$6:BD$19)*(E$6:E$19="Кассир"))^0;;ПОИСКПОЗ(E24;Z$5:BD$5;));))
Код
=ИНДЕКС(F$6:F$19;ПОИСКПОЗ(1;ИНДЕКС(((Z$6:BD$19)*(E$6:E$19="Кассир"))^0;;ДЕНЬ(E24));))
Код
=ИНДЕКС(F$6:F$19;ПОИСКПОЗ(1;ИНДЕКС(((Z$6:BD$19)*(E$6:E$19="Кассир"))^0;;СТРОКА(G1));))

Автор - Nic70y
Дата добавления - 01.10.2019 в 17:21
Monach Дата: Вторник, 01.10.2019, 17:31 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Выражаю огромную благодарность за помощь!
Спасибо огромное!
Подскажите, пожалуйста, где можно на примерах изучить такие приемы?
 
Ответить
СообщениеДобрый день!
Выражаю огромную благодарность за помощь!
Спасибо огромное!
Подскажите, пожалуйста, где можно на примерах изучить такие приемы?

Автор - Monach
Дата добавления - 01.10.2019 в 17:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести имя работника из табеля учета в бланк выручка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!