Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет фактически отработанного времени по данным из СКД - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет фактически отработанного времени по данным из СКД (Формулы/Formulas)
Подсчет фактически отработанного времени по данным из СКД
ksana78 Дата: Пятница, 04.10.2019, 12:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, Не закидывайте меня пожалуйста камнями, знаю что тема затертая, но я не сильна в построении формул, а очень надо. Есть выгрузка из СКД с временем входа и выхода сотрудников, нужно посчитать фактически отработанное время за дату. Данных очень много и поэтому считать вручную не получится физически. Во вложенном файле слева пример как нужно чтобы выглядел отчет. Надеюсь на ваше понимание и помощь.
К сообщению приложен файл: 0073352.xlsx(11.2 Kb)
 
Ответить
СообщениеЗдравствуйте, Не закидывайте меня пожалуйста камнями, знаю что тема затертая, но я не сильна в построении формул, а очень надо. Есть выгрузка из СКД с временем входа и выхода сотрудников, нужно посчитать фактически отработанное время за дату. Данных очень много и поэтому считать вручную не получится физически. Во вложенном файле слева пример как нужно чтобы выглядел отчет. Надеюсь на ваше понимание и помощь.

Автор - ksana78
Дата добавления - 04.10.2019 в 12:19
dude Дата: Пятница, 04.10.2019, 15:32 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 161
Репутация: 22 ±
Замечаний: 0% ±

2016
для доп столбца
Код
=ЕСЛИ(И(E2=$F$1;B2=B3;ЦЕЛОЕ(D3)<>ЦЕЛОЕ(D2));1-ОСТАТ(D2;1);)+ЕСЛИОШИБКА(ЕСЛИ(И(E2=$G$1;B2=B1;ЦЕЛОЕ(D1)<>ЦЕЛОЕ(D2));ОСТАТ(D2;1););)+ЕСЛИ(И(E2=$F$1;B2=B3;ЦЕЛОЕ(D3)=ЦЕЛОЕ(D2));D3-D2;)
К сообщению приложен файл: 2045089.xlsx(12.2 Kb)
 
Ответить
Сообщениедля доп столбца
Код
=ЕСЛИ(И(E2=$F$1;B2=B3;ЦЕЛОЕ(D3)<>ЦЕЛОЕ(D2));1-ОСТАТ(D2;1);)+ЕСЛИОШИБКА(ЕСЛИ(И(E2=$G$1;B2=B1;ЦЕЛОЕ(D1)<>ЦЕЛОЕ(D2));ОСТАТ(D2;1););)+ЕСЛИ(И(E2=$F$1;B2=B3;ЦЕЛОЕ(D3)=ЦЕЛОЕ(D2));D3-D2;)

Автор - dude
Дата добавления - 04.10.2019 в 15:32
ksana78 Дата: Понедельник, 07.10.2019, 09:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
dude, Спасибо, что откликнулись. все работает. Только может еще подскажете, как результат перенести на другой лист в этой же книге, чтобы можно было подставлять данные?
 
Ответить
Сообщениеdude, Спасибо, что откликнулись. все работает. Только может еще подскажете, как результат перенести на другой лист в этой же книге, чтобы можно было подставлять данные?

Автор - ksana78
Дата добавления - 07.10.2019 в 09:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет фактически отработанного времени по данным из СКД (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!