Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать уникальные значения с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать уникальные значения с условием (Формулы/Formulas)
Как посчитать уникальные значения с условием
svarosh Дата: Понедельник, 07.10.2019, 10:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, нужно посчитать уникальные ID входа в конкретном промежутке времени (с 9 часов до 9:59).
Состряпал вроде формулу
Код
=СУММ(--(ПОИСКПОЗ($A$2:$A$23;$A$2:$A$23;0)=СТРОКА(A2:A23)-1)*($B$2:B23>=$B$13)*($B$2:$B$23<=$B$22))

но он показывает Н/Д, я предполагаю, что это из-за наличия пустых строк в столбце A, но все не могу догадаться, как доработать эту формулу. %)

Подскажите, пожалуйста, варианты. Файл прилагаю.
К сообщению приложен файл: 4059851.xls(32.0 Kb)


Сообщение отредактировал svarosh - Понедельник, 07.10.2019, 21:46
 
Ответить
СообщениеДобрый день, нужно посчитать уникальные ID входа в конкретном промежутке времени (с 9 часов до 9:59).
Состряпал вроде формулу
Код
=СУММ(--(ПОИСКПОЗ($A$2:$A$23;$A$2:$A$23;0)=СТРОКА(A2:A23)-1)*($B$2:B23>=$B$13)*($B$2:$B$23<=$B$22))

но он показывает Н/Д, я предполагаю, что это из-за наличия пустых строк в столбце A, но все не могу догадаться, как доработать эту формулу. %)

Подскажите, пожалуйста, варианты. Файл прилагаю.

Автор - svarosh
Дата добавления - 07.10.2019 в 10:38
китин Дата: Понедельник, 07.10.2019, 11:25 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5882
Репутация: 914 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
svarosh, - Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеsvarosh, - Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 07.10.2019 в 11:25
svarosh Дата: Понедельник, 07.10.2019, 21:48 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, спасибо, оформил
 
Ответить
Сообщениекитин, спасибо, оформил

Автор - svarosh
Дата добавления - 07.10.2019 в 21:48
svarosh Дата: Понедельник, 07.10.2019, 22:51 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Не актуально, разобрался самостоятельно.
Просто нужно было добавить ещё
Код
ЕСЛИОШИБКА()


Это массив и окончательное выражение выглядит так:
Код
{=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ($A$2:$A$23;$A$2:$A$23;0);-1)=СТРОКА(A2:A23)-1)*($B$2:B23>=$B$13)*($B$2:$B$23<=$B$22))}


Считает корректно, и пустоты не помеха.
 
Ответить
СообщениеНе актуально, разобрался самостоятельно.
Просто нужно было добавить ещё
Код
ЕСЛИОШИБКА()


Это массив и окончательное выражение выглядит так:
Код
{=СУММ(--(ЕСЛИОШИБКА(ПОИСКПОЗ($A$2:$A$23;$A$2:$A$23;0);-1)=СТРОКА(A2:A23)-1)*($B$2:B23>=$B$13)*($B$2:$B$23<=$B$22))}


Считает корректно, и пустоты не помеха.

Автор - svarosh
Дата добавления - 07.10.2019 в 22:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать уникальные значения с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!