Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление букв из конкретных ячеек и их суммирование - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление букв из конкретных ячеек и их суммирование (Формулы/Formulas)
Удаление букв из конкретных ячеек и их суммирование
jokzZziiiii Дата: Вторник, 08.10.2019, 08:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет! Задача такая: есть таблица, в колонки ИТОГО 1 и ИТОГО 2 нужно посчитать сумму ставок под буквами: KOP + LMC + EPD. Можно ли как-то оптимизировать процесс чтобы удалить буквы из ячеек без макроса ну и в итоге просуммировать всю таблицу. Приведена только часть таблица, оригинальничая состоит из 3-х - 5-ти тысяч строк. И, как вы видите в столбце ставка количество строк может быть разное на разное направление (Москва - Владивосток 8 строк, Москва - находка 10 строк), но, независимо от этого всегда складываются только три значения KOP + LMC + EPD.
К сообщению приложен файл: 0647710.xlsx(10.7 Kb)
 
Ответить
СообщениеВсем привет! Задача такая: есть таблица, в колонки ИТОГО 1 и ИТОГО 2 нужно посчитать сумму ставок под буквами: KOP + LMC + EPD. Можно ли как-то оптимизировать процесс чтобы удалить буквы из ячеек без макроса ну и в итоге просуммировать всю таблицу. Приведена только часть таблица, оригинальничая состоит из 3-х - 5-ти тысяч строк. И, как вы видите в столбце ставка количество строк может быть разное на разное направление (Москва - Владивосток 8 строк, Москва - находка 10 строк), но, независимо от этого всегда складываются только три значения KOP + LMC + EPD.

Автор - jokzZziiiii
Дата добавления - 08.10.2019 в 08:19
Nic70y Дата: Вторник, 08.10.2019, 08:54 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
формула массива
Код
=ЕСЛИ($E6="";"";СУММ(ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК($F6:ИНДЕКС($F7:$F$18000;ПОИСКПОЗ("*";$E7:$E$18000;)-1);"KOP_LMC_EPD"));G6:ИНДЕКС(G7:G$18000;ПОИСКПОЗ("*";$E7:$E$18000;)-1));" ";ПОВТОР(" ";15));15);0)))
а так же см. ячейку E64.
К сообщению приложен файл: 6016133.xlsx(15.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИ($E6="";"";СУММ(ЕСЛИОШИБКА(--ЛЕВБ(ПОДСТАВИТЬ(ЕСЛИ(ЕЧИСЛО(ПОИСК($F6:ИНДЕКС($F7:$F$18000;ПОИСКПОЗ("*";$E7:$E$18000;)-1);"KOP_LMC_EPD"));G6:ИНДЕКС(G7:G$18000;ПОИСКПОЗ("*";$E7:$E$18000;)-1));" ";ПОВТОР(" ";15));15);0)))
а так же см. ячейку E64.

Автор - Nic70y
Дата добавления - 08.10.2019 в 08:54
jokzZziiiii Дата: Вторник, 08.10.2019, 10:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, я сделал черещ формул
Код
=ПСТР (A1;1;3)

Соответственно, эта формула в ячейку вставляет первые 3 знака из А1. У меня вопрос такой. Можно ли как-то "оптимизировать" эту формулу, потому что иногда в ячейке бывает, например, 1458 USD, ну, вообщем, нужно вставить либо первый 3 знака, либо первые 4
 
Ответить
СообщениеNic70y, я сделал черещ формул
Код
=ПСТР (A1;1;3)

Соответственно, эта формула в ячейку вставляет первые 3 знака из А1. У меня вопрос такой. Можно ли как-то "оптимизировать" эту формулу, потому что иногда в ячейке бывает, например, 1458 USD, ну, вообщем, нужно вставить либо первый 3 знака, либо первые 4

Автор - jokzZziiiii
Дата добавления - 08.10.2019 в 10:21
Nic70y Дата: Вторник, 08.10.2019, 10:55 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Код
=--ЛЕВБ(G6;ПОИСК(" ";G6)-1)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=--ЛЕВБ(G6;ПОИСК(" ";G6)-1)

Автор - Nic70y
Дата добавления - 08.10.2019 в 10:55
jokzZziiiii Дата: Вторник, 08.10.2019, 14:20 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, Что за ЛЕВБ?
 
Ответить
СообщениеNic70y, Что за ЛЕВБ?

Автор - jokzZziiiii
Дата добавления - 08.10.2019 в 14:20
Nic70y Дата: Вторник, 08.10.2019, 14:34 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03


ЯД(poison) 41001841029809
 
Ответить
СообщениеЛЕВБ

Автор - Nic70y
Дата добавления - 08.10.2019 в 14:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление букв из конкретных ячеек и их суммирование (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!