Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух столбцов и копирование из третьего - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух столбцов и копирование из третьего (Формулы/Formulas)
Сравнение двух столбцов и копирование из третьего
Gr-eY Дата: Среда, 09.10.2019, 10:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго дня всем! Очень сильно и срочно нужна ваша профессиональная помощь! Помогите пожалуйста с решением следующей проблемы: в столбце "G" есть перечень товаров, в "H" - их класс. Нужно в столбце "С" найти соответствующую позиция и в "D" проставить соответствующий класс из "H". В "G" более 6 тыс. строк, крыжить вручную - не вариант. В файле-примере намного меньше строк, т.к. оригинал файла - по размерам не проходит...
Есть ВПР
Код
=ВПР(C2;$G$3:$H$6064;2)
, но почему-то сравнивает (точнее не ищет корректно, для примера выделил ячейки красным цветом) совпадения в столбцах наименований. Помогите пожалуйста!
Может есть какие-то более простые решения....
К сообщению приложен файл: 8514610.xlsx(61.1 Kb)
 
Ответить
СообщениеДоброго дня всем! Очень сильно и срочно нужна ваша профессиональная помощь! Помогите пожалуйста с решением следующей проблемы: в столбце "G" есть перечень товаров, в "H" - их класс. Нужно в столбце "С" найти соответствующую позиция и в "D" проставить соответствующий класс из "H". В "G" более 6 тыс. строк, крыжить вручную - не вариант. В файле-примере намного меньше строк, т.к. оригинал файла - по размерам не проходит...
Есть ВПР
Код
=ВПР(C2;$G$3:$H$6064;2)
, но почему-то сравнивает (точнее не ищет корректно, для примера выделил ячейки красным цветом) совпадения в столбцах наименований. Помогите пожалуйста!
Может есть какие-то более простые решения....

Автор - Gr-eY
Дата добавления - 09.10.2019 в 10:15
sanpai Дата: Среда, 09.10.2019, 10:52 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Заменил ВПР формулой:
Код
=ИНДЕКС($H$2:$H$10000;ПОИСКПОЗ(C2;$G$2:$G$10000;1))

Но некоторые подсвеченные позиции все равно не ищет)
 
Ответить
СообщениеЗаменил ВПР формулой:
Код
=ИНДЕКС($H$2:$H$10000;ПОИСКПОЗ(C2;$G$2:$G$10000;1))

Но некоторые подсвеченные позиции все равно не ищет)

Автор - sanpai
Дата добавления - 09.10.2019 в 10:52
Gr-eY Дата: Среда, 09.10.2019, 11:02 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Но некоторые подсвеченные позиции все равно не ищет)


Вот в том-то и дело ((( Почему - непонятно...
 
Ответить
Сообщение
Но некоторые подсвеченные позиции все равно не ищет)


Вот в том-то и дело ((( Почему - непонятно...

Автор - Gr-eY
Дата добавления - 09.10.2019 в 11:02
amfor Дата: Среда, 09.10.2019, 11:49 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 51 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Не ищет потому что по разному написано(лишние пробелы в написании)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый день. Не ищет потому что по разному написано(лишние пробелы в написании)

Автор - amfor
Дата добавления - 09.10.2019 в 11:49
Gr-eY Дата: Среда, 09.10.2019, 12:31 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Не ищет потому что по разному написано(лишние пробелы в написании)

Да, наткнулся на это, уже когда создал тему.... Убрал лишние пробелы, текст в обоих столбцах отформатировал и сделал единым шрифтом, но проблема все равно не решилась на 100%.
Я уже ХЗ что делать с этим списком... ((((
 
Ответить
Сообщение
Добрый день. Не ищет потому что по разному написано(лишние пробелы в написании)

Да, наткнулся на это, уже когда создал тему.... Убрал лишние пробелы, текст в обоих столбцах отформатировал и сделал единым шрифтом, но проблема все равно не решилась на 100%.
Я уже ХЗ что делать с этим списком... ((((

Автор - Gr-eY
Дата добавления - 09.10.2019 в 12:31
amfor Дата: Среда, 09.10.2019, 12:47 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 51 ±
Замечаний: 0% ±

Excel 2016
В том файле что Вы выложили пробелы не убраны


Семь бед - один RESET.
 
Ответить
СообщениеВ том файле что Вы выложили пробелы не убраны

Автор - amfor
Дата добавления - 09.10.2019 в 12:47
Gr-eY Дата: Среда, 09.10.2019, 14:40 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Не ищет потому что по разному написано(лишние пробелы в написании)

Спасибо Вам! И всем остальным тоже! Ответ ( ...а ларчик то открывался просто!) был в том, что в одном из столбцов реально были лишние пробелы, в т.ч. и в конце текстовой строки.
 
Ответить
Сообщение
Добрый день. Не ищет потому что по разному написано(лишние пробелы в написании)

Спасибо Вам! И всем остальным тоже! Ответ ( ...а ларчик то открывался просто!) был в том, что в одном из столбцов реально были лишние пробелы, в т.ч. и в конце текстовой строки.

Автор - Gr-eY
Дата добавления - 09.10.2019 в 14:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух столбцов и копирование из третьего (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!