Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВЫБОР ОДИНАКОВЫХ В ТАБЛИЦУ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВЫБОР ОДИНАКОВЫХ В ТАБЛИЦУ (Формулы/Formulas)
ВЫБОР ОДИНАКОВЫХ В ТАБЛИЦУ
MIXAMI Дата: Воскресенье, 20.10.2019, 17:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Я совсем чайник в EXCEL. Как мне сделать чтобы из списка выбирались одинаковые позиции в каждую строку. Я делал с помощью ВПР и ИНДЕКС ПОИСКПОЗ они выделять те строки где есть эти значения и получаются вот такие пробелы. А мне надо чтобы список был в каждой строчке.
 
Ответить
СообщениеЗдравствуйте!
Я совсем чайник в EXCEL. Как мне сделать чтобы из списка выбирались одинаковые позиции в каждую строку. Я делал с помощью ВПР и ИНДЕКС ПОИСКПОЗ они выделять те строки где есть эти значения и получаются вот такие пробелы. А мне надо чтобы список был в каждой строчке.

Автор - MIXAMI
Дата добавления - 20.10.2019 в 17:54
Светлый Дата: Воскресенье, 20.10.2019, 18:31 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1339
Репутация: 333 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Не помешал бы файл. А остальные одинаковые надо выбирать?


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗдравствуйте!
Не помешал бы файл. А остальные одинаковые надо выбирать?

Автор - Светлый
Дата добавления - 20.10.2019 в 18:31
MIXAMI Дата: Воскресенье, 20.10.2019, 18:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Нет просто сгруппировать одинаковые наименования в одну таблицу. Как на картинке.
 
Ответить
СообщениеЗдравствуйте!
Нет просто сгруппировать одинаковые наименования в одну таблицу. Как на картинке.

Автор - MIXAMI
Дата добавления - 20.10.2019 в 18:35
MIXAMI Дата: Воскресенье, 20.10.2019, 18:40 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Т.е чтобы не было пробела.
Берём "СОЛЬ" и получаем вседанные с таблицы. 4,7,8 строки чтобы были в таблице без пробела.
Находит 4, потом 7, вставляет в следующую строку. А то при ВПР и ИНДЕКС ПОИСКПОЗ он прсто выделяет строки где нашёл "СОЛЬ" и всё. Получается большое расстояние между первой найденной позицией и последующей.
 
Ответить
СообщениеТ.е чтобы не было пробела.
Берём "СОЛЬ" и получаем вседанные с таблицы. 4,7,8 строки чтобы были в таблице без пробела.
Находит 4, потом 7, вставляет в следующую строку. А то при ВПР и ИНДЕКС ПОИСКПОЗ он прсто выделяет строки где нашёл "СОЛЬ" и всё. Получается большое расстояние между первой найденной позицией и последующей.

Автор - MIXAMI
Дата добавления - 20.10.2019 в 18:40
MIXAMI Дата: Воскресенье, 20.10.2019, 19:56 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Видимо это непреодолимая задача(((((
 
Ответить
СообщениеВидимо это непреодолимая задача(((((

Автор - MIXAMI
Дата добавления - 20.10.2019 в 19:56
Pelena Дата: Воскресенье, 20.10.2019, 20:37 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
На картинке трудно писать формулы
Цитата Светлый, 20.10.2019 в 18:31, в сообщении № 2 ()
Не помешал бы файл


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНа картинке трудно писать формулы
Цитата Светлый, 20.10.2019 в 18:31, в сообщении № 2 ()
Не помешал бы файл

Автор - Pelena
Дата добавления - 20.10.2019 в 20:37
MIXAMI Дата: Воскресенье, 20.10.2019, 21:26 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Да я понимаю.
Но тут же всё видно. Как из таблицы А1:В34, выбрать все значения "СОЛЬ" с показателями и сгруппировать их как указано в таблице G2:J4.
Нужна формула для выборки всех одинаковых значений (ну как "СОЛЬ" например с его показателями) в таблицу
 
Ответить
СообщениеДа я понимаю.
Но тут же всё видно. Как из таблицы А1:В34, выбрать все значения "СОЛЬ" с показателями и сгруппировать их как указано в таблице G2:J4.
Нужна формула для выборки всех одинаковых значений (ну как "СОЛЬ" например с его показателями) в таблицу

Автор - MIXAMI
Дата добавления - 20.10.2019 в 21:26
Pelena Дата: Воскресенье, 20.10.2019, 21:43 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула массива для G2
Код
=ИНДЕКС(A$1:A$34;НАИМЕНЬШИЙ(ЕСЛИ($A$1:$A$34="Соль";СТРОКА($A$1:$A$34));СТРОКА(A1)))

Но если надо просто сгруппировать, проще отсортировать первый столбец


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива для G2
Код
=ИНДЕКС(A$1:A$34;НАИМЕНЬШИЙ(ЕСЛИ($A$1:$A$34="Соль";СТРОКА($A$1:$A$34));СТРОКА(A1)))

Но если надо просто сгруппировать, проще отсортировать первый столбец

Автор - Pelena
Дата добавления - 20.10.2019 в 21:43
MIXAMI Дата: Воскресенье, 20.10.2019, 22:04 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ничего не понял.
Ну и на том спасибо! :(
 
Ответить
СообщениеНичего не понял.
Ну и на том спасибо! :(

Автор - MIXAMI
Дата добавления - 20.10.2019 в 22:04
Pelena Дата: Воскресенье, 20.10.2019, 22:13 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14761
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Ничего не понял

Как разобраться в работе сложной формулы?

Автор - Pelena
Дата добавления - 20.10.2019 в 22:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВЫБОР ОДИНАКОВЫХ В ТАБЛИЦУ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!