Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка из столбца в таблицу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка из столбца в таблицу (Формулы/Formulas)
Выборка из столбца в таблицу
Poligraf510 Дата: Понедельник, 21.10.2019, 12:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Есть столбец с числами, необходимо из него сделать выборку в таблицу как указано в примере. Заранее спасибо..
К сообщению приложен файл: 6497062.xlsx(8.7 Kb)
 
Ответить
СообщениеДобрый день. Есть столбец с числами, необходимо из него сделать выборку в таблицу как указано в примере. Заранее спасибо..

Автор - Poligraf510
Дата добавления - 21.10.2019 в 12:20
Nic70y Дата: Понедельник, 21.10.2019, 12:43 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
как указано в примере
не очень то понятно.
ориентир однозначные числа?
могут повторяться, не?
и куча вопросов.


ЯД(poison) 41001841029809
 
Ответить
Сообщение
как указано в примере
не очень то понятно.
ориентир однозначные числа?
могут повторяться, не?
и куча вопросов.

Автор - Nic70y
Дата добавления - 21.10.2019 в 12:43
Poligraf510 Дата: Понедельник, 21.10.2019, 12:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ориентир может быть однозначным или двузначным, повторяться не могут
 
Ответить
СообщениеОриентир может быть однозначным или двузначным, повторяться не могут

Автор - Poligraf510
Дата добавления - 21.10.2019 в 12:52
Poligraf510 Дата: Понедельник, 21.10.2019, 13:22 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Постараюсь объяснить по другому. как только в столбце встречается цифра не четырехзначная, то она записывается в ячейку А1, а за ней в столбец А все четырехзначные цифры до того момента пока не дойдет до следующей не четырехзначной цифры, которая записывается я ячейку B1 и так далее, как в примере
 
Ответить
СообщениеПостараюсь объяснить по другому. как только в столбце встречается цифра не четырехзначная, то она записывается в ячейку А1, а за ней в столбец А все четырехзначные цифры до того момента пока не дойдет до следующей не четырехзначной цифры, которая записывается я ячейку B1 и так далее, как в примере

Автор - Poligraf510
Дата добавления - 21.10.2019 в 13:22
Russel Дата: Понедельник, 21.10.2019, 14:20 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1350
Репутация: 305 ±
Замечаний: 0% ±

Excel 2010
Допстолбцы + сводная таблица.
К сообщению приложен файл: 9483307.xlsx(14.8 Kb)


QIWI 9173973973
 
Ответить
СообщениеДопстолбцы + сводная таблица.

Автор - Russel
Дата добавления - 21.10.2019 в 14:20
Nic70y Дата: Понедельник, 21.10.2019, 14:31 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
массивная щапка
Код
=ИНДЕКС('Исходные данные'!$A$1:$A$18000;НАИМЕНЬШИЙ(ЕСЛИ('Исходные данные'!$A$1:$A$18000<1000;СТРОКА('Исходные данные'!$A$1:$A$18000));СТОЛБЕЦ()))
+
К сообщению приложен файл: 3223622.xlsx(10.1 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениемассивная щапка
Код
=ИНДЕКС('Исходные данные'!$A$1:$A$18000;НАИМЕНЬШИЙ(ЕСЛИ('Исходные данные'!$A$1:$A$18000<1000;СТРОКА('Исходные данные'!$A$1:$A$18000));СТОЛБЕЦ()))
+

Автор - Nic70y
Дата добавления - 21.10.2019 в 14:31
Poligraf510 Дата: Понедельник, 21.10.2019, 15:11 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное Russel (его способ я понял) и Nic70v (его способ для меня как темный лес) за решение проблемы. Все вроде работает
 
Ответить
СообщениеСпасибо огромное Russel (его способ я понял) и Nic70v (его способ для меня как темный лес) за решение проблемы. Все вроде работает

Автор - Poligraf510
Дата добавления - 21.10.2019 в 15:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка из столбца в таблицу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!