Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Почему не правильно округляется - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Почему не правильно округляется (Формулы/Formulas)
Почему не правильно округляется
AVI Дата: Вторник, 22.10.2019, 08:14 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 510
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
В файле пример.
Может я не прав, но мне кажется, что округление до десятых не правильно.
Или там какой-то другой принцип?
К сообщению приложен файл: 1250385.xlsx(8.0 Kb)
 
Ответить
СообщениеВ файле пример.
Может я не прав, но мне кажется, что округление до десятых не правильно.
Или там какой-то другой принцип?

Автор - AVI
Дата добавления - 22.10.2019 в 08:14
Nic70y Дата: Вторник, 22.10.2019, 08:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
Все правильно.нет не или


ЯД(poison) 41001841029809
 
Ответить
СообщениеВсе правильно.нет не или

Автор - Nic70y
Дата добавления - 22.10.2019 в 08:27
bmv98rus Дата: Вторник, 22.10.2019, 10:07 | Сообщение № 3
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
А почему Вам так кажется?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеА почему Вам так кажется?

Автор - bmv98rus
Дата добавления - 22.10.2019 в 10:07
AVI Дата: Вторник, 22.10.2019, 10:39 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 510
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, Разве 0,35 не должно округлиться до 0,4?
 
Ответить
Сообщениеbmv98rus, Разве 0,35 не должно округлиться до 0,4?

Автор - AVI
Дата добавления - 22.10.2019 в 10:39
Nic70y Дата: Вторник, 22.10.2019, 10:47 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
AVI, Вы округляете 0,347826086956522, а не 0,35
[p.s.]тема не для Excel - для математики[/p.s.]


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Вторник, 22.10.2019, 10:48
 
Ответить
СообщениеAVI, Вы округляете 0,347826086956522, а не 0,35
[p.s.]тема не для Excel - для математики[/p.s.]

Автор - Nic70y
Дата добавления - 22.10.2019 в 10:47
bmv98rus Дата: Вторник, 22.10.2019, 10:51 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
AVI, Скорее всего вы полагали, что округление идет последовательно от разряда к разряду по правилу математического округления, а это не так. И как отмечено выше 0,3478 меньше 0,35 и округляется до 0,3.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеAVI, Скорее всего вы полагали, что округление идет последовательно от разряда к разряду по правилу математического округления, а это не так. И как отмечено выше 0,3478 меньше 0,35 и округляется до 0,3.

Автор - bmv98rus
Дата добавления - 22.10.2019 в 10:51
Nic70y Дата: Вторник, 22.10.2019, 11:26 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
формула массива, неправильного округления:
Код
=ОКРУГЛ(МАКС(ОКРУГЛ($D$3/$C$3;СТРОКА(ДВССЫЛ(СТОЛБЕЦ(A1)&":15"))));СТОЛБЕЦ(A1))


ЯД(poison) 41001841029809
 
Ответить
Сообщениеформула массива, неправильного округления:
Код
=ОКРУГЛ(МАКС(ОКРУГЛ($D$3/$C$3;СТРОКА(ДВССЫЛ(СТОЛБЕЦ(A1)&":15"))));СТОЛБЕЦ(A1))

Автор - Nic70y
Дата добавления - 22.10.2019 в 11:26
AVI Дата: Среда, 23.10.2019, 03:04 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 510
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Вы округляете 0,347826086956522, а не 0,35

Вы хотите сказать, что 0,347826086956522 округлится до 0,3? Или эксель при округлении числа 0,347826086956522 отбрасывает ...7826086956522 и округляет только 0,34?

тема не для Excel - для математики


Вопрос-то был именно почему эксель округляет неверно, а не в том как округлить правильно.


Сообщение отредактировал AVI - Среда, 23.10.2019, 03:09
 
Ответить
Сообщение
Вы округляете 0,347826086956522, а не 0,35

Вы хотите сказать, что 0,347826086956522 округлится до 0,3? Или эксель при округлении числа 0,347826086956522 отбрасывает ...7826086956522 и округляет только 0,34?

тема не для Excel - для математики


Вопрос-то был именно почему эксель округляет неверно, а не в том как округлить правильно.

Автор - AVI
Дата добавления - 23.10.2019 в 03:04
Nic70y Дата: Среда, 23.10.2019, 08:40 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 5700
Репутация: 1250 ±
Замечаний: 0% ±

ru13;10;03
почему эксель округляет неверно
так он верно округляет, согласно правилам математики
0,347826086956522 округлится до 0,3
именно так


ЯД(poison) 41001841029809
 
Ответить
Сообщение
почему эксель округляет неверно
так он верно округляет, согласно правилам математики
0,347826086956522 округлится до 0,3
именно так

Автор - Nic70y
Дата добавления - 23.10.2019 в 08:40
AVI Дата: Пятница, 25.10.2019, 04:37 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 510
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Вопрос снят. Я тупой
 
Ответить
СообщениеВопрос снят. Я тупой

Автор - AVI
Дата добавления - 25.10.2019 в 04:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Почему не правильно округляется (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!