Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ссылка ячейки при клике на неё, на другую ячейку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка ячейки при клике на неё, на другую ячейку (Формулы/Formulas)
Ссылка ячейки при клике на неё, на другую ячейку
ROM@RIO Дата: Пятница, 25.10.2019, 20:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем доброго времени суток, мне уже очень помогли с вопросом http://www.excelworld.ru/forum/2-43261-1, ОГРОМНОЕ СПАСИБО bmv98rus ,в продолжении я хотел попросить помощи для организации возможности ссылаться с ячейки которая уже под формулой, при клике на неё. В данном примере интересует клик на ячейку C5.
К сообщению приложен файл: 2201461.xlsx(14.8 Kb)
 
Ответить
СообщениеВсем доброго времени суток, мне уже очень помогли с вопросом http://www.excelworld.ru/forum/2-43261-1, ОГРОМНОЕ СПАСИБО bmv98rus ,в продолжении я хотел попросить помощи для организации возможности ссылаться с ячейки которая уже под формулой, при клике на неё. В данном примере интересует клик на ячейку C5.

Автор - ROM@RIO
Дата добавления - 25.10.2019 в 20:46
bmv98rus Дата: Пятница, 25.10.2019, 20:49 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2720
Репутация: 467 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IFERROR(HYPERLINK("#"&ADDRESS(2+MATCH($A4;Лист3!H$3:H$6;);4;;;"Лист3");INDEX(Лист3!$D$3:$D$6;MATCH($A4;Лист3!H$3:H$6;)));"")

Можно конечно и "Лист3" вычислить через
Код
=TRIM(RIGHT(SUBSTITUTE(CELL("filename";Лист3!$A$1);"]";REPT(" ";32));32))
или
Код
=MID(CELL("filename";Лист3!$A$1);FIND("]";CELL("filename";Лист3!$A$1))+1;32)

но будет и летуче и длиннее.
К сообщению приложен файл: 8922885.xlsx(14.1 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 25.10.2019, 20:53
 
Ответить
Сообщение
Код
=IFERROR(HYPERLINK("#"&ADDRESS(2+MATCH($A4;Лист3!H$3:H$6;);4;;;"Лист3");INDEX(Лист3!$D$3:$D$6;MATCH($A4;Лист3!H$3:H$6;)));"")

Можно конечно и "Лист3" вычислить через
Код
=TRIM(RIGHT(SUBSTITUTE(CELL("filename";Лист3!$A$1);"]";REPT(" ";32));32))
или
Код
=MID(CELL("filename";Лист3!$A$1);FIND("]";CELL("filename";Лист3!$A$1))+1;32)

но будет и летуче и длиннее.

Автор - bmv98rus
Дата добавления - 25.10.2019 в 20:49
ROM@RIO Дата: Суббота, 26.10.2019, 16:51 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, только при смене названия листа, перестаёт работать.
К сообщению приложен файл: 7106702.xlsx(18.8 Kb)


Сообщение отредактировал ROM@RIO - Суббота, 26.10.2019, 16:54
 
Ответить
СообщениеСпасибо, только при смене названия листа, перестаёт работать.

Автор - ROM@RIO
Дата добавления - 26.10.2019 в 16:51
bmv98rus Дата: Суббота, 26.10.2019, 18:42 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2720
Репутация: 467 ±
Замечаний: 0% ±

Excel 2013/2016
Так я ж написал рецепт сразу.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеТак я ж написал рецепт сразу.

Автор - bmv98rus
Дата добавления - 26.10.2019 в 18:42
ROM@RIO Дата: Суббота, 26.10.2019, 19:02 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
походу я рукожоп, нифига не получается, если можно пример с формулой которая не боится переименований листов
 
Ответить
Сообщениепоходу я рукожоп, нифига не получается, если можно пример с формулой которая не боится переименований листов

Автор - ROM@RIO
Дата добавления - 26.10.2019 в 19:02
bmv98rus Дата: Суббота, 26.10.2019, 19:31 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2720
Репутация: 467 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IFERROR(HYPERLINK("#"&ADDRESS(2+MATCH($A4;Sheet3!G$3:G$6;);4;;;TRIM(RIGHT(SUBSTITUTE(CELL("filename";Sheet3!$A$1);"]";REPT(" ";32));32)));INDEX(Sheet3!$D$3:$D$6;MATCH($A4;Sheet3!G$3:G$6;)));"")
К сообщению приложен файл: Copy_of_1222_1.xlsx(14.1 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=IFERROR(HYPERLINK("#"&ADDRESS(2+MATCH($A4;Sheet3!G$3:G$6;);4;;;TRIM(RIGHT(SUBSTITUTE(CELL("filename";Sheet3!$A$1);"]";REPT(" ";32));32)));INDEX(Sheet3!$D$3:$D$6;MATCH($A4;Sheet3!G$3:G$6;)));"")

Автор - bmv98rus
Дата добавления - 26.10.2019 в 19:31
ROM@RIO Дата: Вторник, 29.10.2019, 11:31 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ЕСЛИОШИБКА(ГИПЕРССЫЛКА("#"&АДРЕС(2+ПОИСКПОЗ($A4;Sheet3!G$3:G$6;);4;;;СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(ЯЧЕЙКА("filename";Sheet3!$A$1);"]";ПОВТОР(" ";32));32)));ИНДЕКС(Sheet3!$D$3:$D$6;ПОИСКПОЗ($A4;Sheet3!G$3:G$6;)));"")
К сообщению приложен файл: Copy_of_1222_1.xlsx(14.1 Kb)

Огромное спасибо Михаил, всё работает.
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ГИПЕРССЫЛКА("#"&АДРЕС(2+ПОИСКПОЗ($A4;Sheet3!G$3:G$6;);4;;;СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(ЯЧЕЙКА("filename";Sheet3!$A$1);"]";ПОВТОР(" ";32));32)));ИНДЕКС(Sheet3!$D$3:$D$6;ПОИСКПОЗ($A4;Sheet3!G$3:G$6;)));"")
К сообщению приложен файл: Copy_of_1222_1.xlsx(14.1 Kb)

Огромное спасибо Михаил, всё работает.

Автор - ROM@RIO
Дата добавления - 29.10.2019 в 11:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка ячейки при клике на неё, на другую ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!