Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выводить последние данные из столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выводить последние данные из столбцов (Формулы/Formulas)
Выводить последние данные из столбцов
frankenshtein Дата: Пятница, 25.10.2019, 22:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте. Требуется помощь.
Имеется 2 столбика. В нем с регулярной последовательностью меняются числа в разных ячейках по разному.
Требуется, чтобы формула прочитала эти два столбца и отобразила в отдельной ячейке (желтый цвет) данные последней ячейки (самая верхняя) из двух столбцов (ноль не в счет).
В примере она отобразила ячейку с данными 225.
Если бы вместо цифр 225 был бы ноль, тогда формула должна была отразить ячейку с цифрой 17
При этом если данные отображаются в обоих строках одновременно (зеленый цвет), и эти ячейки самые верхние, то в желтой ячейки должен стоять ноль.

Коряво написал, но изложил смысл как смог.
К сообщению приложен файл: 6511982.xlsx(9.1 Kb)
 
Ответить
СообщениеЗдравствуйте. Требуется помощь.
Имеется 2 столбика. В нем с регулярной последовательностью меняются числа в разных ячейках по разному.
Требуется, чтобы формула прочитала эти два столбца и отобразила в отдельной ячейке (желтый цвет) данные последней ячейки (самая верхняя) из двух столбцов (ноль не в счет).
В примере она отобразила ячейку с данными 225.
Если бы вместо цифр 225 был бы ноль, тогда формула должна была отразить ячейку с цифрой 17
При этом если данные отображаются в обоих строках одновременно (зеленый цвет), и эти ячейки самые верхние, то в желтой ячейки должен стоять ноль.

Коряво написал, но изложил смысл как смог.

Автор - frankenshtein
Дата добавления - 25.10.2019 в 22:29
bmv98rus Дата: Суббота, 26.10.2019, 07:30 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Массивная
Код
=IF(MATCH(1=1;A2:A25<>0;)<>MATCH(1=1;B2:B25<>0;);SUM(INDEX(A2:B25;MIN(MATCH(1=1;A2:A25<>0;);MATCH(1=1;B2:B25<>0;));));0)

Можно укорачивать конечно
Код
=IF(MATCH(1=1;A2:A25<>0;)-MATCH(1=1;B2:B25<>0;);SUM(INDEX(A2:B25;MATCH(1;MMULT(--(A2:B25<>0);{1;1}););));0)

Код
=(MATCH(1=1;A2:A25<>0;)<>MATCH(1=1;B2:B25<>0;))*SUM(INDEX(A2:B25;MATCH(1;MMULT(--(A2:B25<>0);{1;1}););))
но есть ли смысл
К сообщению приложен файл: Copy_of_1223.xlsx(9.5 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеМассивная
Код
=IF(MATCH(1=1;A2:A25<>0;)<>MATCH(1=1;B2:B25<>0;);SUM(INDEX(A2:B25;MIN(MATCH(1=1;A2:A25<>0;);MATCH(1=1;B2:B25<>0;));));0)

Можно укорачивать конечно
Код
=IF(MATCH(1=1;A2:A25<>0;)-MATCH(1=1;B2:B25<>0;);SUM(INDEX(A2:B25;MATCH(1;MMULT(--(A2:B25<>0);{1;1}););));0)

Код
=(MATCH(1=1;A2:A25<>0;)<>MATCH(1=1;B2:B25<>0;))*SUM(INDEX(A2:B25;MATCH(1;MMULT(--(A2:B25<>0);{1;1}););))
но есть ли смысл

Автор - bmv98rus
Дата добавления - 26.10.2019 в 07:30
frankenshtein Дата: Воскресенье, 27.10.2019, 00:01 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо огромное bmv98rus.
Вы бы в подпись добавили номер кошелька.
Хотел несколько монет перечислить за помощь.
 
Ответить
СообщениеСпасибо огромное bmv98rus.
Вы бы в подпись добавили номер кошелька.
Хотел несколько монет перечислить за помощь.

Автор - frankenshtein
Дата добавления - 27.10.2019 в 00:01
bmv98rus Дата: Воскресенье, 27.10.2019, 08:30 | Сообщение № 4
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
Цитата frankenshtein, 27.10.2019 в 00:01, в сообщении № 3 ()
Вы бы в подпись добавили номер кошелька
На аватарке - не Коала, а значит нет сумки - нет кошелька :D


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Цитата frankenshtein, 27.10.2019 в 00:01, в сообщении № 3 ()
Вы бы в подпись добавили номер кошелька
На аватарке - не Коала, а значит нет сумки - нет кошелька :D

Автор - bmv98rus
Дата добавления - 27.10.2019 в 08:30
frankenshtein Дата: Вторник, 29.10.2019, 23:56 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Не пойму почему так происходит.
Вот формула
Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C25<>0;)<>ПОИСКПОЗ(1=1;D2:D25<>0;);СУММ(ИНДЕКС(C2:D25;МИН(ПОИСКПОЗ(1=1;C2:C25<>0;);ПОИСКПОЗ(1=1;D2:D25<>0;));));0)

Все работает
Я изменил поиск позиций со 2 по 250 строку.
Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C250<>0;)<>ПОИСКПОЗ(1=1;D2:D250<>0;);СУММ(ИНДЕКС(C2:D250;МИН(ПОИСКПОЗ(1=1;C2:C250<>0;);ПОИСКПОЗ(1=1;D2:D250<>0;));

формула выдает ошибку #Н/Д
Как можно исправить.???


Сообщение отредактировал frankenshtein - Среда, 30.10.2019, 15:19
 
Ответить
СообщениеЗдравствуйте.
Не пойму почему так происходит.
Вот формула
Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C25<>0;)<>ПОИСКПОЗ(1=1;D2:D25<>0;);СУММ(ИНДЕКС(C2:D25;МИН(ПОИСКПОЗ(1=1;C2:C25<>0;);ПОИСКПОЗ(1=1;D2:D25<>0;));));0)

Все работает
Я изменил поиск позиций со 2 по 250 строку.
Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C250<>0;)<>ПОИСКПОЗ(1=1;D2:D250<>0;);СУММ(ИНДЕКС(C2:D250;МИН(ПОИСКПОЗ(1=1;C2:C250<>0;);ПОИСКПОЗ(1=1;D2:D250<>0;));

формула выдает ошибку #Н/Д
Как можно исправить.???

Автор - frankenshtein
Дата добавления - 29.10.2019 в 23:56
Pelena Дата: Среда, 30.10.2019, 00:08 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14763
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
frankenshtein, оформите формулы тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеfrankenshtein, оформите формулы тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 30.10.2019 в 00:08
bmv98rus Дата: Среда, 30.10.2019, 12:51 | Сообщение № 7
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2737
Репутация: 470 ±
Замечаний: 0% ±

Excel 2013/2016
оформите формулы тегами

и перечитайте #2 с самого первого слова.


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
оформите формулы тегами

и перечитайте #2 с самого первого слова.

Автор - bmv98rus
Дата добавления - 30.10.2019 в 12:51
frankenshtein Дата: Среда, 30.10.2019, 14:52 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Наверное это не для меня.
Как оформить тегами формулу я так и понял. fx вставляется код, а что дальше без понятия.
#2 перечитал, но все равно не понял где здесь гвоздь, почему 25 строк работает а 250 нет.
 
Ответить
СообщениеНаверное это не для меня.
Как оформить тегами формулу я так и понял. fx вставляется код, а что дальше без понятия.
#2 перечитал, но все равно не понял где здесь гвоздь, почему 25 строк работает а 250 нет.

Автор - frankenshtein
Дата добавления - 30.10.2019 в 14:52
китин Дата: Среда, 30.10.2019, 15:15 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 5926
Репутация: 920 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
(в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение(в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 30.10.2019 в 15:15
frankenshtein Дата: Среда, 30.10.2019, 15:42 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
разобрался в чем различие одной формулы от другой.
Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C250<>0;)<>ПОИСКПОЗ(1=1;D2:D250<>0;);СУММ(ИНДЕКС(C2:D250;МИН(ПОИСКПОЗ(1=1;C2:C250<>0;);ПОИСКПОЗ(1=1;D2:D250<>0;));));0)

Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C250<>0;)<>ПОИСКПОЗ(1=1;D2:D250<>0;);СУММ(ИНДЕКС(C2:D250;МИН(ПОИСКПОЗ(1=1;C2:C250<>0;);ПОИСКПОЗ(1=1;D2:D250<>0;));


но ни один ни второй вариант почему то не работает с 250 строками.
с 25 работают а 250 нет.
В чем ГВОЗДЬ?
 
Ответить
Сообщениеразобрался в чем различие одной формулы от другой.
Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C250<>0;)<>ПОИСКПОЗ(1=1;D2:D250<>0;);СУММ(ИНДЕКС(C2:D250;МИН(ПОИСКПОЗ(1=1;C2:C250<>0;);ПОИСКПОЗ(1=1;D2:D250<>0;));));0)

Код
=ЕСЛИ(ПОИСКПОЗ(1=1;C2:C250<>0;)<>ПОИСКПОЗ(1=1;D2:D250<>0;);СУММ(ИНДЕКС(C2:D250;МИН(ПОИСКПОЗ(1=1;C2:C250<>0;);ПОИСКПОЗ(1=1;D2:D250<>0;));


но ни один ни второй вариант почему то не работает с 250 строками.
с 25 работают а 250 нет.
В чем ГВОЗДЬ?

Автор - frankenshtein
Дата добавления - 30.10.2019 в 15:42
bigor Дата: Среда, 30.10.2019, 15:49 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 20 ±
Замечаний: 0% ±

Excel 2016
В чем ГВОЗДЬ?


и перечитайте #2 с самого первого слова.

Формулы МАССИВНЫЕ вводятся тремя кнопками Ctrl+Shift+Enter
 
Ответить
Сообщение
В чем ГВОЗДЬ?


и перечитайте #2 с самого первого слова.

Формулы МАССИВНЫЕ вводятся тремя кнопками Ctrl+Shift+Enter

Автор - bigor
Дата добавления - 30.10.2019 в 15:49
frankenshtein Дата: Среда, 30.10.2019, 17:53 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо. Разобрался.
 
Ответить
СообщениеСпасибо. Разобрался.

Автор - frankenshtein
Дата добавления - 30.10.2019 в 17:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выводить последние данные из столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!