Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск данных с несколькими условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных с несколькими условиями (Формулы/Formulas)
Поиск данных с несколькими условиями
КсюАрц Дата: Воскресенье, 10.11.2019, 00:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Необходимо в колонку В подтянуть дату первого фактически оплаченного платежа по договору.
Прошу, подскажите, какой формулой это возможно сделать.
Спасибо большое!
К сообщению приложен файл: 6389378.xls(38.5 Kb)
 
Ответить
СообщениеЗдравствуйте.
Необходимо в колонку В подтянуть дату первого фактически оплаченного платежа по договору.
Прошу, подскажите, какой формулой это возможно сделать.
Спасибо большое!

Автор - КсюАрц
Дата добавления - 10.11.2019 в 00:39
Gustav Дата: Воскресенье, 10.11.2019, 01:20 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 689 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Например, такой формулой массива (ввод по Ctrl+Shift+Enter) для ячейки B3 (для других ниже - скопировать):
Код
=ИНДЕКС($D$2:$CS$2; ПОИСКПОЗ(ИСТИНА; D3:CS3<>0; 0))

P.S. Сорри, деление на План/Факт не увидел - снимаюсь :'(


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Воскресенье, 10.11.2019, 01:27
 
Ответить
СообщениеНапример, такой формулой массива (ввод по Ctrl+Shift+Enter) для ячейки B3 (для других ниже - скопировать):
Код
=ИНДЕКС($D$2:$CS$2; ПОИСКПОЗ(ИСТИНА; D3:CS3<>0; 0))

P.S. Сорри, деление на План/Факт не увидел - снимаюсь :'(

Автор - Gustav
Дата добавления - 10.11.2019 в 01:20
gling Дата: Воскресенье, 10.11.2019, 01:20 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1980
Репутация: 493 ±
Замечаний: 0% ±

2010
Здравствуйте. Можно такой
Код
=ИНДЕКС($D$2:$CS$2;СУММПРОИЗВ(ПОИСКПОЗ(1;--((D3:CS3>0)*($D$1:$CS$1="Факт"));)))
К сообщению приложен файл: 5107232.xls(39.5 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Можно такой
Код
=ИНДЕКС($D$2:$CS$2;СУММПРОИЗВ(ПОИСКПОЗ(1;--((D3:CS3>0)*($D$1:$CS$1="Факт"));)))

Автор - gling
Дата добавления - 10.11.2019 в 01:20
КсюАрц Дата: Воскресенье, 10.11.2019, 02:20 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
gling, hands hands hands hands hands hands
Спасибо Вам огромное!!!
Это то, что нужно!!!!
 
Ответить
Сообщениеgling, hands hands hands hands hands hands
Спасибо Вам огромное!!!
Это то, что нужно!!!!

Автор - КсюАрц
Дата добавления - 10.11.2019 в 02:20
jakim Дата: Воскресенье, 10.11.2019, 15:31 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 905
Репутация: 235 ±
Замечаний: 0% ±

Excel 2010
Ещё одна формула

Код
=AGGREGATE(15;6;D$2:IK$2/(D3:IK3>0)/(D$1:IK$1="Факт");1)
 
Ответить
Сообщение
Ещё одна формула

Код
=AGGREGATE(15;6;D$2:IK$2/(D3:IK3>0)/(D$1:IK$1="Факт");1)

Автор - jakim
Дата добавления - 10.11.2019 в 15:31
КсюАрц Дата: Воскресенье, 10.11.2019, 15:51 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
jakim, hands hands
Благодарю, эта формула тоже подходит!!


Сообщение отредактировал КсюАрц - Воскресенье, 10.11.2019, 15:52
 
Ответить
Сообщениеjakim, hands hands
Благодарю, эта формула тоже подходит!!

Автор - КсюАрц
Дата добавления - 10.11.2019 в 15:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск данных с несколькими условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!