Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Номер повторяющегося значения по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номер повторяющегося значения по условию (Формулы/Formulas)
Номер повторяющегося значения по условию
Xenus91 Дата: Воскресенье, 10.11.2019, 20:52 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Просьба помочь, с задачкой
Необходимо пронумеровать, повторяющиеся значения в столбцe B, по наименьшему времени в столбце А
уникальные значения не отмечаем
К сообщению приложен файл: 0619511.xlsx(11.8 Kb)
 
Ответить
СообщениеДобрый вечер!
Просьба помочь, с задачкой
Необходимо пронумеровать, повторяющиеся значения в столбцe B, по наименьшему времени в столбце А
уникальные значения не отмечаем

Автор - Xenus91
Дата добавления - 10.11.2019 в 20:52
Pelena Дата: Воскресенье, 10.11.2019, 21:22 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14764
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
здравствуйте.
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$18;B2)>1;СЧЁТЕСЛИ($B$2:B2;B2);"")
К сообщению приложен файл: 4710247.xlsx(12.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениездравствуйте.
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$18;B2)>1;СЧЁТЕСЛИ($B$2:B2;B2);"")

Автор - Pelena
Дата добавления - 10.11.2019 в 21:22
Xenus91 Дата: Воскресенье, 10.11.2019, 22:07 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, над подобной уже думал, но нумерация нужна именно по дате и времени от наименьшего к наибольшему, дата и время в столбце не сортированы
 
Ответить
СообщениеPelena, над подобной уже думал, но нумерация нужна именно по дате и времени от наименьшего к наибольшему, дата и время в столбце не сортированы

Автор - Xenus91
Дата добавления - 10.11.2019 в 22:07
Pelena Дата: Воскресенье, 10.11.2019, 22:14 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14764
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Приведите тогда более правдоподобный пример


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПриведите тогда более правдоподобный пример

Автор - Pelena
Дата добавления - 10.11.2019 в 22:14
Xenus91 Дата: Воскресенье, 10.11.2019, 22:22 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, готово
К сообщению приложен файл: 6800178.xlsx(11.8 Kb)
 
Ответить
СообщениеPelena, готово

Автор - Xenus91
Дата добавления - 10.11.2019 в 22:22
Pelena Дата: Воскресенье, 10.11.2019, 22:48 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14764
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$18;B2)>1;СЧЁТЕСЛИМН($A$2:$A$18;"<="&A2;$B$2:$B$18;B2);"")

только с пятерками что-то не сошлось. Почему от 24 числа на первом месте, а от 21-го на втором?
К сообщению приложен файл: 2919534.xlsx(12.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$2:$B$18;B2)>1;СЧЁТЕСЛИМН($A$2:$A$18;"<="&A2;$B$2:$B$18;B2);"")

только с пятерками что-то не сошлось. Почему от 24 числа на первом месте, а от 21-го на втором?

Автор - Pelena
Дата добавления - 10.11.2019 в 22:48
Xenus91 Дата: Воскресенье, 10.11.2019, 23:01 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, огромное спасибо!
Цитата
только с пятерками что-то не сошлось. Почему от 24 числа на первом месте, а от 21-го на втором?

мой косяк,прошу прощения что ввел в заблуждение, второпях правил
 
Ответить
СообщениеPelena, огромное спасибо!
Цитата
только с пятерками что-то не сошлось. Почему от 24 числа на первом месте, а от 21-го на втором?

мой косяк,прошу прощения что ввел в заблуждение, второпях правил

Автор - Xenus91
Дата добавления - 10.11.2019 в 23:01
Светлый Дата: Воскресенье, 10.11.2019, 23:23 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1340
Репутация: 333 ±
Замечаний: 0% ±

Excel 2010
И формула, если есть совершенно одинаковые значения времени:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$2:B$18;B2)>1;СУММПРОИЗВ((A$2:A$18+СТРОКА($2:$18)%%%<=A2+СТРОКА(A2)%%%)*(B$2:B$18=B2));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ формула, если есть совершенно одинаковые значения времени:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$2:B$18;B2)>1;СУММПРОИЗВ((A$2:A$18+СТРОКА($2:$18)%%%<=A2+СТРОКА(A2)%%%)*(B$2:B$18=B2));"")

Автор - Светлый
Дата добавления - 10.11.2019 в 23:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Номер повторяющегося значения по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!