Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула массив уникальные записи - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула массив уникальные записи (Формулы/Formulas)
формула массив уникальные записи
OpaL Дата: Понедельник, 11.11.2019, 09:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
В первом столбце список, содержащий дублирующиеся значения.
Нужно вывести во второй столбец список уникальных значений.
Нашел формулу массива:
Код
{=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$9;
НАИМЕНЬШИЙ(ЕСЛИ(
СЧЁТЕСЛИ($B$1:B1;$A$2:$A$9)=0;
СТРОКА($A$1:$A$8));1));
"")}


Но работает она только если таблица начинается с первой строки (вложение, Лист1)
Если добавляем строки (Вложение, Лист2), уже не работает.
Вопрос: Как сделать чтобы работала?
К сообщению приложен файл: unic.xlsx(15.1 Kb)


Сообщение отредактировал OpaL - Понедельник, 11.11.2019, 09:42
 
Ответить
СообщениеДобрый день!
В первом столбце список, содержащий дублирующиеся значения.
Нужно вывести во второй столбец список уникальных значений.
Нашел формулу массива:
Код
{=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$9;
НАИМЕНЬШИЙ(ЕСЛИ(
СЧЁТЕСЛИ($B$1:B1;$A$2:$A$9)=0;
СТРОКА($A$1:$A$8));1));
"")}


Но работает она только если таблица начинается с первой строки (вложение, Лист1)
Если добавляем строки (Вложение, Лист2), уже не работает.
Вопрос: Как сделать чтобы работала?

Автор - OpaL
Дата добавления - 11.11.2019 в 09:39
Светлый Дата: Понедельник, 11.11.2019, 09:55 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1375
Репутация: 366 ±
Замечаний: 0% ±

Excel 2010, 2013
Добрый день!
Для второго листа можно использовать такую МАССИВНУЮ формулу:
Код
=""&ИНДЕКС(A:A;
МИН(ЕСЛИ(
СЧЁТЕСЛИ($B$11:B11;$A$12:$A$19)=0;
СТРОКА($A$12:$A$19))))
*А для первого так можно:
Код
=ПОДСТАВИТЬ(ИНДЕКС(A:A;
МИН(ЕСЛИ(
СЧЁТЕСЛИ($B$1:B1;$A$2:$A$9)=0;
СТРОКА($A$2:$A$9))));A$1;)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 11.11.2019, 09:59
 
Ответить
СообщениеДобрый день!
Для второго листа можно использовать такую МАССИВНУЮ формулу:
Код
=""&ИНДЕКС(A:A;
МИН(ЕСЛИ(
СЧЁТЕСЛИ($B$11:B11;$A$12:$A$19)=0;
СТРОКА($A$12:$A$19))))
*А для первого так можно:
Код
=ПОДСТАВИТЬ(ИНДЕКС(A:A;
МИН(ЕСЛИ(
СЧЁТЕСЛИ($B$1:B1;$A$2:$A$9)=0;
СТРОКА($A$2:$A$9))));A$1;)

Автор - Светлый
Дата добавления - 11.11.2019 в 09:55
OpaL Дата: Понедельник, 11.11.2019, 11:52 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, работает.
А можно ли в качестве исходных данных использовать конкретный столбец из именованного диапазона?


Сообщение отредактировал OpaL - Понедельник, 11.11.2019, 11:54
 
Ответить
СообщениеСпасибо, работает.
А можно ли в качестве исходных данных использовать конкретный столбец из именованного диапазона?

Автор - OpaL
Дата добавления - 11.11.2019 в 11:52
Светлый Дата: Понедельник, 11.11.2019, 14:56 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1375
Репутация: 366 ±
Замечаний: 0% ±

Excel 2010, 2013
Функция ИНДЕКС на такое способна.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеФункция ИНДЕКС на такое способна.

Автор - Светлый
Дата добавления - 11.11.2019 в 14:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула массив уникальные записи (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!