Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Получение списка всех строк содержащих одинаковые данные - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получение списка всех строк содержащих одинаковые данные (Формулы/Formulas)
Получение списка всех строк содержащих одинаковые данные
drovosek777 Дата: Среда, 13.11.2019, 13:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
добрый день!

подскажите пожалуйста как сделать формулу для получения списка всех строк содержащих искомое значение?
вроде по логике все правильно делаю, но не получается и не пойму почему
подскажите пожалуйста.

добавил ячейки e12 и e13 - смысл в том чтобы в этих ячейках изменялся диапазон массива в котором следует искать значение, исходя из результата в предыдущей строке.

Была тема похожая, но без массива данных
К сообщению приложен файл: 5194640.xlsx(10.8 Kb)


Office 2019
 
Ответить
Сообщениедобрый день!

подскажите пожалуйста как сделать формулу для получения списка всех строк содержащих искомое значение?
вроде по логике все правильно делаю, но не получается и не пойму почему
подскажите пожалуйста.

добавил ячейки e12 и e13 - смысл в том чтобы в этих ячейках изменялся диапазон массива в котором следует искать значение, исходя из результата в предыдущей строке.

Была тема похожая, но без массива данных

Автор - drovosek777
Дата добавления - 13.11.2019 в 13:33
gling Дата: Среда, 13.11.2019, 13:55 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1986
Репутация: 493 ±
Замечаний: 0% ±

2010
А с доп. столбцом не подходит?
К сообщению приложен файл: 4390915.xlsx(10.8 Kb)


ЯД-41001506838083
 
Ответить
СообщениеА с доп. столбцом не подходит?

Автор - gling
Дата добавления - 13.11.2019 в 13:55
drovosek777 Дата: Среда, 13.11.2019, 14:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
gling, не, нужно именно чтобы список формировался


Office 2019
 
Ответить
Сообщениеgling, не, нужно именно чтобы список формировался

Автор - drovosek777
Дата добавления - 13.11.2019 в 14:06
gling Дата: Среда, 13.11.2019, 16:08 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1986
Репутация: 493 ±
Замечаний: 0% ±

2010
нужно именно чтобы список формировался
Покажите какой список и из чего должен сформироваться?В примере не понятен конечный результат, только ваши формулы которые не работают, а как должно получиться нет, или я плохо искал?


ЯД-41001506838083
 
Ответить
Сообщение
нужно именно чтобы список формировался
Покажите какой список и из чего должен сформироваться?В примере не понятен конечный результат, только ваши формулы которые не работают, а как должно получиться нет, или я плохо искал?

Автор - gling
Дата добавления - 13.11.2019 в 16:08
drovosek777 Дата: Четверг, 14.11.2019, 17:02 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
gling, собрал новый файл в нем указал что я имею ввиду. Можно это как то сделать без доп столбцов?
как то можно вставить массив данных({...}) в обычную формулу?

спасибо.
К сообщению приложен файл: 2528864.xlsx(15.3 Kb)


Office 2019
 
Ответить
Сообщениеgling, собрал новый файл в нем указал что я имею ввиду. Можно это как то сделать без доп столбцов?
как то можно вставить массив данных({...}) в обычную формулу?

спасибо.

Автор - drovosek777
Дата добавления - 14.11.2019 в 17:02
Pelena Дата: Четверг, 14.11.2019, 18:26 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14863
Репутация: 3248 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула массива
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($G$1;Лист2!$G$3:$G$23));СТРОКА(Лист2!$G$3:$G$23)-2);СТРОКА(A1));"")
К сообщению приложен файл: 2588122.xlsx(15.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($G$1;Лист2!$G$3:$G$23));СТРОКА(Лист2!$G$3:$G$23)-2);СТРОКА(A1));"")

Автор - Pelena
Дата добавления - 14.11.2019 в 18:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Получение списка всех строк содержащих одинаковые данные (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!