Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как в функции СМЕЩ использовать ссылку? Или другие варианты? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Как в функции СМЕЩ использовать ссылку? Или другие варианты?
mike Дата: Суббота, 06.04.2013, 23:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Привет!
Прошу подсказки!)
Задача: посчитать кол-во символов из диапазона. Диапазон зависит от текущего месяца (Январю соответствует один диапазон, Февраль - тот же диапазон, но смещенный на 4 столбца вправо, каждому следующему месяцу - ещё смещение на 4 столбца). См. файлик в аттаче.

Пример: в отдельную Ячейку вписываем месяц. Этому месяцу определяется автоматически соотв. диапазон. И с помощью СЧЁТЕСЛИ считается кол-во всех значков из этого диапазона.

Заранее спасибо! wink
К сообщению приложен файл: 9436185.xlsx (19.2 Kb)
 
Ответить
СообщениеПривет!
Прошу подсказки!)
Задача: посчитать кол-во символов из диапазона. Диапазон зависит от текущего месяца (Январю соответствует один диапазон, Февраль - тот же диапазон, но смещенный на 4 столбца вправо, каждому следующему месяцу - ещё смещение на 4 столбца). См. файлик в аттаче.

Пример: в отдельную Ячейку вписываем месяц. Этому месяцу определяется автоматически соотв. диапазон. И с помощью СЧЁТЕСЛИ считается кол-во всех значков из этого диапазона.

Заранее спасибо! wink

Автор - mike
Дата добавления - 06.04.2013 в 23:15
Michael_S Дата: Суббота, 06.04.2013, 23:30 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2012
Репутация: 373 ±
Замечаний: 0% ±

Excel2016
Код
=СЧЁТЕСЛИ(СМЕЩ(H:K;0;ПОИСКПОЗ($B$10;$H$1:$BC$1;0)-1);B14)
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(СМЕЩ(H:K;0;ПОИСКПОЗ($B$10;$H$1:$BC$1;0)-1);B14)

Автор - Michael_S
Дата добавления - 06.04.2013 в 23:30
Pelena Дата: Суббота, 06.04.2013, 23:35 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 19235
Репутация: 4433 ±
Замечаний: ±

Excel 365 & Mac Excel
Вариант с именованными диапазонами (сделано до апреля, дальше по аналогии)
Код
=СЧЁТЕСЛИ(ДВССЫЛ($B$10);B13)


ЗЫ: не рекомендуется использовать ссылки на столбец целиком
К сообщению приложен файл: 8115908.xlsx (19.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВариант с именованными диапазонами (сделано до апреля, дальше по аналогии)
Код
=СЧЁТЕСЛИ(ДВССЫЛ($B$10);B13)


ЗЫ: не рекомендуется использовать ссылки на столбец целиком

Автор - Pelena
Дата добавления - 06.04.2013 в 23:35
ikki Дата: Суббота, 06.04.2013, 23:41 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1906
Репутация: 504 ±
Замечаний: 0% ±

Excel 2003, 2010
три варианта.
мне больше нравится последний, ибо не содержит летучих функций СМЕЩ или ДВССЫЛ
но там использована небольшая хитрость - в заголовке таблице даты есть во всех ячейках.
К сообщению приложен файл: 0627654.xlsx (20.0 Kb)


помощь по Excel и VBA
ikki@fxmail.ru, icq 592842413, skype alex.ikki


Сообщение отредактировал ikki - Суббота, 06.04.2013, 23:52
 
Ответить
Сообщениетри варианта.
мне больше нравится последний, ибо не содержит летучих функций СМЕЩ или ДВССЫЛ
но там использована небольшая хитрость - в заголовке таблице даты есть во всех ячейках.

Автор - ikki
Дата добавления - 06.04.2013 в 23:41
mike Дата: Суббота, 06.04.2013, 23:45 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Спасибо! wink
 
Ответить
СообщениеСпасибо! wink

Автор - mike
Дата добавления - 06.04.2013 в 23:45
Rustem Дата: Воскресенье, 07.04.2013, 22:07 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 281
Репутация: 48 ±
Замечаний: 0% ±

Excel 2013
Вариант. Не такой красивый...
К сообщению приложен файл: 8759877.xlsx (20.2 Kb)


WMR: R183220163895
 
Ответить
СообщениеВариант. Не такой красивый...

Автор - Rustem
Дата добавления - 07.04.2013 в 22:07
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!