Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных из строк в один столбец - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из строк в один столбец (Формулы/Formulas)
Перенос данных из строк в один столбец
andreika21 Дата: Вторник, 26.11.2019, 09:56 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 132
Репутация: 1 ±
Замечаний: 0% ±

Здравствуйте. В таблице данные записаны построчно, надо перенести эти данные в другую таблицу в один столбец.
К сообщению приложен файл: Knyga1.xlsx(12.0 Kb)
 
Ответить
СообщениеЗдравствуйте. В таблице данные записаны построчно, надо перенести эти данные в другую таблицу в один столбец.

Автор - andreika21
Дата добавления - 26.11.2019 в 09:56
китин Дата: Вторник, 26.11.2019, 10:12 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Здравствуйте. строго по приведенному примеру
Код
=ИНДЕКС($C$5:$L$5000;(СТРОКА(A1)-1)/10+1;ОСТАТ(СТРОКА(A1)-1;10)+1)
К сообщению приложен файл: Knyga1_1.xlsx(13.4 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеЗдравствуйте. строго по приведенному примеру
Код
=ИНДЕКС($C$5:$L$5000;(СТРОКА(A1)-1)/10+1;ОСТАТ(СТРОКА(A1)-1;10)+1)

Автор - китин
Дата добавления - 26.11.2019 в 10:12
bigor Дата: Вторник, 26.11.2019, 10:13 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 681
Репутация: 139 ±
Замечаний: 0% ±

нет
Добрый день

в 4 строку
Код
=OFFSET($C$5;INT((ROW()-3)/10);MOD((ROW()-3);10))

и протянуть вниз
 
Ответить
СообщениеДобрый день

в 4 строку
Код
=OFFSET($C$5;INT((ROW()-3)/10);MOD((ROW()-3);10))

и протянуть вниз

Автор - bigor
Дата добавления - 26.11.2019 в 10:13
andreika21 Дата: Вторник, 26.11.2019, 10:22 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 132
Репутация: 1 ±
Замечаний: 0% ±

bigor, китин, Спасибо большое оба варианта работают.
 
Ответить
Сообщениеbigor, китин, Спасибо большое оба варианта работают.

Автор - andreika21
Дата добавления - 26.11.2019 в 10:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из строк в один столбец (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!