Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет по заданному значению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет по заданному значению (Формулы/Formulas)
Подсчет по заданному значению
Netriver Дата: Среда, 27.11.2019, 13:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет, не могу родить формулу, нужно посчитать колличество товара по заданному значению.
К сообщению приложен файл: 6625720.xlsx(8.6 Kb)
 
Ответить
СообщениеВсем привет, не могу родить формулу, нужно посчитать колличество товара по заданному значению.

Автор - Netriver
Дата добавления - 27.11.2019 в 13:06
Kostya_Ye Дата: Среда, 27.11.2019, 13:21 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 47 ±
Замечаний: 0% ±

Excel 2016
Netriver, добрый день,
с дополнительным диапазоном B25:E25, содержащим точное название товаров
Код
=SUMPRODUCT(($A$2:$A$22=$A27)*($B$2:$B$22=B$25))

А сводная таблица чем не устраивает ?
К сообщению приложен файл: 9614735.xlsx(14.5 Kb)


Сообщение отредактировал Kostya_Ye - Среда, 27.11.2019, 13:22
 
Ответить
СообщениеNetriver, добрый день,
с дополнительным диапазоном B25:E25, содержащим точное название товаров
Код
=SUMPRODUCT(($A$2:$A$22=$A27)*($B$2:$B$22=B$25))

А сводная таблица чем не устраивает ?

Автор - Kostya_Ye
Дата добавления - 27.11.2019 в 13:21
Netriver Дата: Среда, 27.11.2019, 17:34 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо, тут оказалось, что нужна колонка с колличеством, не могу перестроить формулу под это killed
А сводная таблица чем не устраивает ?

В таблице где используется данная формула обновляемые данные и сводная не совсем подходит.
К сообщению приложен файл: 0819025.xlsx(14.2 Kb)


Сообщение отредактировал Netriver - Среда, 27.11.2019, 17:36
 
Ответить
СообщениеСпасибо, тут оказалось, что нужна колонка с колличеством, не могу перестроить формулу под это killed
А сводная таблица чем не устраивает ?

В таблице где используется данная формула обновляемые данные и сводная не совсем подходит.

Автор - Netriver
Дата добавления - 27.11.2019 в 17:34
Kostya_Ye Дата: Среда, 27.11.2019, 17:43 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 113
Репутация: 47 ±
Замечаний: 0% ±

Excel 2016
Netriver,
Тогда просто добавить еще один диапазон
Код
=SUMPRODUCT(($A$2:$A$22=$A27)*($B$2:$B$22=B$25)*($C$2:$C$22))
 
Ответить
СообщениеNetriver,
Тогда просто добавить еще один диапазон
Код
=SUMPRODUCT(($A$2:$A$22=$A27)*($B$2:$B$22=B$25)*($C$2:$C$22))

Автор - Kostya_Ye
Дата добавления - 27.11.2019 в 17:43
_Boroda_ Дата: Среда, 27.11.2019, 20:35 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15673
Репутация: 6120 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант (табличку перенес)
Код
=СУММЕСЛИМН($C:$C;$A:$A;$G3;$B:$B;H$1)
К сообщению приложен файл: 0819025_1.xlsx(11.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант (табличку перенес)
Код
=СУММЕСЛИМН($C:$C;$A:$A;$G3;$B:$B;H$1)

Автор - _Boroda_
Дата добавления - 27.11.2019 в 20:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет по заданному значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!