Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как удалять пустые строки при переносе ячеек на другой лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как удалять пустые строки при переносе ячеек на другой лист (Формулы/Formulas)
Как удалять пустые строки при переносе ячеек на другой лист
Tort Дата: Пятница, 29.11.2019, 11:12 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Здравствуйте, есть файл в котором во втором листе происходит расчет, а в третьем ссылка на нужный столбец и вывод нужных данных. В них есть пустые строки со сылкой их мне нужно удалить, фильтр не вариант т.к. потом данные выводить через другую программу, там могут появиться пустые ячейки с F5 тоже т.к она их считает заполненными . пробовал вот так не получается
Код
ЕСЛИ(Лист!Q2(СТРОКА()-СТРОКА(НетПустых)+1>ЧСТРОК(ЕстьПустые)-СЧИТАТЬПУСТОТЫ(ЕстьПустые);"";ДВССЫЛ(АДРЕС(НАИМЕНЬШИЙ((ЕСЛИ(ЕстьПустые<>"";СТРОКА(ЕстьПустые);СТРОКА()+ЧСТРОК(ЕстьПустые)));СТРОКА()-СТРОКА(НетПустых)+1);СТОЛБЕЦ(ЕстьПустые);4))))
К сообщению приложен файл: 1818.xlsm(51.4 Kb)
 
Ответить
СообщениеЗдравствуйте, есть файл в котором во втором листе происходит расчет, а в третьем ссылка на нужный столбец и вывод нужных данных. В них есть пустые строки со сылкой их мне нужно удалить, фильтр не вариант т.к. потом данные выводить через другую программу, там могут появиться пустые ячейки с F5 тоже т.к она их считает заполненными . пробовал вот так не получается
Код
ЕСЛИ(Лист!Q2(СТРОКА()-СТРОКА(НетПустых)+1>ЧСТРОК(ЕстьПустые)-СЧИТАТЬПУСТОТЫ(ЕстьПустые);"";ДВССЫЛ(АДРЕС(НАИМЕНЬШИЙ((ЕСЛИ(ЕстьПустые<>"";СТРОКА(ЕстьПустые);СТРОКА()+ЧСТРОК(ЕстьПустые)));СТРОКА()-СТРОКА(НетПустых)+1);СТОЛБЕЦ(ЕстьПустые);4))))

Автор - Tort
Дата добавления - 29.11.2019 в 11:12
Pelena Дата: Пятница, 29.11.2019, 11:53 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14887
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$Q$2:$Q$30;НАИМЕНЬШИЙ(ЕСЛИ(Лист2!$Q$2:$Q$30<>"";СТРОКА(Лист2!$Q$2:$Q$30)-1);СТРОКА(A1)));"")

или обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$Q$2:$Q$30;АГРЕГАТ(15;6;(СТРОКА(Лист2!$Q$2:$Q$30)-1)/(Лист2!$Q$2:$Q$30<>"");СТРОКА(A1)));"")
К сообщению приложен файл: 9757881.xlsm(51.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$Q$2:$Q$30;НАИМЕНЬШИЙ(ЕСЛИ(Лист2!$Q$2:$Q$30<>"";СТРОКА(Лист2!$Q$2:$Q$30)-1);СТРОКА(A1)));"")

или обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$Q$2:$Q$30;АГРЕГАТ(15;6;(СТРОКА(Лист2!$Q$2:$Q$30)-1)/(Лист2!$Q$2:$Q$30<>"");СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 29.11.2019 в 11:53
Tort Дата: Пятница, 29.11.2019, 13:38 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Pelena
у меня вопрос можно ли сделать так чтобы путем сопоставления пустой строки в столбце "Е" и столбца H (а,в,с) оставлять пустые строки в столбце "Е",


Сообщение отредактировал Tort - Пятница, 29.11.2019, 13:38
 
Ответить
СообщениеPelena
у меня вопрос можно ли сделать так чтобы путем сопоставления пустой строки в столбце "Е" и столбца H (а,в,с) оставлять пустые строки в столбце "Е",

Автор - Tort
Дата добавления - 29.11.2019 в 13:38
Pelena Дата: Пятница, 29.11.2019, 13:45 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14887
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ничего не поняла. То "как удалять пустые", теперь "как оставлять пустые"... Это уже другой вопрос? А первый решён?
Вы бы описали общую задачу, конечную цель


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНичего не поняла. То "как удалять пустые", теперь "как оставлять пустые"... Это уже другой вопрос? А первый решён?
Вы бы описали общую задачу, конечную цель

Автор - Pelena
Дата добавления - 29.11.2019 в 13:45
Tort Дата: Пятница, 29.11.2019, 14:02 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Вы бы описали общую задачу, конечную цель

Ваши обе формулы работают. Я дико извиняюсь, я не сразу сообразил про это, мне нужно из столбца Q удалить пустые строки и скопировать их на другой лист, а со столбца "Е" путем анализа столбца H (а,в,с) оставить пустые строки в столбце "Е",. Т.е столбец Q относится к E,F и H.
Пример

Е F H Q

4к 1 а г18
пусто 1 в г18
пусто 1 с г18,Г19,Г20,г21
4К 2 и т.д


Сообщение отредактировал Tort - Пятница, 29.11.2019, 14:03
 
Ответить
Сообщение
Вы бы описали общую задачу, конечную цель

Ваши обе формулы работают. Я дико извиняюсь, я не сразу сообразил про это, мне нужно из столбца Q удалить пустые строки и скопировать их на другой лист, а со столбца "Е" путем анализа столбца H (а,в,с) оставить пустые строки в столбце "Е",. Т.е столбец Q относится к E,F и H.
Пример

Е F H Q

4к 1 а г18
пусто 1 в г18
пусто 1 с г18,Г19,Г20,г21
4К 2 и т.д

Автор - Tort
Дата добавления - 29.11.2019 в 14:02
Tort Дата: Пятница, 29.11.2019, 14:49 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Мне создать другую тему для этого вопроса?
 
Ответить
СообщениеМне создать другую тему для этого вопроса?

Автор - Tort
Дата добавления - 29.11.2019 в 14:49
Pelena Дата: Пятница, 29.11.2019, 15:03 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14887
Репутация: 3251 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Файл приложите, что есть и что надо получить в итоге. Просто руками без формул нарисуйте желаемый результат


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл приложите, что есть и что надо получить в итоге. Просто руками без формул нарисуйте желаемый результат

Автор - Pelena
Дата добавления - 29.11.2019 в 15:03
Tort Дата: Пятница, 29.11.2019, 15:14 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
на 3 листе что должно получиться
К сообщению приложен файл: 1919.xlsm(51.7 Kb)
 
Ответить
Сообщениена 3 листе что должно получиться

Автор - Tort
Дата добавления - 29.11.2019 в 15:14
Nic70y Дата: Пятница, 29.11.2019, 15:24 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 5737
Репутация: 1259 ±
Замечаний: 0% ±

ru13;10;03
вариант с допами и
Код
=ИНДЕКС()


апдЭйт файл заменил
К сообщению приложен файл: 18.xlsm(53.9 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Пятница, 29.11.2019, 15:26
 
Ответить
Сообщениевариант с допами и
Код
=ИНДЕКС()


апдЭйт файл заменил

Автор - Nic70y
Дата добавления - 29.11.2019 в 15:24
Tort Дата: Пятница, 29.11.2019, 15:40 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
вариант с допами и

под допами вы имеете ввиду столбцы R и S ? их нужно вписать?
 
Ответить
Сообщение
вариант с допами и

под допами вы имеете ввиду столбцы R и S ? их нужно вписать?

Автор - Tort
Дата добавления - 29.11.2019 в 15:40
Nic70y Дата: Пятница, 29.11.2019, 16:06 | Сообщение № 11
Группа: Друзья
Ранг: Экселист
Сообщений: 5737
Репутация: 1259 ±
Замечаний: 0% ±

ru13;10;03
таки да


ЯД(poison) 41001841029809
 
Ответить
Сообщениетаки да

Автор - Nic70y
Дата добавления - 29.11.2019 в 16:06
Tort Дата: Пятница, 29.11.2019, 16:29 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Спасибо все работает
 
Ответить
СообщениеСпасибо все работает

Автор - Tort
Дата добавления - 29.11.2019 в 16:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как удалять пустые строки при переносе ячеек на другой лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!