Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование определенных ячеек в диапазоне (по строке) без - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование определенных ячеек в диапазоне (по строке) без (Формулы/Formulas)
Суммирование определенных ячеек в диапазоне (по строке) без
rbk Дата: Вторник, 03.12.2019, 10:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Привет
вот скрин примера таблицы (сам файл тоже прикрепил)


мне нужно в строках в определенном диапазоне считать сумму в ячейках ( в конкретном примере столбец "общий вес" суммирует ячейки в столбцах "кол-во")
для этого я использую формулу массива (если я правильно называю) и суммирую все четные ячейки нужного диапазона. такая формула удобна тем, что может возникнуть необходимость добавлять/удалять столбцы в диапазоне.

все почти устраивает. НО, иногда мне нужно скрывать некоторые столбцы (скрывать клиентов).
в общем, нужно как-то подшаманить формулу, чтобы ячейки в скрытых столбцах не суммировались

спасибо
К сообщению приложен файл: 5743171.xlsx(10.0 Kb)


Сообщение отредактировал rbk - Вторник, 03.12.2019, 10:02
 
Ответить
СообщениеПривет
вот скрин примера таблицы (сам файл тоже прикрепил)


мне нужно в строках в определенном диапазоне считать сумму в ячейках ( в конкретном примере столбец "общий вес" суммирует ячейки в столбцах "кол-во")
для этого я использую формулу массива (если я правильно называю) и суммирую все четные ячейки нужного диапазона. такая формула удобна тем, что может возникнуть необходимость добавлять/удалять столбцы в диапазоне.

все почти устраивает. НО, иногда мне нужно скрывать некоторые столбцы (скрывать клиентов).
в общем, нужно как-то подшаманить формулу, чтобы ячейки в скрытых столбцах не суммировались

спасибо

Автор - rbk
Дата добавления - 03.12.2019 в 10:00
_Boroda_ Дата: Вторник, 03.12.2019, 10:31 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15673
Репутация: 6120 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Предложу немного более другой вариант исходной формулы
Код
=СУММЕСЛИ(C$2:J$2;C$2;C3:J3)

А со скрытыми столбцами вот такой вариант
Код
=СУММ((C$2:J$2=C$2)*C3:J3*(ЯЧЕЙКА("ширина";СМЕЩ(B3;;Ч(ИНДЕКС(СТОЛБЕЦ(A:H);))))>0))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 5743171_1.xlsx(10.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПредложу немного более другой вариант исходной формулы
Код
=СУММЕСЛИ(C$2:J$2;C$2;C3:J3)

А со скрытыми столбцами вот такой вариант
Код
=СУММ((C$2:J$2=C$2)*C3:J3*(ЯЧЕЙКА("ширина";СМЕЩ(B3;;Ч(ИНДЕКС(СТОЛБЕЦ(A:H);))))>0))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 03.12.2019 в 10:31
lebensvoll Дата: Вторник, 03.12.2019, 10:44 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 908
Репутация: 26 ±
Замечаний: 0% ±

Excel 2010
rbk,
ЕСЛИ ЧИСТО ПОДШАМАНИТЬ!!! :D
То вооооот так вот!!!
НЕ БЛАГОДАРИТЕ :D материал взят от сюда deal My WebPage
Цитата
Gustav Дата: Среда, 12.09.2012, 15:27 | Сообщение № 7


Дядя Саша уже ВАМ все написал пока я ПОДШАМАНИВАЛ )))))
К сообщению приложен файл: 0466325.xlsx(10.5 Kb)


Кто бы ты ни был, мир в твоих руках

Сообщение отредактировал lebensvoll - Вторник, 03.12.2019, 10:44
 
Ответить
Сообщениеrbk,
ЕСЛИ ЧИСТО ПОДШАМАНИТЬ!!! :D
То вооооот так вот!!!
НЕ БЛАГОДАРИТЕ :D материал взят от сюда deal My WebPage
Цитата
Gustav Дата: Среда, 12.09.2012, 15:27 | Сообщение № 7


Дядя Саша уже ВАМ все написал пока я ПОДШАМАНИВАЛ )))))

Автор - lebensvoll
Дата добавления - 03.12.2019 в 10:44
rbk Дата: Среда, 11.12.2019, 10:46 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Предложу немного более другой вариант исходной формулы

=СУММЕСЛИ(C$2:J$2;C$2;C3:J3)

спасибо. это намного более удобная формула

а вот со второй частью не могу совладать (логику ее не понимаю)
прикрепил более сложный пример. не получается подстроить формулу так, чтобы суммировались желтые ячейки (ну и не суммировались при скрытии)
К сообщению приложен файл: 9211451.xls(35.0 Kb)


Сообщение отредактировал rbk - Среда, 11.12.2019, 10:48
 
Ответить
Сообщение
Предложу немного более другой вариант исходной формулы

=СУММЕСЛИ(C$2:J$2;C$2;C3:J3)

спасибо. это намного более удобная формула

а вот со второй частью не могу совладать (логику ее не понимаю)
прикрепил более сложный пример. не получается подстроить формулу так, чтобы суммировались желтые ячейки (ну и не суммировались при скрытии)

Автор - rbk
Дата добавления - 11.12.2019 в 10:46
_Boroda_ Дата: Среда, 11.12.2019, 11:15 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15673
Репутация: 6120 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня Ваш файл не открывается


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня Ваш файл не открывается

Автор - _Boroda_
Дата добавления - 11.12.2019 в 11:15
Pelena Дата: Среда, 11.12.2019, 17:18 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14888
Репутация: 3254 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так проверьте
Код
=СУММ(ЕСЛИОШИБКА((I$1:V$1=$K$1)*I2:V2;0)*(ЯЧЕЙКА("ширина";СМЕЩ(G2;;Ч(ИНДЕКС(СТОЛБЕЦ(A:N);))))>0))
К сообщению приложен файл: 2247816.xls(35.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак проверьте
Код
=СУММ(ЕСЛИОШИБКА((I$1:V$1=$K$1)*I2:V2;0)*(ЯЧЕЙКА("ширина";СМЕЩ(G2;;Ч(ИНДЕКС(СТОЛБЕЦ(A:N);))))>0))

Автор - Pelena
Дата добавления - 11.12.2019 в 17:18
rbk Дата: Понедельник, 16.12.2019, 11:04 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
спасибо. эта формула отлично подошла


Сообщение отредактировал китин - Понедельник, 16.12.2019, 13:28
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума
спасибо. эта формула отлично подошла

Автор - rbk
Дата добавления - 16.12.2019 в 11:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование определенных ячеек в диапазоне (по строке) без (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!