Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать уникальные значения с дополнительными условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать уникальные значения с дополнительными условиями (Формулы/Formulas)
Посчитать уникальные значения с дополнительными условиями
hohloviv Дата: Среда, 04.12.2019, 17:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, господа.

Прошу помочь с подсчетом уникальных значений.

На первом листу условно база данных. На втором листе сводная таблица. Можно ли как-то посчитать количество сварщиков, работавших на конкретной линии? Т.е. в ячейке D3 должно быть - 3, D4 - 2, D5 - 2.

Буду очень благодарен.
К сообщению приложен файл: 7010139.xlsx(15.4 Kb)
 
Ответить
СообщениеДобрый день, господа.

Прошу помочь с подсчетом уникальных значений.

На первом листу условно база данных. На втором листе сводная таблица. Можно ли как-то посчитать количество сварщиков, работавших на конкретной линии? Т.е. в ячейке D3 должно быть - 3, D4 - 2, D5 - 2.

Буду очень благодарен.

Автор - hohloviv
Дата добавления - 04.12.2019 в 17:48
_Boroda_ Дата: Среда, 04.12.2019, 18:10 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15644
Репутация: 6114 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(ЕСЛИ((Лист1!A$2:A$99=A3)*(Лист1!F$2:F$99<>"");1/СЧЁТЕСЛИМН(Лист1!A$2:A$99;A3;Лист1!F$2:F$99;Лист1!F$2:F$99)))

Код
=СУММ(ЕСЛИ((Лист1!A$2:A$99=A3);(Лист1!F$2:F$99<>"")/СЧЁТЕСЛИМН(Лист1!A$2:A$99;A3;Лист1!F$2:F$99;Лист1!F$2:F$99)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 7010139_1.xlsx(15.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(ЕСЛИ((Лист1!A$2:A$99=A3)*(Лист1!F$2:F$99<>"");1/СЧЁТЕСЛИМН(Лист1!A$2:A$99;A3;Лист1!F$2:F$99;Лист1!F$2:F$99)))

Код
=СУММ(ЕСЛИ((Лист1!A$2:A$99=A3);(Лист1!F$2:F$99<>"")/СЧЁТЕСЛИМН(Лист1!A$2:A$99;A3;Лист1!F$2:F$99;Лист1!F$2:F$99)))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 04.12.2019 в 18:10
hohloviv Дата: Среда, 04.12.2019, 19:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Так нужно?


Спасибо ОГРОМНОЕ! Нифига не понял, как она работает, но она это делает))))
 
Ответить
Сообщение
Так нужно?


Спасибо ОГРОМНОЕ! Нифига не понял, как она работает, но она это делает))))

Автор - hohloviv
Дата добавления - 04.12.2019 в 19:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать уникальные значения с дополнительными условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!