Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование времени по фильтру - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование времени по фильтру (Формулы/Formulas)
Суммирование времени по фильтру
FasterQ Дата: Четверг, 05.12.2019, 13:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Есть таблица с Именем телефоном и временем разговора. Создан фильтр по именам. Нужно сделать так чтобы по фильтру Иван Иваныч складывались всё время его разговоров.
Пример:Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума

Я покурил мануалы, почитал про промежуточную сумму, но проблема в том, что обычные числа он складывает хорошо, а время оставляет по нулям. Как не крути. Всю голову поломал. Формат ячеек менял на ч:мм:сс, на [ч]:мм:cc
Вообщем по разному пробовал. Где я ошибаюсь?


Сообщение отредактировал китин - Четверг, 05.12.2019, 13:52
 
Ответить
СообщениеЕсть таблица с Именем телефоном и временем разговора. Создан фильтр по именам. Нужно сделать так чтобы по фильтру Иван Иваныч складывались всё время его разговоров.
Пример:Внешняя ссылка удалена администрацией - это нарушение п.3 Правил форума

Я покурил мануалы, почитал про промежуточную сумму, но проблема в том, что обычные числа он складывает хорошо, а время оставляет по нулям. Как не крути. Всю голову поломал. Формат ячеек менял на ч:мм:сс, на [ч]:мм:cc
Вообщем по разному пробовал. Где я ошибаюсь?

Автор - FasterQ
Дата добавления - 05.12.2019 в 13:51
китин Дата: Четверг, 05.12.2019, 13:53 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
FasterQ, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеFasterQ, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 05.12.2019 в 13:53
lebensvoll Дата: Четверг, 05.12.2019, 14:08 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1002
Репутация: 30 ±
Замечаний: 0% ±

Excel 2010
FasterQ, а вы искали материал для решения своей задачи!?
Может Вам это поможет My WebPage
Если и после не справитесь (((( то прислушайтесь к Игорю (модератору)!!! deal deal deal


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеFasterQ, а вы искали материал для решения своей задачи!?
Может Вам это поможет My WebPage
Если и после не справитесь (((( то прислушайтесь к Игорю (модератору)!!! deal deal deal

Автор - lebensvoll
Дата добавления - 05.12.2019 в 14:08
FasterQ Дата: Четверг, 05.12.2019, 14:11 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот
К сообщению приложен файл: Book_2.xlsx(9.3 Kb)
 
Ответить
СообщениеВот

Автор - FasterQ
Дата добавления - 05.12.2019 в 14:11
lebensvoll Дата: Четверг, 05.12.2019, 14:15 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1002
Репутация: 30 ±
Замечаний: 0% ±

Excel 2010
FasterQ, а материал не помог )))) !? что в ссылке
ТАК ПОДХОДИТ!? возможно
К сообщению приложен файл: 3727024.xlsx(12.2 Kb)


Кто бы ты ни был, мир в твоих руках

Сообщение отредактировал lebensvoll - Четверг, 05.12.2019, 14:28
 
Ответить
СообщениеFasterQ, а материал не помог )))) !? что в ссылке
ТАК ПОДХОДИТ!? возможно

Автор - lebensvoll
Дата добавления - 05.12.2019 в 14:15
FasterQ Дата: Четверг, 05.12.2019, 14:19 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Простое сложение времени, где A1+B1 работает прекрасно, но в формуле разряда: =ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;C2:C99)
Оно почему то выдаёт 0:00:00
 
Ответить
СообщениеПростое сложение времени, где A1+B1 работает прекрасно, но в формуле разряда: =ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;C2:C99)
Оно почему то выдаёт 0:00:00

Автор - FasterQ
Дата добавления - 05.12.2019 в 14:19
_Boroda_ Дата: Четверг, 05.12.2019, 14:25 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16356
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У Вас время текстом. Выделите столбец С, вкладка Данные - Текст по столбцам - Готово. После этого формула заработает

Или используйте формулу
Код
=СУММПРОИЗВ((B$2:B$99=B2)*C$2:C$99)
К сообщению приложен файл: Book_21.xlsx(9.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ Вас время текстом. Выделите столбец С, вкладка Данные - Текст по столбцам - Готово. После этого формула заработает

Или используйте формулу
Код
=СУММПРОИЗВ((B$2:B$99=B2)*C$2:C$99)

Автор - _Boroda_
Дата добавления - 05.12.2019 в 14:25
FasterQ Дата: Четверг, 05.12.2019, 17:20 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое! Помог Текст по столбцам!
 
Ответить
СообщениеСпасибо большое! Помог Текст по столбцам!

Автор - FasterQ
Дата добавления - 05.12.2019 в 17:20
Wildmechanic Дата: Понедельник, 09.12.2019, 09:22 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
FasterQ,

например, функцией СУММЕСЛИМН


"Сделать сложно - это очень просто, а вот сделать просто - это очень сложно" (С)
 
Ответить
СообщениеFasterQ,

например, функцией СУММЕСЛИМН

Автор - Wildmechanic
Дата добавления - 09.12.2019 в 09:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование времени по фильтру (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!