Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Самые частые сочетания позиций в продажах - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Самые частые сочетания позиций в продажах (Формулы/Formulas)
Самые частые сочетания позиций в продажах
Flatcher Дата: Среда, 11.12.2019, 06:14 | Сообщение № 1
Группа: Проверенные
Ранг: Участник
Сообщений: 90
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Подскажите пожалуйста как на основе данных о продажах по чекам получить информацию какие позиции чаще всего берут/покупают вместе с друг другом. Идея в том чтобы отловить такие позиции и сделать к новому году популярную корзину с очень хорошей скидкой
К сообщению приложен файл: 8309998.xlsx(9.5 Kb)


Сообщение отредактировал Flatcher - Среда, 11.12.2019, 08:30
 
Ответить
СообщениеЗдравствуйте! Подскажите пожалуйста как на основе данных о продажах по чекам получить информацию какие позиции чаще всего берут/покупают вместе с друг другом. Идея в том чтобы отловить такие позиции и сделать к новому году популярную корзину с очень хорошей скидкой

Автор - Flatcher
Дата добавления - 11.12.2019 в 06:14
dude Дата: Четверг, 12.12.2019, 18:05 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 193
Репутация: 28 ±
Замечаний: 0% ±

2016
можно так
Код
=СУММ(ЕЧИСЛО(B3:G3)*10^(СТОЛБЕЦ(B3:G3)-1))

и
Код
=СЧЁТЕСЛИ($H$3:$H$10;H3)
К сообщению приложен файл: 3641162.xlsx(10.9 Kb)
 
Ответить
Сообщениеможно так
Код
=СУММ(ЕЧИСЛО(B3:G3)*10^(СТОЛБЕЦ(B3:G3)-1))

и
Код
=СЧЁТЕСЛИ($H$3:$H$10;H3)

Автор - dude
Дата добавления - 12.12.2019 в 18:05
Светлый Дата: Четверг, 12.12.2019, 19:11 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Для данной конкретной таблицы. При изменении количества столбцов надо будет переделать {}.
Количество совпадений:
Код
=НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({1;1;1;1;1;2;2;2;2;3;3;3;4;4;5};)))*ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({2;3;4;5;6;3;4;5;6;4;5;6;5;6;6};)))>0));СТРОКА(B1))
И два столбца парных названий:
Код
=ИНДЕКС($B$2:$G$2;;ПРАВБ(НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({1;1;1;1;1;2;2;2;2;3;3;3;4;4;5};)))*ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({2;3;4;5;6;3;4;5;6;4;5;6;5;6;6};)))>0))*1000+{12;13;14;15;16;23;24;25;26;34;35;36;45;46;56};СТРОКА(B1));СТОЛБЕЦ(A1))/10^(СТОЛБЕЦ(A1)-1))
*
Код
=НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(Ч(СМЕЩ($A$2;СТРОКА($1:$8);{1;1;1;1;1;2;2;2;2;3;3;3;4;4;5}))*Ч(СМЕЩ($A$2;СТРОКА($1:$8);{2;3;4;5;6;3;4;5;6;4;5;6;5;6;6}))>0));СТРОКА(B1))
Код
=ИНДЕКС($B$2:$G$2;;ПРАВБ(НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(Ч(СМЕЩ($A$2;СТРОКА($1:$8);{1;1;1;1;1;2;2;2;2;3;3;3;4;4;5}))*Ч(СМЕЩ($A$2;СТРОКА($1:$8);{2;3;4;5;6;3;4;5;6;4;5;6;5;6;6}))>0))*1000+{12;13;14;15;16;23;24;25;26;34;35;36;45;46;56};СТРОКА(B1));СТОЛБЕЦ(A1))/10^(СТОЛБЕЦ(A1)-1))
Файл перезалил.
**Почти универсальные формулы. Файл опять перезалил.
К сообщению приложен файл: 8309998-1.xlsx(11.6 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 12.12.2019, 21:02
 
Ответить
СообщениеДля данной конкретной таблицы. При изменении количества столбцов надо будет переделать {}.
Количество совпадений:
Код
=НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({1;1;1;1;1;2;2;2;2;3;3;3;4;4;5};)))*ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({2;3;4;5;6;3;4;5;6;4;5;6;5;6;6};)))>0));СТРОКА(B1))
И два столбца парных названий:
Код
=ИНДЕКС($B$2:$G$2;;ПРАВБ(НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({1;1;1;1;1;2;2;2;2;3;3;3;4;4;5};)))*ИНДЕКС($B$3:$G$10;Ч(ИНДЕКС(СТРОКА($1:$8);));Ч(ИНДЕКС({2;3;4;5;6;3;4;5;6;4;5;6;5;6;6};)))>0))*1000+{12;13;14;15;16;23;24;25;26;34;35;36;45;46;56};СТРОКА(B1));СТОЛБЕЦ(A1))/10^(СТОЛБЕЦ(A1)-1))
*
Код
=НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(Ч(СМЕЩ($A$2;СТРОКА($1:$8);{1;1;1;1;1;2;2;2;2;3;3;3;4;4;5}))*Ч(СМЕЩ($A$2;СТРОКА($1:$8);{2;3;4;5;6;3;4;5;6;4;5;6;5;6;6}))>0));СТРОКА(B1))
Код
=ИНДЕКС($B$2:$G$2;;ПРАВБ(НАИБОЛЬШИЙ(МУМНОЖ(СТОЛБЕЦ(A:H)^0;Ч(Ч(СМЕЩ($A$2;СТРОКА($1:$8);{1;1;1;1;1;2;2;2;2;3;3;3;4;4;5}))*Ч(СМЕЩ($A$2;СТРОКА($1:$8);{2;3;4;5;6;3;4;5;6;4;5;6;5;6;6}))>0))*1000+{12;13;14;15;16;23;24;25;26;34;35;36;45;46;56};СТРОКА(B1));СТОЛБЕЦ(A1))/10^(СТОЛБЕЦ(A1)-1))
Файл перезалил.
**Почти универсальные формулы. Файл опять перезалил.

Автор - Светлый
Дата добавления - 12.12.2019 в 19:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Самые частые сочетания позиций в продажах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!