Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значения из таблицы при совпадении 2 условий - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из таблицы при совпадении 2 условий (Формулы/Formulas)
Выбор значения из таблицы при совпадении 2 условий
taveselo Дата: Среда, 11.12.2019, 12:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!

Подскажите, пожалуйста, как решить такую задачу: есть две таблицы, из первой таблицы нужно выбрать значение ячейки (тестовый формат) при совпадении двух условий сравнения данных между данными 1-й и 2-й таблиц и проставить эти значения во вторую таблицу, если условия верны. См. пример

Заранее спасибо за помощь!
К сообщению приложен файл: 6512264.xlsx(10.4 Kb)


Сообщение отредактировал taveselo - Среда, 11.12.2019, 12:41
 
Ответить
СообщениеДобрый день!

Подскажите, пожалуйста, как решить такую задачу: есть две таблицы, из первой таблицы нужно выбрать значение ячейки (тестовый формат) при совпадении двух условий сравнения данных между данными 1-й и 2-й таблиц и проставить эти значения во вторую таблицу, если условия верны. См. пример

Заранее спасибо за помощь!

Автор - taveselo
Дата добавления - 11.12.2019 в 12:40
alexa1965 Дата: Среда, 11.12.2019, 13:00 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 260
Репутация: 20 ±
Замечаний: 0% ±

2003> 2010> 2016
Наверно так?
Код
=ИНДЕКС(A4:C13;ПОИСКПОЗ(K4;A4:A13;0);3)


Главное не быть балабастиком
 
Ответить
СообщениеНаверно так?
Код
=ИНДЕКС(A4:C13;ПОИСКПОЗ(K4;A4:A13;0);3)

Автор - alexa1965
Дата добавления - 11.12.2019 в 13:00
китин Дата: Среда, 11.12.2019, 13:00 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
так?
Код
=ПРОСМОТР(2;1/(($K4=$A$4:$A$13)*($M4=$B$4:$B$13));$C$4:$C$13)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениетак?
Код
=ПРОСМОТР(2;1/(($K4=$A$4:$A$13)*($M4=$B$4:$B$13));$C$4:$C$13)

Автор - китин
Дата добавления - 11.12.2019 в 13:00
_Boroda_ Дата: Среда, 11.12.2019, 13:37 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16359
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
alexa1965, доллары?
Код
=ИНДЕКС(C$4:C$13;ПОИСКПОЗ(K4;A$4:A$13;))

Если только по городу, то можно и
Код
=ВПР(M4;B$4:C$13;2;)

Еще вариант с ПРОСМОТРом
Код
=ПРОСМОТР(2;1/(K4&M4=A$4:A$13&B$4:B$13);C$4:C$13)

И с ВПР
Код
=ВПР(K4&M4;A$4:C$13&B$4:D$13;3;)

И с ИНДЕКСом
Код
=ИНДЕКС(C$4:C$13;ПОИСКПОЗ(K4&M4;A$4:A$13&B$4:B$13;))

Две последние - формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 6512264_1.xlsx(11.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеalexa1965, доллары?
Код
=ИНДЕКС(C$4:C$13;ПОИСКПОЗ(K4;A$4:A$13;))

Если только по городу, то можно и
Код
=ВПР(M4;B$4:C$13;2;)

Еще вариант с ПРОСМОТРом
Код
=ПРОСМОТР(2;1/(K4&M4=A$4:A$13&B$4:B$13);C$4:C$13)

И с ВПР
Код
=ВПР(K4&M4;A$4:C$13&B$4:D$13;3;)

И с ИНДЕКСом
Код
=ИНДЕКС(C$4:C$13;ПОИСКПОЗ(K4&M4;A$4:A$13&B$4:B$13;))

Две последние - формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 11.12.2019 в 13:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из таблицы при совпадении 2 условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!