Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Cуммирование ячеек в плавающем диапазоне. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Cуммирование ячеек в плавающем диапазоне. (Формулы/Formulas)
Cуммирование ячеек в плавающем диапазоне.
Macar Дата: Понедельник, 16.12.2019, 10:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!

Прошу Вас, помочь с решением проблемы с суммированием ячеек при определенном условии в плавающем диапазоне.

Имеется Два столбца B(Длина сегмента) и C(Угол градусы) получаемый из Autocad. Число сток может быть в несколько тысяч.
В столбце D(Угол) мы получаем нужный нам угол и обнуляем не нужные углы.
В столбце E(метраж) хочется получить следующий результат.

Например: в приложенном файле, считаем ячейку E23, если в столбце D(Угол) в значение в вышестоящей ячейке или ячейках равно 0 (изменяющийся диапазон) в примере диапазон D22:D15, то суммируем диапазон по столбцу B(Длина сегмента) B23:B15.

В приложенном файле, красным отметил строки с нужным результатом.(просто сейчас это делается в ручную). Надеюсь есть возможность автоматизировать данный процесс.

P.S. С Наступающим Новым Годом!
К сообщению приложен файл: 11111.xlsx(47.3 Kb)
 
Ответить
СообщениеЗдравствуйте!

Прошу Вас, помочь с решением проблемы с суммированием ячеек при определенном условии в плавающем диапазоне.

Имеется Два столбца B(Длина сегмента) и C(Угол градусы) получаемый из Autocad. Число сток может быть в несколько тысяч.
В столбце D(Угол) мы получаем нужный нам угол и обнуляем не нужные углы.
В столбце E(метраж) хочется получить следующий результат.

Например: в приложенном файле, считаем ячейку E23, если в столбце D(Угол) в значение в вышестоящей ячейке или ячейках равно 0 (изменяющийся диапазон) в примере диапазон D22:D15, то суммируем диапазон по столбцу B(Длина сегмента) B23:B15.

В приложенном файле, красным отметил строки с нужным результатом.(просто сейчас это делается в ручную). Надеюсь есть возможность автоматизировать данный процесс.

P.S. С Наступающим Новым Годом!

Автор - Macar
Дата добавления - 16.12.2019 в 10:43
Pelena Дата: Понедельник, 16.12.2019, 11:10 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Как вариант
Код
=ЕСЛИ(D2=0;B2;ЕСЛИОШИБКА(СУММ(ИНДЕКС($B1:B$2;ЕСЛИОШИБКА(АГРЕГАТ(14;6;($A1:A$2+1)/($D1:D$2>0);1);1)):B2);B2))
К сообщению приложен файл: 7304795.xlsx(47.7 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Как вариант
Код
=ЕСЛИ(D2=0;B2;ЕСЛИОШИБКА(СУММ(ИНДЕКС($B1:B$2;ЕСЛИОШИБКА(АГРЕГАТ(14;6;($A1:A$2+1)/($D1:D$2>0);1);1)):B2);B2))

Автор - Pelena
Дата добавления - 16.12.2019 в 11:10
_Boroda_ Дата: Понедельник, 16.12.2019, 11:12 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=ЕСЛИ(D2>0;СУММ(B$1:B2)-СУММЕСЛИ(D$1:D1;">0";E$1:E1);B2)
К сообщению приложен файл: 11111-2-1.xlsx(46.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИ(D2>0;СУММ(B$1:B2)-СУММЕСЛИ(D$1:D1;">0";E$1:E1);B2)

Автор - _Boroda_
Дата добавления - 16.12.2019 в 11:12
Macar Дата: Понедельник, 16.12.2019, 12:55 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Большое спасибо за быстрый ответ и помощь. Очень красивые решения.
 
Ответить
СообщениеБольшое спасибо за быстрый ответ и помощь. Очень красивые решения.

Автор - Macar
Дата добавления - 16.12.2019 в 12:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Cуммирование ячеек в плавающем диапазоне. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!