Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Помогите создать список сотрудников по критерию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Помогите создать список сотрудников по критерию (Формулы/Formulas)
Помогите создать список сотрудников по критерию
OlegOV Дата: Понедельник, 16.12.2019, 14:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Помогите создать формулу или макрос по созданию определенного списка персонала (см.лист "список персонала") по критерию, т.е. по начальникам управлений.
К сообщению приложен файл: 5423248.xlsx(16.5 Kb)
 
Ответить
СообщениеДобрый день! Помогите создать формулу или макрос по созданию определенного списка персонала (см.лист "список персонала") по критерию, т.е. по начальникам управлений.

Автор - OlegOV
Дата добавления - 16.12.2019 в 14:51
Светлый Дата: Понедельник, 16.12.2019, 14:59 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Добрый день!
И какой же критерий?


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
И какой же критерий?

Автор - Светлый
Дата добавления - 16.12.2019 в 14:59
китин Дата: Понедельник, 16.12.2019, 15:00 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6896
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
OlegOV, а зачем дублировать темы? это грубейшее нарушение Правил форума. Вам надо было просто поменять название вашей прошлой темы. Дубль закрыл


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеOlegOV, а зачем дублировать темы? это грубейшее нарушение Правил форума. Вам надо было просто поменять название вашей прошлой темы. Дубль закрыл

Автор - китин
Дата добавления - 16.12.2019 в 15:00
OlegOV Дата: Понедельник, 16.12.2019, 15:07 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 16.12.2019 в 14:59, в сообщении № 2 ()
И какой же критерий?

Критерий по начальникам управлений, имеется выпадающий список А1, выделен цветом.
 
Ответить
Сообщение
Цитата Светлый, 16.12.2019 в 14:59, в сообщении № 2 ()
И какой же критерий?

Критерий по начальникам управлений, имеется выпадающий список А1, выделен цветом.

Автор - OlegOV
Дата добавления - 16.12.2019 в 15:07
OlegOV Дата: Понедельник, 16.12.2019, 15:08 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
OlegOV, а зачем дублировать темы? это грубейшее нарушение Правил форума. Вам надо было просто поменять название вашей прошлой темы. Дубль закрыл


Спасибо за понимание)
 
Ответить
Сообщение
OlegOV, а зачем дублировать темы? это грубейшее нарушение Правил форума. Вам надо было просто поменять название вашей прошлой темы. Дубль закрыл


Спасибо за понимание)

Автор - OlegOV
Дата добавления - 16.12.2019 в 15:08
OlegOV Дата: Понедельник, 16.12.2019, 15:12 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 16.12.2019 в 14:59, в сообщении № 2 ()
И какой же критерий?

Лист1 - отражает список предприятия, в Лист3 нужно сформировать список сотрудников по выпадающему списку А1. Количество сотрудников в Лист1 может меняться как в большую так и в меньшую сторону.
 
Ответить
Сообщение
Цитата Светлый, 16.12.2019 в 14:59, в сообщении № 2 ()
И какой же критерий?

Лист1 - отражает список предприятия, в Лист3 нужно сформировать список сотрудников по выпадающему списку А1. Количество сотрудников в Лист1 может меняться как в большую так и в меньшую сторону.

Автор - OlegOV
Дата добавления - 16.12.2019 в 15:12
китин Дата: Понедельник, 16.12.2019, 15:23 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6896
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
чисто по вопросу:
созданию определенного списка персонала (см.лист "список персонала") по критерию

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$263;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Лист1!$A$2:$A$263;Лист1!$A$2:$A$263;0)=СТРОКА($C$2:$C$263)-1)*(Лист1!$C$2:$C$263=Лист3!$A$1);СТРОКА($C$2:$C$263)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
на лист4 при помощи Pouer Qwery сделал список уникальных групп( обновляемый)
К сообщению приложен файл: 6943148.xlsx(30.1 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениечисто по вопросу:
созданию определенного списка персонала (см.лист "список персонала") по критерию

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$263;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Лист1!$A$2:$A$263;Лист1!$A$2:$A$263;0)=СТРОКА($C$2:$C$263)-1)*(Лист1!$C$2:$C$263=Лист3!$A$1);СТРОКА($C$2:$C$263)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
на лист4 при помощи Pouer Qwery сделал список уникальных групп( обновляемый)

Автор - китин
Дата добавления - 16.12.2019 в 15:23
OlegOV Дата: Понедельник, 16.12.2019, 15:42 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
на лист4 при помощи Pouer Qwery сделал список уникальных групп( обновляемый)

Огромное спасибо!! Две недели мучался...
 
Ответить
Сообщение
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
на лист4 при помощи Pouer Qwery сделал список уникальных групп( обновляемый)

Огромное спасибо!! Две недели мучался...

Автор - OlegOV
Дата добавления - 16.12.2019 в 15:42
OlegOV Дата: Среда, 18.12.2019, 07:34 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$263;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Лист1!$A$2:$A$263;Лист1!$A$2:$A$263;0)=СТРОКА($C$2:$C$263)-1)*(Лист1!$C$2:$C$263=Лист3!$A$1);СТРОКА($C$2:$C$263)-1);СТРОКА(A1)));"")

Здравствуйте!
Изменился количественный состав персонала, внёс изменение в формулу, т.е. изменил диапазон с $A$2:$A$263/C$2:$C$263 на $A$2:$A$2500/C$2:$C$2500 во всей формуле и всё, перестала работать, т.е. не ищет ФИО оставляет пустую ячейку. Почему так происходит?
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$263;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ(Лист1!$A$2:$A$263;Лист1!$A$2:$A$263;0)=СТРОКА($C$2:$C$263)-1)*(Лист1!$C$2:$C$263=Лист3!$A$1);СТРОКА($C$2:$C$263)-1);СТРОКА(A1)));"")

Здравствуйте!
Изменился количественный состав персонала, внёс изменение в формулу, т.е. изменил диапазон с $A$2:$A$263/C$2:$C$263 на $A$2:$A$2500/C$2:$C$2500 во всей формуле и всё, перестала работать, т.е. не ищет ФИО оставляет пустую ячейку. Почему так происходит?

Автор - OlegOV
Дата добавления - 18.12.2019 в 07:34
Светлый Дата: Среда, 18.12.2019, 07:52 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Можно НАИМЕНЬШИЙ заменить на АГРЕГАТ с игнорированием ошибок.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$2630;АГРЕГАТ(15;6;ЕСЛИ((ПОИСКПОЗ(Лист1!$A$2:$A$2630;Лист1!$A$2:$A$2630;)=СТРОКА($1:$2629))*(Лист1!$C$2:$C$2630=Лист3!$A$1);СТРОКА($1:$2629));СТРОКА(A1)));"")
*Или использовать массивную (Ctrl+Shift+Enter) формулу:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$2630;ПОИСКПОЗ(1;(Лист1!$C$2:$C$2630=$A$1)*(СЧЁТЕСЛИ(A$3:A3;Лист1!A$2:A$2630)=0);));"")
**Если порядок сортировки неважен, можно такой формулой:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;СЧЁТЕСЛИ(A$3:A3;Лист1!A$2:A$2630)/(Лист1!C$2:C$2630=A$1);Лист1!A$2:A$2630);"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 18.12.2019, 08:41
 
Ответить
СообщениеМожно НАИМЕНЬШИЙ заменить на АГРЕГАТ с игнорированием ошибок.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$2630;АГРЕГАТ(15;6;ЕСЛИ((ПОИСКПОЗ(Лист1!$A$2:$A$2630;Лист1!$A$2:$A$2630;)=СТРОКА($1:$2629))*(Лист1!$C$2:$C$2630=Лист3!$A$1);СТРОКА($1:$2629));СТРОКА(A1)));"")
*Или использовать массивную (Ctrl+Shift+Enter) формулу:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!A$2:A$2630;ПОИСКПОЗ(1;(Лист1!$C$2:$C$2630=$A$1)*(СЧЁТЕСЛИ(A$3:A3;Лист1!A$2:A$2630)=0);));"")
**Если порядок сортировки неважен, можно такой формулой:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;СЧЁТЕСЛИ(A$3:A3;Лист1!A$2:A$2630)/(Лист1!C$2:C$2630=A$1);Лист1!A$2:A$2630);"")

Автор - Светлый
Дата добавления - 18.12.2019 в 07:52
OlegOV Дата: Среда, 18.12.2019, 08:23 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Цитата Светлый, 18.12.2019 в 07:52, в сообщении № 10 ()
Можно НАИМЕНЬШИЙ заменить на АГРЕГАТ с игнорированием ошибок.

РАБОТАЕТ))) Спасибо!
 
Ответить
Сообщение
Цитата Светлый, 18.12.2019 в 07:52, в сообщении № 10 ()
Можно НАИМЕНЬШИЙ заменить на АГРЕГАТ с игнорированием ошибок.

РАБОТАЕТ))) Спасибо!

Автор - OlegOV
Дата добавления - 18.12.2019 в 08:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Помогите создать список сотрудников по критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!