Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт кол-ва ячеек в таблице с одинаковыми пунктами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт кол-ва ячеек в таблице с одинаковыми пунктами (Формулы/Formulas)
Подсчёт кол-ва ячеек в таблице с одинаковыми пунктами
Uncle_Cyrus Дата: Четверг, 19.12.2019, 08:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Утречко доброе!
Я тут с формулами балуюсь и не могу сообразить как подсчитать количество заполненных и не заполненных ячеек в таблице по месяцам (месяцы особо не нужны мне, хотя бы за 1 месяц прикинуть). Есть 6 пунктов и по каждому одинаковому пункту нужно посчитать заполненные ячейки.... Эм... Чего ляпнул.... В общем, есть столбики в таблице "Число первое" и "Число второе", их нужно посчитать по повторяющимся пунктам в строках в отдельности и вывести результат в нижней таблице. Сколько заполненных ячеек по данному пункту в таблице. (Извиняюсь за тофталогию...)
ВПР? ПОИСКПОЗ и ИНДЕКС? Пытался с СЧЁТ, СЧЁТЕСЛИМН... Не получается формула... Но СЧЁТ*** Должна присутствовать наверняка, я думаю, раз это подсчёт ячеек. А дальше ПОИСКПОЗ и ИНДЕКС, видимо я делаю что-то неправильно... :'(
Вооот. ^_^
К сообщению приложен файл: __Uncle_Cyrus.xlsx(41.2 Kb)


Подожди-подожди...
Щас сколдую....
 
Ответить
СообщениеУтречко доброе!
Я тут с формулами балуюсь и не могу сообразить как подсчитать количество заполненных и не заполненных ячеек в таблице по месяцам (месяцы особо не нужны мне, хотя бы за 1 месяц прикинуть). Есть 6 пунктов и по каждому одинаковому пункту нужно посчитать заполненные ячейки.... Эм... Чего ляпнул.... В общем, есть столбики в таблице "Число первое" и "Число второе", их нужно посчитать по повторяющимся пунктам в строках в отдельности и вывести результат в нижней таблице. Сколько заполненных ячеек по данному пункту в таблице. (Извиняюсь за тофталогию...)
ВПР? ПОИСКПОЗ и ИНДЕКС? Пытался с СЧЁТ, СЧЁТЕСЛИМН... Не получается формула... Но СЧЁТ*** Должна присутствовать наверняка, я думаю, раз это подсчёт ячеек. А дальше ПОИСКПОЗ и ИНДЕКС, видимо я делаю что-то неправильно... :'(
Вооот. ^_^

Автор - Uncle_Cyrus
Дата добавления - 19.12.2019 в 08:43
китин Дата: Четверг, 19.12.2019, 09:09 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6047
Репутация: 935 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам доброго!!!
как понял
для не пустых
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(ПСТР($AD53;ПОИСК(".";$AD53)+1;ДЛСТР($AD53)))=(СЖПРОБЕЛЫ(ПСТР($AD$16:$AD$45;ПОИСК(".";$AD$16:$AD$45)+1;ДЛСТР($AD$16:$AD$45)))))*(AE$16:AE$45<>""))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: _Uncle_Cyrus.xlsx(51.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам доброго!!!
как понял
для не пустых
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(ПСТР($AD53;ПОИСК(".";$AD53)+1;ДЛСТР($AD53)))=(СЖПРОБЕЛЫ(ПСТР($AD$16:$AD$45;ПОИСК(".";$AD$16:$AD$45)+1;ДЛСТР($AD$16:$AD$45)))))*(AE$16:AE$45<>""))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 19.12.2019 в 09:09
_Boroda_ Дата: Четверг, 19.12.2019, 09:21 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15747
Репутация: 6143 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А я так понял
Код
=СЧЁТЕСЛИМН($AD$16:$AD52;$AD53;AE$16:AE52;"?*")

Код
=СЧЁТЕСЛИМН($AD$16:$AD$45;$AD63;AE$16:AE$45;"")


Первую формулу можно так еще
Код
=СЧЁТЕСЛИ($AD$16:$AD$45;$AD53)-AE63
К сообщению приложен файл: _Uncle_Cyrus_2.xlsx(43.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА я так понял
Код
=СЧЁТЕСЛИМН($AD$16:$AD52;$AD53;AE$16:AE52;"?*")

Код
=СЧЁТЕСЛИМН($AD$16:$AD$45;$AD63;AE$16:AE$45;"")


Первую формулу можно так еще
Код
=СЧЁТЕСЛИ($AD$16:$AD$45;$AD53)-AE63

Автор - _Boroda_
Дата добавления - 19.12.2019 в 09:21
Uncle_Cyrus Дата: Четверг, 19.12.2019, 09:30 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Идеально! shock
Я не рассматривал подобные формулы... Теперь я буду знать больше. Спасибо. hands respect


Подожди-подожди...
Щас сколдую....
 
Ответить
СообщениеИдеально! shock
Я не рассматривал подобные формулы... Теперь я буду знать больше. Спасибо. hands respect

Автор - Uncle_Cyrus
Дата добавления - 19.12.2019 в 09:30
Uncle_Cyrus Дата: Четверг, 19.12.2019, 09:34 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
И второй вариант подходит. Значит я не до конца понял эти формулы. Даже компактнее. Отлично! Ещё раз спасибо! hands


Подожди-подожди...
Щас сколдую....


Сообщение отредактировал Uncle_Cyrus - Четверг, 19.12.2019, 09:37
 
Ответить
СообщениеИ второй вариант подходит. Значит я не до конца понял эти формулы. Даже компактнее. Отлично! Ещё раз спасибо! hands

Автор - Uncle_Cyrus
Дата добавления - 19.12.2019 в 09:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт кол-ва ячеек в таблице с одинаковыми пунктами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!