Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Динамическая сортировка таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамическая сортировка таблицы (Формулы/Formulas)
Динамическая сортировка таблицы
mv87 Дата: Вторник, 24.12.2019, 12:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет.Сломал голову всю.
Лист "Январь"
Слева каждый день будут заносится расходы
Как сделать через формулы так,чтобы при занесении расходов слева, справа таблица динамически сортировалась по убыванию сумм расходов (Наибольшая категория-сумма-%)
Как сделать через макрос,я понял.и делал.Но минус в том,что онлайн редактирование файла через облако не поддерживает макросы.А каждый раз качать файл из облака,потом снова загружать очень неудобно.
Спасибо
К сообщению приложен файл: _2020.xlsx(20.2 Kb)


Сообщение отредактировал mv87 - Вторник, 24.12.2019, 13:01
 
Ответить
СообщениеВсем привет.Сломал голову всю.
Лист "Январь"
Слева каждый день будут заносится расходы
Как сделать через формулы так,чтобы при занесении расходов слева, справа таблица динамически сортировалась по убыванию сумм расходов (Наибольшая категория-сумма-%)
Как сделать через макрос,я понял.и делал.Но минус в том,что онлайн редактирование файла через облако не поддерживает макросы.А каждый раз качать файл из облака,потом снова загружать очень неудобно.
Спасибо

Автор - mv87
Дата добавления - 24.12.2019 в 12:58
Anton2201 Дата: Вторник, 24.12.2019, 13:13 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Ну как вариант сделать сводную таблицу с вычисляемым полем. Такой вариант вас не устроит?


Сообщение отредактировал Anton2201 - Вторник, 24.12.2019, 13:13
 
Ответить
СообщениеНу как вариант сделать сводную таблицу с вычисляемым полем. Такой вариант вас не устроит?

Автор - Anton2201
Дата добавления - 24.12.2019 в 13:13
китин Дата: Вторник, 24.12.2019, 13:15 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6279
Репутация: 963 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Привет!!!
так?
Код
=ИНДЕКС(Категория_расхода;ПОИСКПОЗ(НАИБОЛЬШИЙ((Доля);СТРОКА(A1));Доля;0))
К сообщению приложен файл: 2103369.xlsx(21.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеПривет!!!
так?
Код
=ИНДЕКС(Категория_расхода;ПОИСКПОЗ(НАИБОЛЬШИЙ((Доля);СТРОКА(A1));Доля;0))

Автор - китин
Дата добавления - 24.12.2019 в 13:15
mv87 Дата: Вторник, 24.12.2019, 14:16 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Привет!!!
так?

Так!
Только таблица другая.Большая которая.
 
Ответить
Сообщение
Привет!!!
так?

Так!
Только таблица другая.Большая которая.

Автор - mv87
Дата добавления - 24.12.2019 в 14:16
китин Дата: Вторник, 24.12.2019, 14:29 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6279
Репутация: 963 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
тады так
К сообщению приложен файл: 9535712.xlsx(20.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетады так

Автор - китин
Дата добавления - 24.12.2019 в 14:29
mv87 Дата: Вторник, 24.12.2019, 15:00 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
тады так

О да.
Спасибо! это облегчило мою жизнь.
 
Ответить
Сообщение
тады так

О да.
Спасибо! это облегчило мою жизнь.

Автор - mv87
Дата добавления - 24.12.2019 в 15:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамическая сортировка таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!