Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных из двух таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных из двух таблиц (Формулы/Formulas)
Выборка данных из двух таблиц
AVI Дата: Среда, 25.12.2019, 10:12 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 518
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Выбирая из значений в ячейке B19 должна получаться выборка из двух таблиц: из первой выбирается "оборудование", из второй выбирается "мп". Но у меня получается только из одной и я не знаю как добавить выбор из второй
К сообщению приложен файл: 6794876.xlsx(9.4 Kb)
 
Ответить
СообщениеВыбирая из значений в ячейке B19 должна получаться выборка из двух таблиц: из первой выбирается "оборудование", из второй выбирается "мп". Но у меня получается только из одной и я не знаю как добавить выбор из второй

Автор - AVI
Дата добавления - 25.12.2019 в 10:12
YouGreed Дата: Среда, 25.12.2019, 10:41 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 559
Репутация: 118 ±
Замечаний: 0% ±

Excel 2010
AVI, Да простит меня, правообладатель первого массива:

Код
=ЕСЛИОШИБКА(ИНДЕКС($D$6:$D$15;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ($B$21:B21;$D$6:$D$15)=0)*($B$6:$B$15=$B$19)*($C$6:$C$15="Оборудование")*($D$6:$D$15<>""););));ЕСЛИОШИБКА(ИНДЕКС($J$6:$J$15;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ($B$21:B21;$J$6:$J$15)=0)*($H$6:$H$15=$B$19)*($I$6:$I$15="мп")*($J$6:$J$15<>""););));""))


[offtop]скопировал всю формулу и вставил в ошибку первого условия...
К сообщению приложен файл: 4080999.xlsx(10.1 Kb)


Сообщение отредактировал YouGreed - Среда, 25.12.2019, 10:43
 
Ответить
СообщениеAVI, Да простит меня, правообладатель первого массива:

Код
=ЕСЛИОШИБКА(ИНДЕКС($D$6:$D$15;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ($B$21:B21;$D$6:$D$15)=0)*($B$6:$B$15=$B$19)*($C$6:$C$15="Оборудование")*($D$6:$D$15<>""););));ЕСЛИОШИБКА(ИНДЕКС($J$6:$J$15;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ($B$21:B21;$J$6:$J$15)=0)*($H$6:$H$15=$B$19)*($I$6:$I$15="мп")*($J$6:$J$15<>""););));""))


[offtop]скопировал всю формулу и вставил в ошибку первого условия...

Автор - YouGreed
Дата добавления - 25.12.2019 в 10:41
bmv98rus Дата: Среда, 25.12.2019, 11:36 | Сообщение № 3
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 3082
Репутация: 535 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IF(ROW(A1)>COUNTIFS($B$6:$B$15;$B$19;$C$6:$C$15;"Оборудование");IFERROR(INDEX(J:J;SMALL(IF(($H$6:$H$15=$B$19)*($I$6:$I$15="мп");ROW($B$6:$B$15));ROW(A1)-COUNTIFS($B$6:$B$15;$B$19;$C$6:$C$15;"Оборудование")));"");INDEX(D:D;SMALL(IF(($B$6:$B$15=$B$19)*($C$6:$C$15="Оборудование");ROW($B$6:$B$15));ROW(A1))))
К сообщению приложен файл: Copy_of_1362.xlsx(14.5 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=IF(ROW(A1)>COUNTIFS($B$6:$B$15;$B$19;$C$6:$C$15;"Оборудование");IFERROR(INDEX(J:J;SMALL(IF(($H$6:$H$15=$B$19)*($I$6:$I$15="мп");ROW($B$6:$B$15));ROW(A1)-COUNTIFS($B$6:$B$15;$B$19;$C$6:$C$15;"Оборудование")));"");INDEX(D:D;SMALL(IF(($B$6:$B$15=$B$19)*($C$6:$C$15="Оборудование");ROW($B$6:$B$15));ROW(A1))))

Автор - bmv98rus
Дата добавления - 25.12.2019 в 11:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных из двух таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!