Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечение из таблицы определенных данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение из таблицы определенных данных (Формулы/Formulas)
Извлечение из таблицы определенных данных
parovoznik Дата: Воскресенье, 29.12.2019, 20:51 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 377
Репутация: 20 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер.
Имеется таблица-реестр учета выписанных счет фактур.
Рядом создана таблица оплат. Нужно по № счета(ввод в ячейку числа) извлечь данные о Клиенте и товаре и перенести в таблицу оплат. Что нужно изменить в формуле для корректного отображения данных?
К сообщению приложен файл: 7992335.xlsm(13.6 Kb)
 
Ответить
СообщениеДобрый вечер.
Имеется таблица-реестр учета выписанных счет фактур.
Рядом создана таблица оплат. Нужно по № счета(ввод в ячейку числа) извлечь данные о Клиенте и товаре и перенести в таблицу оплат. Что нужно изменить в формуле для корректного отображения данных?

Автор - parovoznik
Дата добавления - 29.12.2019 в 20:51
bigor Дата: Понедельник, 30.12.2019, 10:22 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 203
Репутация: 37 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте

Так? В L
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$8;НАИМЕНЬШИЙ(ЕСЛИ($K$3=$C$3:$C$8;СТРОКА($A$3:$A$8);99999);СТРОКА()-2)-2);"")

В M
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$8;НАИМЕНЬШИЙ(ЕСЛИ($K$3=$C$3:$C$8;СТРОКА($B$3:$B$8);"");СТРОКА()-2)-2);"")

массивные
К сообщению приложен файл: para_1.xlsm(9.2 Kb)
 
Ответить
СообщениеЗдравствуйте

Так? В L
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$8;НАИМЕНЬШИЙ(ЕСЛИ($K$3=$C$3:$C$8;СТРОКА($A$3:$A$8);99999);СТРОКА()-2)-2);"")

В M
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$8;НАИМЕНЬШИЙ(ЕСЛИ($K$3=$C$3:$C$8;СТРОКА($B$3:$B$8);"");СТРОКА()-2)-2);"")

массивные

Автор - bigor
Дата добавления - 30.12.2019 в 10:22
Nic70y Дата: Понедельник, 30.12.2019, 10:49 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6359
Репутация: 1402 ±
Замечаний: 0% ±

ru13;10;03
если строки счета идут подряд, то можно проще
K4
Код
=ЕСЛИ(СТРОКА(K1)<СЧЁТЕСЛИ(C$3:C$8;K3);K3;"")
L и т.п.
Код
=ЕСЛИ($K3="";"";ИНДЕКС(A:A;ПОИСКПОЗ($K3;$C:$C;)+СТРОКА(L1)-1))
К сообщению приложен файл: 4463314.xlsm(13.1 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениеесли строки счета идут подряд, то можно проще
K4
Код
=ЕСЛИ(СТРОКА(K1)<СЧЁТЕСЛИ(C$3:C$8;K3);K3;"")
L и т.п.
Код
=ЕСЛИ($K3="";"";ИНДЕКС(A:A;ПОИСКПОЗ($K3;$C:$C;)+СТРОКА(L1)-1))

Автор - Nic70y
Дата добавления - 30.12.2019 в 10:49
parovoznik Дата: Понедельник, 30.12.2019, 18:18 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 377
Репутация: 20 ±
Замечаний: 0% ±

Excel 2007
bigor, благодарю за ответ.ОТветы отображаются только в первой строке.
Если прописать выпадающий список в строку ниже -ответ пусто. :)
Nic70y, класс. Только столбец Оплачено ,грн. не всегда срабатывает. Бывает выписали 22тн ,а оплатитили 10.тн поэтому сумму оплаты вношу вручную. Но формула бомба. hands
 
Ответить
Сообщениеbigor, благодарю за ответ.ОТветы отображаются только в первой строке.
Если прописать выпадающий список в строку ниже -ответ пусто. :)
Nic70y, класс. Только столбец Оплачено ,грн. не всегда срабатывает. Бывает выписали 22тн ,а оплатитили 10.тн поэтому сумму оплаты вношу вручную. Но формула бомба. hands

Автор - parovoznik
Дата добавления - 30.12.2019 в 18:18
parovoznik Дата: Понедельник, 30.12.2019, 18:31 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 377
Репутация: 20 ±
Замечаний: 0% ±

Excel 2007
Ввел новые позиции счетов и одну из списка что было, но формула отображает разные значения
К сообщению приложен файл: 0042091.xlsm(12.6 Kb)
 
Ответить
СообщениеВвел новые позиции счетов и одну из списка что было, но формула отображает разные значения

Автор - parovoznik
Дата добавления - 30.12.2019 в 18:31
bigor Дата: Вторник, 31.12.2019, 11:11 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 203
Репутация: 37 ±
Замечаний: 0% ±

Excel 2016
И моя и Nic70y формулы работают по принципу один реестр один счет. номер счета вводится в K3
 
Ответить
СообщениеИ моя и Nic70y формулы работают по принципу один реестр один счет. номер счета вводится в K3

Автор - bigor
Дата добавления - 31.12.2019 в 11:11
parovoznik Дата: Вторник, 31.12.2019, 11:26 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 377
Репутация: 20 ±
Замечаний: 0% ±

Excel 2007
Мне нужно , что бы формулы работали и в ячейках ниже K3 :(
 
Ответить
СообщениеМне нужно , что бы формулы работали и в ячейках ниже K3 :(

Автор - parovoznik
Дата добавления - 31.12.2019 в 11:26
bigor Дата: Вторник, 31.12.2019, 14:11 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 203
Репутация: 37 ±
Замечаний: 0% ±

Excel 2016
Тогда , наверное, проще макросом сделать. Или со сводной помудрить
 
Ответить
СообщениеТогда , наверное, проще макросом сделать. Или со сводной помудрить

Автор - bigor
Дата добавления - 31.12.2019 в 14:11
parovoznik Дата: Вторник, 31.12.2019, 15:22 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 377
Репутация: 20 ±
Замечаний: 0% ±

Excel 2007
Как я понял это сделать формулами нельзя.надо создавать тему в разделе vba?
 
Ответить
СообщениеКак я понял это сделать формулами нельзя.надо создавать тему в разделе vba?

Автор - parovoznik
Дата добавления - 31.12.2019 в 15:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечение из таблицы определенных данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!