Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ранг с повторением значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранг с повторением значений (Формулы/Formulas)
Ранг с повторением значений
Art1111 Дата: Пятница, 03.01.2020, 19:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Подскажите, пожалуйста. Как сделать вот такой ранг, как изображен на картинке?
Проще говоря.
Есть разные значения.
Например: 0,1; 0,2; 0,2; 0,3; 0,3; 0,5
Нужно, чтобы результаты выводились без пропусков мест после повторных значений.
К сообщению приложен файл: 4577.xls(17.5 Kb)


Сообщение отредактировал Art1111 - Пятница, 03.01.2020, 19:19
 
Ответить
СообщениеПодскажите, пожалуйста. Как сделать вот такой ранг, как изображен на картинке?
Проще говоря.
Есть разные значения.
Например: 0,1; 0,2; 0,2; 0,3; 0,3; 0,5
Нужно, чтобы результаты выводились без пропусков мест после повторных значений.

Автор - Art1111
Дата добавления - 03.01.2020 в 19:17
Pelena Дата: Пятница, 03.01.2020, 19:54 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16218
Репутация: 3516 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как вариант
Код
=СУММПРОИЗВ((ПОИСКПОЗ($C$4:$C$9;$C$4:$C$9;0)=СТРОКА($C$4:$C$9)-3)*($C$4:$C$9<C4))+1
К сообщению приложен файл: 0877926.xls(24.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант
Код
=СУММПРОИЗВ((ПОИСКПОЗ($C$4:$C$9;$C$4:$C$9;0)=СТРОКА($C$4:$C$9)-3)*($C$4:$C$9<C4))+1

Автор - Pelena
Дата добавления - 03.01.2020 в 19:54
Art1111 Дата: Пятница, 03.01.2020, 20:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - Art1111
Дата добавления - 03.01.2020 в 20:09
Art1111 Дата: Пятница, 03.01.2020, 20:38 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, Если результат будет идти от наибольшего к наименьшему, то, что мне нужно будет изменить в самой формуле?
 
Ответить
СообщениеPelena, Если результат будет идти от наибольшего к наименьшему, то, что мне нужно будет изменить в самой формуле?

Автор - Art1111
Дата добавления - 03.01.2020 в 20:38
Pelena Дата: Пятница, 03.01.2020, 22:24 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16218
Репутация: 3516 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Очевидно, < заменить на >


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеОчевидно, < заменить на >

Автор - Pelena
Дата добавления - 03.01.2020 в 22:24
Art1111 Дата: Суббота, 04.01.2020, 00:47 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, Еще раз большое спасибо!!!
 
Ответить
СообщениеPelena, Еще раз большое спасибо!!!

Автор - Art1111
Дата добавления - 04.01.2020 в 00:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранг с повторением значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!