Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Собрать данные из одной таблицы в другой по 1 признаку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Собрать данные из одной таблицы в другой по 1 признаку (Формулы/Formulas)
Собрать данные из одной таблицы в другой по 1 признаку
Tomtik Дата: Воскресенье, 12.01.2020, 15:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
Я перечитала весь форум пробовала разные моменты. Но у меня не получается. Поэтому, как всегда, прошу помощи умных людей.
Есть список сотрудников с фамилиями, адресами, датами рождения и профессиями. В другой таблице необходимо собрать только людей с одной профессией.
Понятно, что это можно было бы через сводную таблицу сделать, но мне необходимо, чтобы данная таблица всегда висела, и при добавлении в 1 список, автоматически добавлялись в те таблицы, в которых они должны находиться по профессии.
Спасибо.
К сообщению приложен файл: 3527623.xlsx(16.6 Kb)
 
Ответить
СообщениеДобрый день.
Я перечитала весь форум пробовала разные моменты. Но у меня не получается. Поэтому, как всегда, прошу помощи умных людей.
Есть список сотрудников с фамилиями, адресами, датами рождения и профессиями. В другой таблице необходимо собрать только людей с одной профессией.
Понятно, что это можно было бы через сводную таблицу сделать, но мне необходимо, чтобы данная таблица всегда висела, и при добавлении в 1 список, автоматически добавлялись в те таблицы, в которых они должны находиться по профессии.
Спасибо.

Автор - Tomtik
Дата добавления - 12.01.2020 в 15:07
jakim Дата: Воскресенье, 12.01.2020, 15:53 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 955
Репутация: 249 ±
Замечаний: 0% ±

Excel 2010
Смотрите приложение с выпадвющим списком и формулой

Код
=IFERROR(INDEX(ВСЕ!A$2:A$20;AGGREGATE(15;6;ROW($1:$20)/(ВСЕ!$D$2:$D$17=$D$1);ROWS($3:3)));"")
К сообщению приложен файл: 8718356.xlsx(15.4 Kb)
 
Ответить
Сообщение
Смотрите приложение с выпадвющим списком и формулой

Код
=IFERROR(INDEX(ВСЕ!A$2:A$20;AGGREGATE(15;6;ROW($1:$20)/(ВСЕ!$D$2:$D$17=$D$1);ROWS($3:3)));"")

Автор - jakim
Дата добавления - 12.01.2020 в 15:53
Tomtik Дата: Воскресенье, 12.01.2020, 16:41 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
jakim, Спасибо огромное. Я даже не знала про АГРЕГАТ.
 
Ответить
Сообщениеjakim, Спасибо огромное. Я даже не знала про АГРЕГАТ.

Автор - Tomtik
Дата добавления - 12.01.2020 в 16:41
Che79 Дата: Воскресенье, 12.01.2020, 22:53 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1578
Репутация: 294 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Тамара, здравствуйте.
У Вас есть почти готовый вариант
Цитата
ИНДЕКС(Все!A2:A400;НАИМЕНЬШИЙ(ЕСЛИ(Все!D2:D400="Медсестра";СТРОКА(Все!A2:A400)-1;СТРОКА(A2)))
Там только со скобками разобраться и в обработчик ошибок завернуть. Вот так
Код
=ЕСЛИОШИБКА(ИНДЕКС(ВСЕ!A$2:A$500;НАИМЕНЬШИЙ(ЕСЛИ(ВСЕ!$D$2:$D$500="Медсестра ";СТРОКА($A$1:$A$499));СТРОКА($A1)));"")
Формула массива.
И обратите внимание, что в Вашем файле названия "Медсестра " и "Инспектор ОК " написаны именно так, с пробелом на конце.


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Воскресенье, 12.01.2020, 22:54
 
Ответить
СообщениеТамара, здравствуйте.
У Вас есть почти готовый вариант
Цитата
ИНДЕКС(Все!A2:A400;НАИМЕНЬШИЙ(ЕСЛИ(Все!D2:D400="Медсестра";СТРОКА(Все!A2:A400)-1;СТРОКА(A2)))
Там только со скобками разобраться и в обработчик ошибок завернуть. Вот так
Код
=ЕСЛИОШИБКА(ИНДЕКС(ВСЕ!A$2:A$500;НАИМЕНЬШИЙ(ЕСЛИ(ВСЕ!$D$2:$D$500="Медсестра ";СТРОКА($A$1:$A$499));СТРОКА($A1)));"")
Формула массива.
И обратите внимание, что в Вашем файле названия "Медсестра " и "Инспектор ОК " написаны именно так, с пробелом на конце.

Автор - Che79
Дата добавления - 12.01.2020 в 22:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Собрать данные из одной таблицы в другой по 1 признаку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!