Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка ячеек по содержащимся в них значениям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка ячеек по содержащимся в них значениям (Формулы/Formulas)
Выборка ячеек по содержащимся в них значениям
Alleksdom Дата: Четверг, 16.01.2020, 16:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Есть таблица лист 1 и 2. В 1-ый вносится информация, необходимо из 1-ой во 2-ую подтягивать те строки, в которых в столбце D, присутствует "КП".
 
Ответить
СообщениеДобрый день. Есть таблица лист 1 и 2. В 1-ый вносится информация, необходимо из 1-ой во 2-ую подтягивать те строки, в которых в столбце D, присутствует "КП".

Автор - Alleksdom
Дата добавления - 16.01.2020 в 16:27
Alleksdom Дата: Четверг, 16.01.2020, 16:27 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Забыл прикрепить файл
К сообщению приложен файл: 3019445.xlsx(34.0 Kb)
 
Ответить
СообщениеЗабыл прикрепить файл

Автор - Alleksdom
Дата добавления - 16.01.2020 в 16:27
Nic70y Дата: Четверг, 16.01.2020, 16:49 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5824
Репутация: 1274 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИОШИБКА(ИНДЕКС('1'!A:A;ПОИСКПОЗ("КП*";ИНДЕКС('1'!D:D;ПОИСКПОЗ(A1;'1'!A:A;)+1):'1'!D$184000;)+ПОИСКПОЗ(A1;'1'!A:A;));"")
далее
Код
=ВПР()
К сообщению приложен файл: 2420906.xlsx(35.5 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС('1'!A:A;ПОИСКПОЗ("КП*";ИНДЕКС('1'!D:D;ПОИСКПОЗ(A1;'1'!A:A;)+1):'1'!D$184000;)+ПОИСКПОЗ(A1;'1'!A:A;));"")
далее
Код
=ВПР()

Автор - Nic70y
Дата добавления - 16.01.2020 в 16:49
Alleksdom Дата: Четверг, 16.01.2020, 16:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, Спасибо большое.
Еще вопрос, а если таблица 1 и 2, это разные книги?
 
Ответить
СообщениеNic70y, Спасибо большое.
Еще вопрос, а если таблица 1 и 2, это разные книги?

Автор - Alleksdom
Дата добавления - 16.01.2020 в 16:56
Nic70y Дата: Четверг, 16.01.2020, 17:21 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 5824
Репутация: 1274 ±
Замечаний: 0% ±

ru13;10;03
в формуле перед диапазонами будет путь и имя файла.
откройте две книги и переместите лист с формулами в нужный файл
(ПКМ по листу - Переместить или скопировать)


ЯД(poison) 41001841029809
 
Ответить
Сообщениев формуле перед диапазонами будет путь и имя файла.
откройте две книги и переместите лист с формулами в нужный файл
(ПКМ по листу - Переместить или скопировать)

Автор - Nic70y
Дата добавления - 16.01.2020 в 17:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка ячеек по содержащимся в них значениям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!