Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск данных и их сложение - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск данных и их сложение (Формулы/Formulas)
поиск данных и их сложение
charik-2j Дата: Вторник, 21.01.2020, 15:02 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y, AlexM СПАСИБО)
 
Ответить
СообщениеNic70y, AlexM СПАСИБО)

Автор - charik-2j
Дата добавления - 21.01.2020 в 15:02
YouGreed Дата: Вторник, 21.01.2020, 15:03 | Сообщение № 22
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
charik-2j,
Цитата
YouGreed, формула не складывает данные(


Складывает

Код
=СУММ(((--ЛЕВБ($A$1:$A$150;3)=202)+(--ЛЕВБ($A$1:$A$150;3)=204)+($A$1:$A$150=20302)+($A$1:$A$150=20303)+($A$1:$A$150=20305))*ЧЗНАЧ(ПОДСТАВИТЬ($B$1:$B$150;СИМВОЛ(160);"")))


Формула массива
К сообщению приложен файл: 1990643.xlsx(29.5 Kb)


Сообщение отредактировал YouGreed - Вторник, 21.01.2020, 15:04
 
Ответить
Сообщениеcharik-2j,
Цитата
YouGreed, формула не складывает данные(


Складывает

Код
=СУММ(((--ЛЕВБ($A$1:$A$150;3)=202)+(--ЛЕВБ($A$1:$A$150;3)=204)+($A$1:$A$150=20302)+($A$1:$A$150=20303)+($A$1:$A$150=20305))*ЧЗНАЧ(ПОДСТАВИТЬ($B$1:$B$150;СИМВОЛ(160);"")))


Формула массива

Автор - YouGreed
Дата добавления - 21.01.2020 в 15:03
Светлый Дата: Вторник, 21.01.2020, 15:05 | Сообщение № 23
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
задача агрегировать данные по нескольким балансовым счетам
У Вас нет списка этих счетов? Берём конкретные значения из сообщения №1 ?


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
задача агрегировать данные по нескольким балансовым счетам
У Вас нет списка этих счетов? Берём конкретные значения из сообщения №1 ?

Автор - Светлый
Дата добавления - 21.01.2020 в 15:05
Nic70y Дата: Вторник, 21.01.2020, 15:07 | Сообщение № 24
Группа: Друзья
Ранг: Экселист
Сообщений: 7744
Репутация: 1858 ±
Замечаний: 0% ±

Excel 2010
Складывает
не, в 2010 не складывает
К сообщению приложен файл: 7727183.gif(3.9 Kb)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Вторник, 21.01.2020, 15:08
 
Ответить
Сообщение
Складывает
не, в 2010 не складывает

Автор - Nic70y
Дата добавления - 21.01.2020 в 15:07
AlexM Дата: Вторник, 21.01.2020, 15:10 | Сообщение № 25
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2003
А если столбец А сделать тестом, то формулы проще
К сообщению приложен файл: 7937399_02.xlsx(46.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеА если столбец А сделать тестом, то формулы проще

Автор - AlexM
Дата добавления - 21.01.2020 в 15:10
charik-2j Дата: Вторник, 21.01.2020, 15:38 | Сообщение № 26
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Цитата Светлый, 21.01.2020 в 15:05, в сообщении № 23 ()
У Вас нет списка этих счетов? Берём конкретные значения из сообщения №1 ?

прикрепил файл.
К сообщению приложен файл: 4332080.xlsx(51.4 Kb)
 
Ответить
Сообщение
Цитата Светлый, 21.01.2020 в 15:05, в сообщении № 23 ()
У Вас нет списка этих счетов? Берём конкретные значения из сообщения №1 ?

прикрепил файл.

Автор - charik-2j
Дата добавления - 21.01.2020 в 15:38
charik-2j Дата: Вторник, 21.01.2020, 15:39 | Сообщение № 27
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
AlexM, при перемещении данной формулы все сбивается((
 
Ответить
СообщениеAlexM, при перемещении данной формулы все сбивается((

Автор - charik-2j
Дата добавления - 21.01.2020 в 15:39
AlexM Дата: Вторник, 21.01.2020, 17:17 | Сообщение № 28
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2003
все сбивается
Покажите ошибку в файле.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
все сбивается
Покажите ошибку в файле.

Автор - AlexM
Дата добавления - 21.01.2020 в 17:17
charik-2j Дата: Вторник, 21.01.2020, 19:10 | Сообщение № 29
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Покажите ошибку в файле.


пытаюсь скопировать формулу, что бы перенести в другую ячейку, и выдает ошибку (да и первоисточник "ломается")
К сообщению приложен файл: 5555555.xlsx(37.0 Kb)
 
Ответить
Сообщение
Покажите ошибку в файле.


пытаюсь скопировать формулу, что бы перенести в другую ячейку, и выдает ошибку (да и первоисточник "ломается")

Автор - charik-2j
Дата добавления - 21.01.2020 в 19:10
jakim Дата: Вторник, 21.01.2020, 19:49 | Сообщение № 30
Группа: Друзья
Ранг: Старожил
Сообщений: 1116
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Без дополнительных столбцов (пробелы удалены через Ctrl+h)
Формула

Код
=SUMPRODUCT((LEFT(A$1:A$767;LEN(E2))=TEXT(E2;0))*B$1:B$767)
К сообщению приложен файл: 4218328.xlsx(29.8 Kb)
 
Ответить
Сообщение
Без дополнительных столбцов (пробелы удалены через Ctrl+h)
Формула

Код
=SUMPRODUCT((LEFT(A$1:A$767;LEN(E2))=TEXT(E2;0))*B$1:B$767)

Автор - jakim
Дата добавления - 21.01.2020 в 19:49
Светлый Дата: Вторник, 21.01.2020, 22:14 | Сообщение № 31
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
прикрепил файл
Массивная формула:
Код
=СУММ((ЛЕВБ(A1:A999;ТРАНСП(ДЛСТР(I2:I9)))=ТРАНСП(""&Ч(+I2:I9)))*(0&ПОДСТАВИТЬ(B1:B999;СИМВОЛ(160);)))
Более корректная формула для устранения дублирования образцов (например: 203, 20305):
Код
=СУММ((МУМНОЖ(Ч(ЛЕВБ(A1:A999;ТРАНСП(ДЛСТР(I2:I9)))=ТРАНСП(""&Ч(+I2:I9)));1^I2:I9)>0)*(0&ПОДСТАВИТЬ(B1:B999;СИМВОЛ(160);)))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 21.01.2020, 22:15
 
Ответить
Сообщение
прикрепил файл
Массивная формула:
Код
=СУММ((ЛЕВБ(A1:A999;ТРАНСП(ДЛСТР(I2:I9)))=ТРАНСП(""&Ч(+I2:I9)))*(0&ПОДСТАВИТЬ(B1:B999;СИМВОЛ(160);)))
Более корректная формула для устранения дублирования образцов (например: 203, 20305):
Код
=СУММ((МУМНОЖ(Ч(ЛЕВБ(A1:A999;ТРАНСП(ДЛСТР(I2:I9)))=ТРАНСП(""&Ч(+I2:I9)));1^I2:I9)>0)*(0&ПОДСТАВИТЬ(B1:B999;СИМВОЛ(160);)))

Автор - Светлый
Дата добавления - 21.01.2020 в 22:14
charik-2j Дата: Среда, 22.01.2020, 09:56 | Сообщение № 32
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый, спасибо, видимо у меня руки не оттуда, и все равно какая то ошибка вылезает(((
К сообщению приложен файл: 4963677.xlsx(37.1 Kb)
 
Ответить
СообщениеСветлый, спасибо, видимо у меня руки не оттуда, и все равно какая то ошибка вылезает(((

Автор - charik-2j
Дата добавления - 22.01.2020 в 09:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск данных и их сложение (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!