Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сложить цифры с определенным символами в разные ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сложить цифры с определенным символами в разные ячейки (Формулы/Formulas)
Как сложить цифры с определенным символами в разные ячейки
mcintosh55 Дата: Суббота, 25.01.2020, 07:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Собственно задача которая в теме решил Я, но появился касяк если нет значений в ячейки или в ячейки просто просто цифра то ошибка #знач!. Помогите решить задачку
К сообщению приложен файл: ______.xlsx(9.5 Kb)
 
Ответить
СообщениеСобственно задача которая в теме решил Я, но появился касяк если нет значений в ячейки или в ячейки просто просто цифра то ошибка #знач!. Помогите решить задачку

Автор - mcintosh55
Дата добавления - 25.01.2020 в 07:13
Nic70y Дата: Суббота, 25.01.2020, 08:20 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6455
Репутация: 1421 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(G1;$A$2:$F$2))*ПРАВБ(ПОДСТАВИТЬ(0&$A$2:$F$2;"/";"    ");5))


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(G1;$A$2:$F$2))*ПРАВБ(ПОДСТАВИТЬ(0&$A$2:$F$2;"/";"    ");5))

Автор - Nic70y
Дата добавления - 25.01.2020 в 08:20
bmv98rus Дата: Суббота, 25.01.2020, 09:46 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3182
Репутация: 546 ±
Замечаний: 0% ±

Excel 2013/2016


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеи кросс

Автор - bmv98rus
Дата добавления - 25.01.2020 в 09:46
Nic70y Дата: Суббота, 25.01.2020, 10:06 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6455
Репутация: 1421 ±
Замечаний: 0% ±

ru13;10;03
кросс
да и ладно
решил Я
точно? :)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
кросс
да и ладно
решил Я
точно? :)

Автор - Nic70y
Дата добавления - 25.01.2020 в 10:06
Светлый Дата: Суббота, 25.01.2020, 10:26 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1474
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Массивная:
Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ($A2:$F2;G1&"/";);))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМассивная:
Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ($A2:$F2;G1&"/";);))

Автор - Светлый
Дата добавления - 25.01.2020 в 10:26
mcintosh55 Дата: Суббота, 25.01.2020, 15:08 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
точно?

не точно, но еще проблема вылезла есть символ /тр /р так вот где нужно просуммировать /тр туда же считает /р, а /р это уже другой параметр
 
Ответить
Сообщение
точно?

не точно, но еще проблема вылезла есть символ /тр /р так вот где нужно просуммировать /тр туда же считает /р, а /р это уже другой параметр

Автор - mcintosh55
Дата добавления - 25.01.2020 в 15:08
bmv98rus Дата: Суббота, 25.01.2020, 19:56 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3182
Репутация: 546 ±
Замечаний: 0% ±

Excel 2013/2016
mcintosh55, Пример то будет?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеmcintosh55, Пример то будет?

Автор - bmv98rus
Дата добавления - 25.01.2020 в 19:56
mcintosh55 Дата: Суббота, 25.01.2020, 22:10 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
mcintosh55, Пример то будет?
К сообщению приложен файл: primer.xlsx(9.5 Kb)
 
Ответить
Сообщение
mcintosh55, Пример то будет?

Автор - mcintosh55
Дата добавления - 25.01.2020 в 22:10
bmv98rus Дата: Воскресенье, 26.01.2020, 09:03 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3182
Репутация: 546 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUM(IFERROR(--SUBSTITUTE("/"&TRIM($A2:$F2);"/"&I$1&"/";);))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=SUM(IFERROR(--SUBSTITUTE("/"&TRIM($A2:$F2);"/"&I$1&"/";);))

Автор - bmv98rus
Дата добавления - 26.01.2020 в 09:03
Светлый Дата: Воскресенье, 26.01.2020, 10:31 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1474
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Не могу понять, чем не устроила формула из сообщения №5 ?
К сообщению приложен файл: primer-1-.xlsx(9.7 Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНе могу понять, чем не устроила формула из сообщения №5 ?

Автор - Светлый
Дата добавления - 26.01.2020 в 10:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сложить цифры с определенным символами в разные ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!