Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных по году - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных по году (Формулы/Formulas)
Выборка данных по году
Gopronotmore Дата: Вторник, 28.01.2020, 23:20 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 127
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Друзья, вот еще столкнулся с ВПР формулой,

как привязать поискпоз к этой формуле что бы при выборе года данные подставлялись автоматически из массива?
К сообщению приложен файл: _2.xlsx(8.8 Kb)
 
Ответить
СообщениеДрузья, вот еще столкнулся с ВПР формулой,

как привязать поискпоз к этой формуле что бы при выборе года данные подставлялись автоматически из массива?

Автор - Gopronotmore
Дата добавления - 28.01.2020 в 23:20
Pelena Дата: Вторник, 28.01.2020, 23:27 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15238
Репутация: 3340 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ИНДЕКС($S:$S;ПОИСКПОЗ($B$1;$R:$R;0)+D$2-1)

Правда, не рекомендуется брать в формулу целиком столбцы, лучше взять диапазоны с запасом без фанатизма

Можно ещё почитать ВПР по двум столбцам


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($S:$S;ПОИСКПОЗ($B$1;$R:$R;0)+D$2-1)

Правда, не рекомендуется брать в формулу целиком столбцы, лучше взять диапазоны с запасом без фанатизма

Можно ещё почитать ВПР по двум столбцам

Автор - Pelena
Дата добавления - 28.01.2020 в 23:27
Gopronotmore Дата: Вторник, 28.01.2020, 23:54 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 127
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena,

Спасибо, но что-то у меня не получается ее адаптировать. Я приложил файл, в котором у меня выборка идет по 2 столбцам. И я не могу вашу формулу прицепить к моей. Потому что индекс ищет по строкам и столбцам.

А как сделать так что бы он искал по 2 столбцам из заданных 2 критериев?

Буду очень признателен
К сообщению приложен файл: example.xlsx(12.2 Kb)
 
Ответить
СообщениеPelena,

Спасибо, но что-то у меня не получается ее адаптировать. Я приложил файл, в котором у меня выборка идет по 2 столбцам. И я не могу вашу формулу прицепить к моей. Потому что индекс ищет по строкам и столбцам.

А как сделать так что бы он искал по 2 столбцам из заданных 2 критериев?

Буду очень признателен

Автор - Gopronotmore
Дата добавления - 28.01.2020 в 23:54
Pelena Дата: Среда, 29.01.2020, 00:04 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15238
Репутация: 3340 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ИНДЕКС($C:$C;ПОИСКПОЗ($H$4;$B:$B;0)+I$4-1)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($C:$C;ПОИСКПОЗ($H$4;$B:$B;0)+I$4-1)

Автор - Pelena
Дата добавления - 29.01.2020 в 00:04
gling Дата: Среда, 29.01.2020, 00:11 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2016
Репутация: 508 ±
Замечаний: 0% ±

2010
А может такую надо?
Код
=ВПР(I4;ИНДЕКС($A$1:$A$500;ПОИСКПОЗ(H4;B1:B500;)):ИНДЕКС($D$1:$D$500;ПОИСКПОЗ(H4;B1:B500;)+СЧЁТЕСЛИ(B1:B500;H4));3;)


ЯД-41001506838083
 
Ответить
СообщениеА может такую надо?
Код
=ВПР(I4;ИНДЕКС($A$1:$A$500;ПОИСКПОЗ(H4;B1:B500;)):ИНДЕКС($D$1:$D$500;ПОИСКПОЗ(H4;B1:B500;)+СЧЁТЕСЛИ(B1:B500;H4));3;)

Автор - gling
Дата добавления - 29.01.2020 в 00:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных по году (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!