Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных из оного листа на другой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных из оного листа на другой (Формулы/Formulas)
Выборка данных из оного листа на другой
Aleksnsk Дата: Среда, 29.01.2020, 09:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте форумчане! Помогите разобраться как лучше поизвести выборку данных приходится постоянно вручную лопатить! Пример прикладываю
К сообщению приложен файл: _Microsoft_Exce.xlsx(12.9 Kb)
 
Ответить
СообщениеЗдравствуйте форумчане! Помогите разобраться как лучше поизвести выборку данных приходится постоянно вручную лопатить! Пример прикладываю

Автор - Aleksnsk
Дата добавления - 29.01.2020 в 09:54
YouGreed Дата: Среда, 29.01.2020, 10:06 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 119 ±
Замечаний: 0% ±

Excel 2010
Aleksnsk, Можно так, объединенные ячейки не самый лучший вариант.

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$13:$Y$13;1;ПОИСКПОЗ(Лист2!$B5&Лист2!C$4;Лист1!$B$2:$Y$2&Лист1!$B$4:$Y$4;0);1);"")


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: __-.xlsx(14.9 Kb)
 
Ответить
СообщениеAleksnsk, Можно так, объединенные ячейки не самый лучший вариант.

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$13:$Y$13;1;ПОИСКПОЗ(Лист2!$B5&Лист2!C$4;Лист1!$B$2:$Y$2&Лист1!$B$4:$Y$4;0);1);"")


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter

Автор - YouGreed
Дата добавления - 29.01.2020 в 10:06
Aleksnsk Дата: Среда, 29.01.2020, 10:17 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное! То что надо, спасибо за помощь
 
Ответить
СообщениеСпасибо огромное! То что надо, спасибо за помощь

Автор - Aleksnsk
Дата добавления - 29.01.2020 в 10:17
YouGreed Дата: Среда, 29.01.2020, 10:23 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 119 ±
Замечаний: 0% ±

Excel 2010
Aleksnsk, Вот еще...

Подправил с объединением
К сообщению приложен файл: 0548445.xlsx(15.0 Kb)
 
Ответить
СообщениеAleksnsk, Вот еще...

Подправил с объединением

Автор - YouGreed
Дата добавления - 29.01.2020 в 10:23
Aleksnsk Дата: Среда, 29.01.2020, 12:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Что-то я видать не то делаю :(
К сообщению приложен файл: 7081480.xlsx(23.3 Kb)
 
Ответить
СообщениеЧто-то я видать не то делаю :(

Автор - Aleksnsk
Дата добавления - 29.01.2020 в 12:16
YouGreed Дата: Среда, 29.01.2020, 13:16 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 119 ±
Замечаний: 0% ±

Excel 2010
Aleksnsk, Поправил со ссылкой на опр, лист

Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&C$2&"'!$I$26:$AF$26");1;ПОИСКПОЗ($B5&Сводка!C$4;ДВССЫЛ("'"&C$2&"'!$I$1:$AF$1")&ДВССЫЛ("'"&C$2&"'!$I$3:$AF$3");0);1);"")


Вы можете, попробовать так.
1. В шапке, там где объединены ячейки, в каждой ячейке должна стоять корректная дата.
2. Выделяете диапазон пусто, по размеру подходящий тому, что будет у Вас. Объединяете.
3. Нажимаете формат по образцу.
4. Наводите на диапазон с Вашими данными, которые нужно объединить.
5. Визуально, ячейки объединены, формально в каждой ячейке находится дата, для работы формулы.

Инструкция и видео вот тут:
Объединение без удаления данных
У Вас не получалось, т.к. даты были скрыты под объединением и они были 9,13,20 как в примере ранее.
К сообщению приложен файл: 7022061.xlsx(24.7 Kb)


Сообщение отредактировал YouGreed - Среда, 29.01.2020, 13:20
 
Ответить
СообщениеAleksnsk, Поправил со ссылкой на опр, лист

Код
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("'"&C$2&"'!$I$26:$AF$26");1;ПОИСКПОЗ($B5&Сводка!C$4;ДВССЫЛ("'"&C$2&"'!$I$1:$AF$1")&ДВССЫЛ("'"&C$2&"'!$I$3:$AF$3");0);1);"")


Вы можете, попробовать так.
1. В шапке, там где объединены ячейки, в каждой ячейке должна стоять корректная дата.
2. Выделяете диапазон пусто, по размеру подходящий тому, что будет у Вас. Объединяете.
3. Нажимаете формат по образцу.
4. Наводите на диапазон с Вашими данными, которые нужно объединить.
5. Визуально, ячейки объединены, формально в каждой ячейке находится дата, для работы формулы.

Инструкция и видео вот тут:
Объединение без удаления данных
У Вас не получалось, т.к. даты были скрыты под объединением и они были 9,13,20 как в примере ранее.

Автор - YouGreed
Дата добавления - 29.01.2020 в 13:16
Aleksnsk Дата: Среда, 29.01.2020, 14:13 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо огромное! Все сделал, работает!
 
Ответить
СообщениеСпасибо огромное! Все сделал, работает!

Автор - Aleksnsk
Дата добавления - 29.01.2020 в 14:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных из оного листа на другой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!