Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула ДВССЫЛ с шагом в 32 ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ДВССЫЛ с шагом в 32 ячейки (Формулы/Formulas)
Формула ДВССЫЛ с шагом в 32 ячейки
stendikov_m Дата: Суббота, 01.02.2020, 10:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте.
Не могу придумать формулу, что бы при протягивании брались ячейки с шагом 32 ячейки.
То есть необходимо, что бы на Листе 2 в столбце B подтягивались данные с Листа 1, столбец L. с шагом в 32 ячейки.
На 01.01.20 берется результат дня с листа 1 этого же дня из ячейки L35
На 02.01.20 берется результат дня с листа 1 этого же дня из ячейки L67
На 03.01.20 берется результат дня с листа 1 этого же дня из ячейки L99 .... 131, 163...

Раньше у меня был шаг 22 ячейки, я это реализовал формулой
Код
=ДВССЫЛ("'Лист 01'!K"&;(СТРОКА(A2)-1)*22+3)

А вот с шагом в 32 ячейки чет не могу догадаться

P.S. Спасибо, догадался сам
Код
=ДВССЫЛ("'ВИП 02'!l"&(СТРОКА(A2))*32-29)
К сообщению приложен файл: 6693723.xlsx(134.9 Kb)


Сообщение отредактировал stendikov_m - Суббота, 01.02.2020, 12:01
 
Ответить
СообщениеЗдравствуйте.
Не могу придумать формулу, что бы при протягивании брались ячейки с шагом 32 ячейки.
То есть необходимо, что бы на Листе 2 в столбце B подтягивались данные с Листа 1, столбец L. с шагом в 32 ячейки.
На 01.01.20 берется результат дня с листа 1 этого же дня из ячейки L35
На 02.01.20 берется результат дня с листа 1 этого же дня из ячейки L67
На 03.01.20 берется результат дня с листа 1 этого же дня из ячейки L99 .... 131, 163...

Раньше у меня был шаг 22 ячейки, я это реализовал формулой
Код
=ДВССЫЛ("'Лист 01'!K"&;(СТРОКА(A2)-1)*22+3)

А вот с шагом в 32 ячейки чет не могу догадаться

P.S. Спасибо, догадался сам
Код
=ДВССЫЛ("'ВИП 02'!l"&(СТРОКА(A2))*32-29)

Автор - stendikov_m
Дата добавления - 01.02.2020 в 10:50
Che79 Дата: Суббота, 01.02.2020, 12:54 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1431
Репутация: 257 ±
Замечаний: 0% ±

Excel 2013
А зачем Вам ДВССЫЛ()? По Вашему примеру можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!L:L;35+32*(СТРОКА(A1)-1));"")


Делай нормально и будет нормально!
 
Ответить
СообщениеА зачем Вам ДВССЫЛ()? По Вашему примеру можно так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!L:L;35+32*(СТРОКА(A1)-1));"")

Автор - Che79
Дата добавления - 01.02.2020 в 12:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула ДВССЫЛ с шагом в 32 ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!