Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Просуммировать значения из всех столбцов с одним названием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать значения из всех столбцов с одним названием (Формулы/Formulas)
Просуммировать значения из всех столбцов с одним названием
fimka29 Дата: Среда, 05.02.2020, 15:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
Подскажите, пожалуйста, как обработать исходную информацию: есть данные по сотрудникам с указанием вида начислении заработной платы. Нужно вывести сумму по каждому виду начислений и по категориям сотрудников. Получилось с помощью СУММПРОИЗВ, но только берет фиксированный столбец с итогами, лучше было для первой таблицы в примере, чтобы суммировал по всем столбцам со словом ФОТ, или же по названию итогового столбца "Итого_ФОТ" (его номер каждый месяц будет плавающим, в один месяц - R, потом S и т.д.). Единой формулой сумм если, индес и поискпоз у меня не получилось, выводит только самого первого сотрудника сумму по всем столбцам.
И вторая таблица - нужно сделать аналитику по начислениям- E-P4. Причем вид начисления заработная плата разделить на оклад/тариф /сделка (соединить со столбцом С -вид заработной платы).Ключевое - то что видов начислений каждый месяц разное, то есть нужно найти по 4 строке нужный вид и просуммировать по этому виду всех сотрудников. И лучше бы без дополнительных итоговых столбцов в исходных данных, только на основании столбцов B-P (не используя последние три итоговых). Сводной таблицей все можно, но нужно именно в статическую форму с помощью формул.
Буду благодарен, если кто-нибудь направит на путь истинный.
К сообщению приложен файл: 4085775.xls(74.0 Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, как обработать исходную информацию: есть данные по сотрудникам с указанием вида начислении заработной платы. Нужно вывести сумму по каждому виду начислений и по категориям сотрудников. Получилось с помощью СУММПРОИЗВ, но только берет фиксированный столбец с итогами, лучше было для первой таблицы в примере, чтобы суммировал по всем столбцам со словом ФОТ, или же по названию итогового столбца "Итого_ФОТ" (его номер каждый месяц будет плавающим, в один месяц - R, потом S и т.д.). Единой формулой сумм если, индес и поискпоз у меня не получилось, выводит только самого первого сотрудника сумму по всем столбцам.
И вторая таблица - нужно сделать аналитику по начислениям- E-P4. Причем вид начисления заработная плата разделить на оклад/тариф /сделка (соединить со столбцом С -вид заработной платы).Ключевое - то что видов начислений каждый месяц разное, то есть нужно найти по 4 строке нужный вид и просуммировать по этому виду всех сотрудников. И лучше бы без дополнительных итоговых столбцов в исходных данных, только на основании столбцов B-P (не используя последние три итоговых). Сводной таблицей все можно, но нужно именно в статическую форму с помощью формул.
Буду благодарен, если кто-нибудь направит на путь истинный.

Автор - fimka29
Дата добавления - 05.02.2020 в 15:24
YouGreed Дата: Среда, 05.02.2020, 16:23 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 517
Репутация: 109 ±
Замечаний: 0% ±

Excel 2010
fimka29, 1-ая часть:

Код
=ЕСЛИ(ЕЧИСЛО(НАЙТИ("(";$A3;1));СУММ((исх_данные!$B$5:$B$41=аналитика!$A3)*(исх_данные!$E$2:$S$2=аналитика!$B$1)*исх_данные!$E$5:$S$41);СУММ((исх_данные!$D$5:$D$41=аналитика!$A3)*(исх_данные!$E$2:$S$2=аналитика!$B$1)*исх_данные!$E$5:$S$41))


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter

2-ая часть, тоже массивная
Код
=ЕСЛИ($B25="";СУММ((исх_данные!$E$3:$P$3=аналитика!C$24)*(исх_данные!$E$4:$P$4=аналитика!$A25)*исх_данные!$E$5:$P$41);СУММ((исх_данные!$E$3:$P$3=аналитика!C$24)*(исх_данные!$C$5:$C$41=аналитика!$B25)*(исх_данные!$E$4:$P$4=аналитика!$A25)*исх_данные!$E$5:$P$41))


[p.s.]По сути, можно использовать и СУММПРОИЗВ, в том направлении которое Вы начали. Но, я больше люблю СУММ.
К сообщению приложен файл: 6491951.xls(84.0 Kb)


Сообщение отредактировал YouGreed - Среда, 05.02.2020, 16:38
 
Ответить
Сообщениеfimka29, 1-ая часть:

Код
=ЕСЛИ(ЕЧИСЛО(НАЙТИ("(";$A3;1));СУММ((исх_данные!$B$5:$B$41=аналитика!$A3)*(исх_данные!$E$2:$S$2=аналитика!$B$1)*исх_данные!$E$5:$S$41);СУММ((исх_данные!$D$5:$D$41=аналитика!$A3)*(исх_данные!$E$2:$S$2=аналитика!$B$1)*исх_данные!$E$5:$S$41))


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter

2-ая часть, тоже массивная
Код
=ЕСЛИ($B25="";СУММ((исх_данные!$E$3:$P$3=аналитика!C$24)*(исх_данные!$E$4:$P$4=аналитика!$A25)*исх_данные!$E$5:$P$41);СУММ((исх_данные!$E$3:$P$3=аналитика!C$24)*(исх_данные!$C$5:$C$41=аналитика!$B25)*(исх_данные!$E$4:$P$4=аналитика!$A25)*исх_данные!$E$5:$P$41))


[p.s.]По сути, можно использовать и СУММПРОИЗВ, в том направлении которое Вы начали. Но, я больше люблю СУММ.

Автор - YouGreed
Дата добавления - 05.02.2020 в 16:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать значения из всех столбцов с одним названием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!