Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод данных из сводной табл. в другой лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод данных из сводной табл. в другой лист (Формулы/Formulas)
Вывод данных из сводной табл. в другой лист
Гри_ша Дата: Пятница, 07.02.2020, 12:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Как сделать, чтобы данные из сводной таблицы заполнялись в нужных столбцах на другом Листе?
Пример с итогом прикрепил.
Заранее Спасибо!
К сообщению приложен файл: forTest2.xlsx(14.0 Kb)
 
Ответить
СообщениеДобрый день! Как сделать, чтобы данные из сводной таблицы заполнялись в нужных столбцах на другом Листе?
Пример с итогом прикрепил.
Заранее Спасибо!

Автор - Гри_ша
Дата добавления - 07.02.2020 в 12:01
Nic70y Дата: Пятница, 07.02.2020, 12:17 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5963
Репутация: 1306 ±
Замечаний: 0% ±

ru13;10;03
ну как-то так можно:
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("b1")) Is Nothing Then
        u = Sheets("sheet2").Cells(Rows.Count, "a").End(xlUp).Row
        If u > 1 Then Sheets("sheet2").Range("a2:d" & u).Clear
        v = Sheets("sheet1").Cells(Rows.Count, "a").End(xlUp).Row
        If v > 3 Then Sheets("sheet1").Range("a4:d" & v).Copy Sheets("sheet2").Range("a2")
    End If
End Sub
[/vba]
К сообщению приложен файл: 99999.xlsm(20.6 Kb)


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Пятница, 07.02.2020, 12:19
 
Ответить
Сообщениену как-то так можно:
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Not Intersect(Target, Range("b1")) Is Nothing Then
        u = Sheets("sheet2").Cells(Rows.Count, "a").End(xlUp).Row
        If u > 1 Then Sheets("sheet2").Range("a2:d" & u).Clear
        v = Sheets("sheet1").Cells(Rows.Count, "a").End(xlUp).Row
        If v > 3 Then Sheets("sheet1").Range("a4:d" & v).Copy Sheets("sheet2").Range("a2")
    End If
End Sub
[/vba]

Автор - Nic70y
Дата добавления - 07.02.2020 в 12:17
Гри_ша Дата: Пятница, 07.02.2020, 12:25 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, спасибо за ответ!
А с помощью формулы никак нельзя вытащить эти данные? да?
 
Ответить
СообщениеNic70y, спасибо за ответ!
А с помощью формулы никак нельзя вытащить эти данные? да?

Автор - Гри_ша
Дата добавления - 07.02.2020 в 12:25
Nic70y Дата: Пятница, 07.02.2020, 12:30 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5963
Репутация: 1306 ±
Замечаний: 0% ±

ru13;10;03
можно
Код
=ЕСЛИ(sheet1!A4=0;"";sheet1!A4)
Код
=ЕСЛИ($A2="";"";sheet1!B4)
К сообщению приложен файл: 2823969.xlsx(14.7 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеможно
Код
=ЕСЛИ(sheet1!A4=0;"";sheet1!A4)
Код
=ЕСЛИ($A2="";"";sheet1!B4)

Автор - Nic70y
Дата добавления - 07.02.2020 в 12:30
Гри_ша Дата: Пятница, 07.02.2020, 12:41 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, Большое Вам спасибо!
 
Ответить
СообщениеNic70y, Большое Вам спасибо!

Автор - Гри_ша
Дата добавления - 07.02.2020 в 12:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод данных из сводной табл. в другой лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!