Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по условию (Формулы/Formulas)
Суммирование по условию
Kaiyr Дата: Понедельник, 10.02.2020, 09:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Суммирование по условию. Файл и пример прикреплен.
К сообщению приложен файл: 6439883.xlsx(21.3 Kb)


Активный участник Википедии, могу проконсультировать. Также по казахской генеалогии и программам.
 
Ответить
СообщениеДобрый день! Суммирование по условию. Файл и пример прикреплен.

Автор - Kaiyr
Дата добавления - 10.02.2020 в 09:47
Nic70y Дата: Понедельник, 10.02.2020, 10:06 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6445
Репутация: 1418 ±
Замечаний: 0% ±

ru13;10;03
не совсем понятно.
суммировать нужно именного до встречи кода на 1 меньше
или все же одинаковые подряд идущие?
смутили строки 42-43


Яндекс Деньги 41001841029809
 
Ответить
Сообщениене совсем понятно.
суммировать нужно именного до встречи кода на 1 меньше
или все же одинаковые подряд идущие?
смутили строки 42-43

Автор - Nic70y
Дата добавления - 10.02.2020 в 10:06
Kaiyr Дата: Понедельник, 10.02.2020, 10:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, суммировать всех с кодом которые на одну единицу больше вниз, до тех пор пока не встретится равный код. Код в столбце В. В 7 строке код 1, значит суммировать все строки со значением 2 (1(код)+1), пока не встретится код 1. Получается Акмолинская область (код) суммирует коды 2 (Кокшетау г.а., Степногорск г.а. и Аккольский район) до кода 1 (Актюбинская область)


Активный участник Википедии, могу проконсультировать. Также по казахской генеалогии и программам.
 
Ответить
СообщениеNic70y, суммировать всех с кодом которые на одну единицу больше вниз, до тех пор пока не встретится равный код. Код в столбце В. В 7 строке код 1, значит суммировать все строки со значением 2 (1(код)+1), пока не встретится код 1. Получается Акмолинская область (код) суммирует коды 2 (Кокшетау г.а., Степногорск г.а. и Аккольский район) до кода 1 (Актюбинская область)

Автор - Kaiyr
Дата добавления - 10.02.2020 в 10:21
Nic70y Дата: Понедельник, 10.02.2020, 10:36 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6445
Репутация: 1418 ±
Замечаний: 0% ±

ru13;10;03
вдруг правильно
Код
=ЕСЛИ(B6<>B7;СУММЕСЛИ(B7:ИНДЕКС(B7:B$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66)));B6+1;D7:ИНДЕКС(D7:D$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66))));"")


апдэйт
наверное ЕСЛИ лишнее
Код
=СУММЕСЛИ(B7:ИНДЕКС(B7:B$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66)));B6+1;D7:ИНДЕКС(D7:D$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66))))
К сообщению приложен файл: 18.xlsx(21.0 Kb)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 10.02.2020, 10:40
 
Ответить
Сообщениевдруг правильно
Код
=ЕСЛИ(B6<>B7;СУММЕСЛИ(B7:ИНДЕКС(B7:B$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66)));B6+1;D7:ИНДЕКС(D7:D$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66))));"")


апдэйт
наверное ЕСЛИ лишнее
Код
=СУММЕСЛИ(B7:ИНДЕКС(B7:B$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66)));B6+1;D7:ИНДЕКС(D7:D$66;ЕСЛИОШИБКА(ПОИСКПОЗ(B6;B7:B$66;);ПОИСКПОЗ(9E+307;B7:B$66))))

Автор - Nic70y
Дата добавления - 10.02.2020 в 10:36
YouGreed Дата: Понедельник, 10.02.2020, 10:54 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 564
Репутация: 119 ±
Замечаний: 0% ±

Excel 2010
Kaiyr, Попробую и я

Код
=ЕСЛИОШИБКА(ЕСЛИ($B7=4;"";ЕСЛИ($B7=0;СУММЕСЛИ($B7:$B$65;1;$D7:$D$65);СУММЕСЛИ(B7:ИНДЕКС($B7:$B$65;ПОИСКПОЗ(B7;$B8:$B$65;0);1;1);$B7+1;D7:ИНДЕКС($D8:$D$65;ПОИСКПОЗ(B7;$B8:$B$65;0);1;1))));"")
К сообщению приложен файл: 4440272.xlsx(23.8 Kb)
 
Ответить
СообщениеKaiyr, Попробую и я

Код
=ЕСЛИОШИБКА(ЕСЛИ($B7=4;"";ЕСЛИ($B7=0;СУММЕСЛИ($B7:$B$65;1;$D7:$D$65);СУММЕСЛИ(B7:ИНДЕКС($B7:$B$65;ПОИСКПОЗ(B7;$B8:$B$65;0);1;1);$B7+1;D7:ИНДЕКС($D8:$D$65;ПОИСКПОЗ(B7;$B8:$B$65;0);1;1))));"")

Автор - YouGreed
Дата добавления - 10.02.2020 в 10:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!