Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для рассчета совпадений столбцов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для рассчета совпадений столбцов (Формулы/Formulas)
Формула для рассчета совпадений столбцов
TwoAces Дата: Суббота, 15.02.2020, 18:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет!

Мне нужно чтобы в таблице C10:H14 автоматически подставлялись имена столбцов, где есть искомое значение 1 и 2
К сообщению приложен файл: 0461986.xlsx(9.6 Kb)
 
Ответить
СообщениеВсем привет!

Мне нужно чтобы в таблице C10:H14 автоматически подставлялись имена столбцов, где есть искомое значение 1 и 2

Автор - TwoAces
Дата добавления - 15.02.2020 в 18:18
Pelena Дата: Суббота, 15.02.2020, 19:23 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Если допустимо небольшое изменение шапки таблицы
Формула массива (желтые ячейки)
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$J$2;НАИМЕНЬШИЙ(ЕСЛИ(C$9=ИНДЕКС($C$3:$J$7;ПОИСКПОЗ($B10;$B$3:$B$7;0);0);СТОЛБЕЦ($C$2:$J$2)-2);СЧЁТЕСЛИ($C$9:C$9;C$9)));"")

или обычная формула (голубые ячейки)
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$J$2;АГРЕГАТ(15;6;(СТОЛБЕЦ($C$2:$J$2)-2)/(C$9=ИНДЕКС($C$3:$J$7;ПОИСКПОЗ($B10;$B$3:$B$7;0);0));СЧЁТЕСЛИ($C$9:C$9;C$9)));"")
К сообщению приложен файл: 6655865.xlsx(10.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если допустимо небольшое изменение шапки таблицы
Формула массива (желтые ячейки)
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$J$2;НАИМЕНЬШИЙ(ЕСЛИ(C$9=ИНДЕКС($C$3:$J$7;ПОИСКПОЗ($B10;$B$3:$B$7;0);0);СТОЛБЕЦ($C$2:$J$2)-2);СЧЁТЕСЛИ($C$9:C$9;C$9)));"")

или обычная формула (голубые ячейки)
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$2:$J$2;АГРЕГАТ(15;6;(СТОЛБЕЦ($C$2:$J$2)-2)/(C$9=ИНДЕКС($C$3:$J$7;ПОИСКПОЗ($B10;$B$3:$B$7;0);0));СЧЁТЕСЛИ($C$9:C$9;C$9)));"")

Автор - Pelena
Дата добавления - 15.02.2020 в 19:23
TwoAces Дата: Суббота, 15.02.2020, 20:29 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ок, спасибо
 
Ответить
СообщениеОк, спасибо

Автор - TwoAces
Дата добавления - 15.02.2020 в 20:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для рассчета совпадений столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!