Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт из ячеек выделенных через УФ - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт из ячеек выделенных через УФ (Формулы/Formulas)
Подсчёт из ячеек выделенных через УФ
DrMini Дата: Воскресенье, 16.02.2020, 08:03 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Доброго времени суток форумчане и гости!
Нужно, что бы в ячейку "Выходные и праздники"(AN8) суммировались часы из ячеек выделенных через "УФ".
Не уверен, что это можно сделать без макросов. Но я здесь такие чудеса видел... Помогите пожалуйста если это возможно. Если без макросов никак, то модераторы перенесите эту тему в раздел "Вопросы по VBA".
Файл прилагаю. В нём? как смог пояснил свою просьбу.
К сообщению приложен файл: _____.xlsx(21.6 Kb)
 
Ответить
СообщениеДоброго времени суток форумчане и гости!
Нужно, что бы в ячейку "Выходные и праздники"(AN8) суммировались часы из ячеек выделенных через "УФ".
Не уверен, что это можно сделать без макросов. Но я здесь такие чудеса видел... Помогите пожалуйста если это возможно. Если без макросов никак, то модераторы перенесите эту тему в раздел "Вопросы по VBA".
Файл прилагаю. В нём? как смог пояснил свою просьбу.

Автор - DrMini
Дата добавления - 16.02.2020 в 08:03
Pelena Дата: Воскресенье, 16.02.2020, 08:45 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18611
Репутация: 4220 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(((ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1>7)*(ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1<10)+(ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1>12)*(ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1<15));E8:AI8)
К сообщению приложен файл: 7452398.xlsx(20.9 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(((ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1>7)*(ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1<10)+(ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1>12)*(ОСТАТ($E$7:$AI$7-DATA!$B$1;14)+1<15));E8:AI8)

Автор - Pelena
Дата добавления - 16.02.2020 в 08:45
DrMini Дата: Воскресенье, 16.02.2020, 09:23 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
ЕЛЕНА. БООООЛЬШУЩЕЕ СПАСИБО! Всё работает. Позже проверю на других месяцах. Отпишусь.
:o :o :o :o :o :o :o :o
[offtop]Репутацию не получается Вам увеличить сегодня. Завтра отпишусь и поставлю Вам + к репутации.
 
Ответить
СообщениеЕЛЕНА. БООООЛЬШУЩЕЕ СПАСИБО! Всё работает. Позже проверю на других месяцах. Отпишусь.
:o :o :o :o :o :o :o :o
[offtop]Репутацию не получается Вам увеличить сегодня. Завтра отпишусь и поставлю Вам + к репутации.

Автор - DrMini
Дата добавления - 16.02.2020 в 09:23
DrMini Дата: Воскресенье, 16.02.2020, 10:54 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
И снова здравствуйте.
При создании копии листа для Февраля (и т.д.) формула в ячейке "Выходные и праздничные дни" (AN8) не работает.
Файл прикрепил.
[p.s.]Я так понял это происходит из-за "недостающих" дней до 31-ого дня в месяце. В Апреле такая же ошибка.
[p.s.]В ячейках AG7:AI7 при подстановке в формулу
Код
=ЕСЛИ(ДЕНЬ($AF7+1)>ДЕНЬ(AF7);$AF7+1;"")

любой цифры:
Код
=ЕСЛИ(ДЕНЬ($AF7+1)>ДЕНЬ(AF7);$AF7+1;"0")

Формула работает но эти дни окрашиваются выходными.
К сообщению приложен файл: 7452398-3-.xlsx(24.5 Kb)


Сообщение отредактировал DrMini - Воскресенье, 16.02.2020, 11:19
 
Ответить
СообщениеИ снова здравствуйте.
При создании копии листа для Февраля (и т.д.) формула в ячейке "Выходные и праздничные дни" (AN8) не работает.
Файл прикрепил.
[p.s.]Я так понял это происходит из-за "недостающих" дней до 31-ого дня в месяце. В Апреле такая же ошибка.
[p.s.]В ячейках AG7:AI7 при подстановке в формулу
Код
=ЕСЛИ(ДЕНЬ($AF7+1)>ДЕНЬ(AF7);$AF7+1;"")

любой цифры:
Код
=ЕСЛИ(ДЕНЬ($AF7+1)>ДЕНЬ(AF7);$AF7+1;"0")

Формула работает но эти дни окрашиваются выходными.

Автор - DrMini
Дата добавления - 16.02.2020 в 10:54
Pelena Дата: Воскресенье, 16.02.2020, 11:53 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18611
Репутация: 4220 ±
Замечаний: ±

Excel 2016 & Mac Excel
Так?
К сообщению приложен файл: 7103705.xlsx(24.5 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеТак?

Автор - Pelena
Дата добавления - 16.02.2020 в 11:53
DrMini Дата: Воскресенье, 16.02.2020, 12:06 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Так точно! respect hands
Идеально!!!
СПАСИБО!
 
Ответить
СообщениеТак точно! respect hands
Идеально!!!
СПАСИБО!

Автор - DrMini
Дата добавления - 16.02.2020 в 12:06
DrMini Дата: Воскресенье, 16.02.2020, 12:13 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
И последнее. Елена взгляните если будет желание. Я переделал Вашу формулу из Сообщение № 2
Код
=СУММПРОИЗВ(((ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3>7)*(ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3<8)+(ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3>5)*(ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3<8));E8:AI8)

для пятидневки с двумя выходными. Она работает. Но мне кажется её можно укоротить. Я куски формулы кое как понимаю, а вот всю формулу целиком не могу представить.
[p.s.]Ещё раз огромное Вам спасибо.
 
Ответить
СообщениеИ последнее. Елена взгляните если будет желание. Я переделал Вашу формулу из Сообщение № 2
Код
=СУММПРОИЗВ(((ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3>7)*(ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3<8)+(ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3>5)*(ОСТАТ($E$7:$AI$7-DATA!$A$1;7)+3<8));E8:AI8)

для пятидневки с двумя выходными. Она работает. Но мне кажется её можно укоротить. Я куски формулы кое как понимаю, а вот всю формулу целиком не могу представить.
[p.s.]Ещё раз огромное Вам спасибо.

Автор - DrMini
Дата добавления - 16.02.2020 в 12:13
Pelena Дата: Воскресенье, 16.02.2020, 18:18 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 18611
Репутация: 4220 ±
Замечаний: ±

Excel 2016 & Mac Excel
Дык, пятидневка с двумя выходными - это же обычная неделя, изначально у Вас была. Нет?


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеДык, пятидневка с двумя выходными - это же обычная неделя, изначально у Вас была. Нет?

Автор - Pelena
Дата добавления - 16.02.2020 в 18:18
DrMini Дата: Воскресенье, 16.02.2020, 18:49 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
у Вас была. Нет?

Да была. Но Вашей формулы не было.


Сообщение отредактировал DrMini - Воскресенье, 16.02.2020, 19:22
 
Ответить
Сообщение
у Вас была. Нет?

Да была. Но Вашей формулы не было.

Автор - DrMini
Дата добавления - 16.02.2020 в 18:49
Pelena Дата: Воскресенье, 16.02.2020, 21:31 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 18611
Репутация: 4220 ±
Замечаний: ±

Excel 2016 & Mac Excel
DrMini, сформулируйте задачу конкретнее. Вам надо посчитать часы, отработанные в субботу и воскресенье? Или как? С примером желательно


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеDrMini, сформулируйте задачу конкретнее. Вам надо посчитать часы, отработанные в субботу и воскресенье? Или как? С примером желательно

Автор - Pelena
Дата добавления - 16.02.2020 в 21:31
DrMini Дата: Понедельник, 17.02.2020, 11:11 | Сообщение № 11
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Pelena, Я
сформулируйте задачу конкретнее. С примером желательно

Я попытался "допилить" под себя Вашу формулу для УФ на пятидневку. Работает. Просто мне кажется, что формулу можно уменьшить и убрать ненужный окрас столбцов AH и AI на листе Февраль.
К сообщению приложен файл: 20200217.xlsx(37.3 Kb)
 
Ответить
СообщениеPelena, Я
сформулируйте задачу конкретнее. С примером желательно

Я попытался "допилить" под себя Вашу формулу для УФ на пятидневку. Работает. Просто мне кажется, что формулу можно уменьшить и убрать ненужный окрас столбцов AH и AI на листе Февраль.

Автор - DrMini
Дата добавления - 17.02.2020 в 11:11
Pelena Дата: Понедельник, 17.02.2020, 13:00 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 18611
Репутация: 4220 ±
Замечаний: ±

Excel 2016 & Mac Excel
Для суббот и воскресений формула гораздо проще
Код
=СУММПРОИЗВ(--(ДЕНЬНЕД($E$7:$AI$7;2)>5);E8:AI8)
К сообщению приложен файл: 6631705.xlsx(37.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеДля суббот и воскресений формула гораздо проще
Код
=СУММПРОИЗВ(--(ДЕНЬНЕД($E$7:$AI$7;2)>5);E8:AI8)

Автор - Pelena
Дата добавления - 17.02.2020 в 13:00
DrMini Дата: Понедельник, 17.02.2020, 14:16 | Сообщение № 13
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
гораздо проще

СПАСИБО БОЛЬШОЕ!
Вот этот кусочек формулы для "УФ" был очень нужен.
Код
*(E$7<>0)

А формула действительно сильно сократилась в размерах.
respect respect respect
 
Ответить
Сообщение
гораздо проще

СПАСИБО БОЛЬШОЕ!
Вот этот кусочек формулы для "УФ" был очень нужен.
Код
*(E$7<>0)

А формула действительно сильно сократилась в размерах.
respect respect respect

Автор - DrMini
Дата добавления - 17.02.2020 в 14:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт из ячеек выделенных через УФ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!