Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества дней из списка дат - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества дней из списка дат (Формулы/Formulas)
Подсчет количества дней из списка дат
fanishe Дата: Четверг, 20.02.2020, 11:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день дамы и гспода!
У меня возникла некоторая сложность с подсчетом количества текущих дней
Таблица "График" ведет начало рабочего дня(20.02.20 10:00) конец (20.02.20 22:00)
Есть таблица "отчет", которая через формулу СУММПРОИЗВ считает кол-во дней в заданном месяце

Я хочу реализовать подсчет уже отработанных дней
То есть если взять февраль, то первый рабочий день будет 3.02, а текущий день 20.02 найти в графике кол-во дней за текущий месяц от первого числа, до сегодняшнего

Пример файла прикрепил, буду рад любой помощи и за идеи
Прошу прощения за повествование, чукча не писатель, отвечу на все уточнения
К сообщению приложен файл: 7236074.xlsx(17.1 Kb)
 
Ответить
СообщениеДобрый день дамы и гспода!
У меня возникла некоторая сложность с подсчетом количества текущих дней
Таблица "График" ведет начало рабочего дня(20.02.20 10:00) конец (20.02.20 22:00)
Есть таблица "отчет", которая через формулу СУММПРОИЗВ считает кол-во дней в заданном месяце

Я хочу реализовать подсчет уже отработанных дней
То есть если взять февраль, то первый рабочий день будет 3.02, а текущий день 20.02 найти в графике кол-во дней за текущий месяц от первого числа, до сегодняшнего

Пример файла прикрепил, буду рад любой помощи и за идеи
Прошу прощения за повествование, чукча не писатель, отвечу на все уточнения

Автор - fanishe
Дата добавления - 20.02.2020 в 11:42
AlexM Дата: Четверг, 20.02.2020, 12:10 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММПРОИЗВ((--A2:A999>ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ());))*(--A2:A999<=СЕГОДНЯ()))
К сообщению приложен файл: 7236074_01.xlsx(17.2 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((--A2:A999>ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ());))*(--A2:A999<=СЕГОДНЯ()))

Автор - AlexM
Дата добавления - 20.02.2020 в 12:10
fanishe Дата: Четверг, 20.02.2020, 12:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=СУММПРОИЗВ((--A2:A999>ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ());))*(--A2:A999<=СЕГОДНЯ()))


Ухты! круто!
спасибо большое
А объясните пожалуйста на пальцах, как она считает, в чем логика этой формулы, почему там стоят знаки сравнения и двойное тире
 
Ответить
Сообщение
=СУММПРОИЗВ((--A2:A999>ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ());))*(--A2:A999<=СЕГОДНЯ()))


Ухты! круто!
спасибо большое
А объясните пожалуйста на пальцах, как она считает, в чем логика этой формулы, почему там стоят знаки сравнения и двойное тире

Автор - fanishe
Дата добавления - 20.02.2020 в 12:32
YouGreed Дата: Четверг, 20.02.2020, 12:32 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
fanishe, А мне кажется, вот так
Код
=СУММПРОИЗВ((--График!A2:A110>A2)*(--График!A2:A110<=КОНМЕСЯЦА(A2;0)+1)*(--График!A2:A110<СЕГОДНЯ()))


И счет дней, соответственно
Код
=СУММПРОИЗВ((--График!A2:A110>A2)*(--График!A2:A110<=КОНМЕСЯЦА(A2;0)+1)*(--График!A2:A110<СЕГОДНЯ())*(График!C2:C110))


Двойное тире, используется для перевода текста в значение, по сути это также как если бы Вы, ячейки умножили на единицу.
Знаки ">" и "<" используются для сравнения знач <= я поставил, как костыль, т.к. формула упорно не хотела считать 31 число, как конец месяца.
Код
СЕГОДНЯ()
собственно сравнение с текущей датой.
Сначала из массива данных, выбираются все даты большие от целевой, перемножаются на все даты менее конца месяца целевой ячейки и перемножается на даты которые меньше чем сегодня, все это безобразие суммируется.
К сообщению приложен файл: 6746453.xlsx(18.7 Kb)


Сообщение отредактировал YouGreed - Четверг, 20.02.2020, 12:46
 
Ответить
Сообщениеfanishe, А мне кажется, вот так
Код
=СУММПРОИЗВ((--График!A2:A110>A2)*(--График!A2:A110<=КОНМЕСЯЦА(A2;0)+1)*(--График!A2:A110<СЕГОДНЯ()))


И счет дней, соответственно
Код
=СУММПРОИЗВ((--График!A2:A110>A2)*(--График!A2:A110<=КОНМЕСЯЦА(A2;0)+1)*(--График!A2:A110<СЕГОДНЯ())*(График!C2:C110))


Двойное тире, используется для перевода текста в значение, по сути это также как если бы Вы, ячейки умножили на единицу.
Знаки ">" и "<" используются для сравнения знач <= я поставил, как костыль, т.к. формула упорно не хотела считать 31 число, как конец месяца.
Код
СЕГОДНЯ()
собственно сравнение с текущей датой.
Сначала из массива данных, выбираются все даты большие от целевой, перемножаются на все даты менее конца месяца целевой ячейки и перемножается на даты которые меньше чем сегодня, все это безобразие суммируется.

Автор - YouGreed
Дата добавления - 20.02.2020 в 12:32
fanishe Дата: Четверг, 20.02.2020, 12:41 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
YouGreed, Надо чтобы включало текущий день, то есть 8 дней а не 7

UPD
Интересное решение, я даже не догадывался о таких возможностях этой функции


Сообщение отредактировал fanishe - Четверг, 20.02.2020, 12:45
 
Ответить
СообщениеYouGreed, Надо чтобы включало текущий день, то есть 8 дней а не 7

UPD
Интересное решение, я даже не догадывался о таких возможностях этой функции

Автор - fanishe
Дата добавления - 20.02.2020 в 12:41
YouGreed Дата: Четверг, 20.02.2020, 12:45 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
fanishe, Добавьте после
Код
СЕГОДНЯ()
+1
 
Ответить
Сообщениеfanishe, Добавьте после
Код
СЕГОДНЯ()
+1

Автор - YouGreed
Дата добавления - 20.02.2020 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества дней из списка дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!