Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значений по двум критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений по двум критериям (Формулы/Formulas)
Вывод значений по двум критериям
Гри_ша Дата: Четверг, 20.02.2020, 12:35 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Подскажите, пожалуйста, формулу, которая находит ЗАДАЧИ, год и квартал которых равен текущему кварталу текущего года.

Пример в прикрепленном файле: Нужно вывести в столбец "ID Промежуточ.качест.результатов" все ID задач "Промежуточный качественный результат"(поле ТИП), ГОД и КВАРТАЛ которых равен ТЕКУЩЕМУ КВАРТАЛУ, ТЕКУЩЕГО ГОДА.
К сообщению приложен файл: forTest6.xlsx(11.1 Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, формулу, которая находит ЗАДАЧИ, год и квартал которых равен текущему кварталу текущего года.

Пример в прикрепленном файле: Нужно вывести в столбец "ID Промежуточ.качест.результатов" все ID задач "Промежуточный качественный результат"(поле ТИП), ГОД и КВАРТАЛ которых равен ТЕКУЩЕМУ КВАРТАЛУ, ТЕКУЩЕГО ГОДА.

Автор - Гри_ша
Дата добавления - 20.02.2020 в 12:35
YouGreed Дата: Четверг, 20.02.2020, 13:37 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
Гри_ша,
Код
=НАИМЕНЬШИЙ((ЕСЛИ((($D$2:$D$45=ГОД(СЕГОДНЯ()))*("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45)*$A$2:$A$45)<>0;($D$2:$D$45=ГОД(СЕГОДНЯ()))*("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45)*$A$2:$A$45;""));СТРОКА(A1))
Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 4487563.xlsx(12.2 Kb)


Сообщение отредактировал YouGreed - Четверг, 20.02.2020, 13:39
 
Ответить
СообщениеГри_ша,
Код
=НАИМЕНЬШИЙ((ЕСЛИ((($D$2:$D$45=ГОД(СЕГОДНЯ()))*("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45)*$A$2:$A$45)<>0;($D$2:$D$45=ГОД(СЕГОДНЯ()))*("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45)*$A$2:$A$45;""));СТРОКА(A1))
Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter

Автор - YouGreed
Дата добавления - 20.02.2020 в 13:37
Pelena Дата: Четверг, 20.02.2020, 14:06 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Ещё варианты.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$45;НАИМЕНЬШИЙ(ЕСЛИ(($D$2:$D$45=ГОД(СЕГОДНЯ()))*("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45);СТРОКА($D$2:$D$45)-1);СТРОКА(A1)));"")

обычная формула
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$45;АГРЕГАТ(15;6;$A$2:$A$45/($D$2:$D$45=ГОД(СЕГОДНЯ()))/("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45);СТРОКА(A1)));"")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЕщё варианты.
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$45;НАИМЕНЬШИЙ(ЕСЛИ(($D$2:$D$45=ГОД(СЕГОДНЯ()))*("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45);СТРОКА($D$2:$D$45)-1);СТРОКА(A1)));"")

обычная формула
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$45;АГРЕГАТ(15;6;$A$2:$A$45/($D$2:$D$45=ГОД(СЕГОДНЯ()))/("Q"&ЦЕЛОЕ((МЕСЯЦ(СЕГОДНЯ())+2)/3)=$E$2:$E$45);СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 20.02.2020 в 14:06
Гри_ша Дата: Четверг, 20.02.2020, 14:09 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
YouGreed, Pelena, Круть! Спасибо Вам!
 
Ответить
СообщениеYouGreed, Pelena, Круть! Спасибо Вам!

Автор - Гри_ша
Дата добавления - 20.02.2020 в 14:09
Гри_ша Дата: Четверг, 20.02.2020, 14:15 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А не подскажете еще.... Какой формулой найти значение(QWE-3) состоящее из букв и цифр в ячейках, в которых таких значений(RTY-4,QWE-7,QWE-3) может быть несколько...То есть мне нужны все ячейки из списка, которые имеют значение (QWE-3) в своем списке...
 
Ответить
СообщениеА не подскажете еще.... Какой формулой найти значение(QWE-3) состоящее из букв и цифр в ячейках, в которых таких значений(RTY-4,QWE-7,QWE-3) может быть несколько...То есть мне нужны все ячейки из списка, которые имеют значение (QWE-3) в своем списке...

Автор - Гри_ша
Дата добавления - 20.02.2020 в 14:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений по двум критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!