Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Уникальные значения по строкам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Уникальные значения по строкам (Формулы/Formulas)
Уникальные значения по строкам
GLR Дата: Пятница, 21.02.2020, 05:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, Уважаемые господа.
Прошу Вас помощь, как сцепить в строках из 12 значений только уникальные значения, пример во вложение.
Спасибо!!!
К сообщению приложен файл: 123468.xlsx(8.5 Kb)
 
Ответить
СообщениеДобрый день, Уважаемые господа.
Прошу Вас помощь, как сцепить в строках из 12 значений только уникальные значения, пример во вложение.
Спасибо!!!

Автор - GLR
Дата добавления - 21.02.2020 в 05:36
YouGreed Дата: Пятница, 21.02.2020, 09:41 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
Можно попробовать такую формулу
Код
=ИНДЕКС($A$2:$M$2;ПОИСКПОЗ(2;ЕСЛИ(ЕПУСТО($A$2:$M$2);"";СЧЁТЕСЛИ($A$2:$M$2;$A$2:$M$2));0))

массивна, вводится одновременным нажатием Ctrl+Shift+Enter. Выдергивает 1 значение. Нужно сцеплять это все.
 
Ответить
СообщениеМожно попробовать такую формулу
Код
=ИНДЕКС($A$2:$M$2;ПОИСКПОЗ(2;ЕСЛИ(ЕПУСТО($A$2:$M$2);"";СЧЁТЕСЛИ($A$2:$M$2;$A$2:$M$2));0))

массивна, вводится одновременным нажатием Ctrl+Shift+Enter. Выдергивает 1 значение. Нужно сцеплять это все.

Автор - YouGreed
Дата добавления - 21.02.2020 в 09:41
AlexM Дата: Пятница, 21.02.2020, 09:53 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2003
С 12-ю доп. столбцами с формулой массива
Код
=ИНДЕКС($A2:$L2;ПОИСКПОЗ(1;(СЧЁТЕСЛИ($N2:N2;$A2:$L2)=0)/($A2:$L2<>"");))
и формулы склейки
Код
=ЕСЛИ(ЕНД(O2);"";O2)&ЕСЛИ(ЕНД(P2);"";"-"&P2)&ЕСЛИ(ЕНД(Q2);"";"-"&Q2)&ЕСЛИ(ЕНД(R2);"";"-"&R2)&ЕСЛИ(ЕНД(S2);"";"-"&S2)&ЕСЛИ(ЕНД(T2);"";"-"&T2)&ЕСЛИ(ЕНД(U2);"";"-"&U2)&ЕСЛИ(ЕНД(V2);"";"-"&V2)&ЕСЛИ(ЕНД(W2);"";"-"&W2)&ЕСЛИ(ЕНД(X2);"";"-"&X2)&ЕСЛИ(ЕНД(Y2);"";"-"&Y2)&ЕСЛИ(ЕНД(Z2);"";"-"&Z2)
К сообщению приложен файл: 123468_01.xlsx(9.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 21.02.2020, 10:23
 
Ответить
СообщениеС 12-ю доп. столбцами с формулой массива
Код
=ИНДЕКС($A2:$L2;ПОИСКПОЗ(1;(СЧЁТЕСЛИ($N2:N2;$A2:$L2)=0)/($A2:$L2<>"");))
и формулы склейки
Код
=ЕСЛИ(ЕНД(O2);"";O2)&ЕСЛИ(ЕНД(P2);"";"-"&P2)&ЕСЛИ(ЕНД(Q2);"";"-"&Q2)&ЕСЛИ(ЕНД(R2);"";"-"&R2)&ЕСЛИ(ЕНД(S2);"";"-"&S2)&ЕСЛИ(ЕНД(T2);"";"-"&T2)&ЕСЛИ(ЕНД(U2);"";"-"&U2)&ЕСЛИ(ЕНД(V2);"";"-"&V2)&ЕСЛИ(ЕНД(W2);"";"-"&W2)&ЕСЛИ(ЕНД(X2);"";"-"&X2)&ЕСЛИ(ЕНД(Y2);"";"-"&Y2)&ЕСЛИ(ЕНД(Z2);"";"-"&Z2)

Автор - AlexM
Дата добавления - 21.02.2020 в 09:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Уникальные значения по строкам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!