Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выстроить в определенном порядке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выстроить в определенном порядке (Формулы/Formulas)
выстроить в определенном порядке
АЛЕКСАНДР1986 Дата: Среда, 26.02.2020, 21:08 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 169
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем добрый вечер!
не подскажите
как изменить формулу или написать новую чтобы она подтягивала не только первое найденное значение а все уникальные в соответствующем порядке
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$8:$C$13;НАИМЕНЬШИЙ(ЕСЛИ($D$8:$D$13=H$7;СТРОКА($C$8:$C$13)-7);H$7));"")
К сообщению приложен файл: 7570034.xlsx(11.0 Kb)


Сообщение отредактировал АЛЕКСАНДР1986 - Среда, 26.02.2020, 21:12
 
Ответить
СообщениеВсем добрый вечер!
не подскажите
как изменить формулу или написать новую чтобы она подтягивала не только первое найденное значение а все уникальные в соответствующем порядке
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$8:$C$13;НАИМЕНЬШИЙ(ЕСЛИ($D$8:$D$13=H$7;СТРОКА($C$8:$C$13)-7);H$7));"")

Автор - АЛЕКСАНДР1986
Дата добавления - 26.02.2020 в 21:08
Pelena Дата: Среда, 26.02.2020, 21:14 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$8:$C$13;НАИМЕНЬШИЙ(ЕСЛИ($D$8:$D$13=H$7;СТРОКА($C$8:$C$13)-7);СТРОКА(A1)));"")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$8:$C$13;НАИМЕНЬШИЙ(ЕСЛИ($D$8:$D$13=H$7;СТРОКА($C$8:$C$13)-7);СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 26.02.2020 в 21:14
Nic70y Дата: Четверг, 27.02.2020, 11:15 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
строго по файлу-примеру не массивная
Код
=ЕСЛИ(СТРОКА(H1)>СЧЁТЕСЛИ($D:$D;H$7);"";ИНДЕКС($C:$C;ПОИСКПОЗ(H$7;$D:$D;)+СТРОКА(H1)-1))
К сообщению приложен файл: 0749292.xlsx(11.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениестрого по файлу-примеру не массивная
Код
=ЕСЛИ(СТРОКА(H1)>СЧЁТЕСЛИ($D:$D;H$7);"";ИНДЕКС($C:$C;ПОИСКПОЗ(H$7;$D:$D;)+СТРОКА(H1)-1))

Автор - Nic70y
Дата добавления - 27.02.2020 в 11:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выстроить в определенном порядке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!